LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2005, 10:14 AM   #1
gcom
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
SuSe, startx monitor goes away.


I installed SuSE 9.3 on a gateway E-3400 gateway 1gig pIII, 256Mmem. All went well during the installation and everything worked well. Now that the installation is finished the system rebooted and I get the green screen that lets you boot 9.3, floppy or in failsave. Then I get the green screen initializing hardware, I esc out and see what it is really doing and the last thing I see is Starting mail services. At this point the monitor acts like it is not getting power from the graphics card. I can go to another system and ssh to the unit and login fine (I can't configre telnet yet). When I run the command reboot on the host I have ssh'ed to the SuSE box the monitor on the SuSE box comes up with the green screen and tells us the System is shutting down.

Now to go back a step, if I boot from the failsave mode I get a login prompt and all is well. I have not yet figured out how to enambe telnet with out x.

I am looking to find out what the graphics card is to see if I need a driver but if anyone knows why this is happening please let me know.

Thanks.
 
Old 10-20-2005, 07:52 PM   #2
zilvis
LQ Newbie
 
Registered: May 2005
Location: Lithuania
Distribution: Debian for ever!!!! suse for fun
Posts: 28

Rep: Reputation: 15
this is monitor problem- it doesn't resolve resolution. this problem occurred to me too, when i installed suse under one monitor, then changed it: everything goes ok until kde- monitor out, but sounds are played as it is normal boot up. you have to edit one file (i forgot which) as soon as i remember i'll let you know (1-2 days). if you need it working now- try changing monitors, also try to boot from cdrom, then after language selection and license agreement you'll be prompted to choose from list (new install and etc.) choose repair existing system, there you'll have a choice of repairing modes, choose the suitable for you.

I didn't try that but it might help by booting that failsave from boot menu. it should be like safe-mode in windows.
 
Old 10-20-2005, 08:05 PM   #3
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
If I remember correctly the POS E-3400 has a Riser card that the VC plugs into? am I right?

I am not sure how linux would handle these risers.. weird.
 
Old 10-20-2005, 08:45 PM   #4
zilvis
LQ Newbie
 
Registered: May 2005
Location: Lithuania
Distribution: Debian for ever!!!! suse for fun
Posts: 28

Rep: Reputation: 15
just found in the other thread:

>>vi /etc/X11/xorg.conf

>>go down untill u find

>> Section "Monitor"

>>make sure that HorizSync and VertRefresh values are correct.

>>or you can try find

>> Section "Screen"

>>and change Modes value to "800x600"


vi is text editor, u can use other, it is for redhat but it must work for you too, there might be placed in the other directory than in /etc/x11
HorizSync VertRefresh MUST be adjusted to your monitor's if you don't know the values try to google, you might want to change color depth too as the resolution type.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
startx shuts off my monitor Seventh_Warrior Linux - Hardware 4 09-27-2004 02:24 PM
Startx, monitor goes blank, HELP! Twitches Linux - General 2 06-17-2004 11:11 AM
monitor/mouse trouble startx centr0 Slackware - Installation 1 04-16-2004 03:07 PM
I Can't Get My Monitor To Work When I Run Startx!!!!!!!!!!! psychoninja Linux - Newbie 3 12-24-2002 06:33 PM
Monitor unreadable after startx jburtner Linux - General 1 04-21-2001 09:08 PM


All times are GMT -5. The time now is 04:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration