LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 10-12-2004, 12:10 PM   #1
blavo
LQ Newbie
 
Registered: Jun 2004
Distribution: Suse 10
Posts: 22

Rep: Reputation: 0
Suse Konsole prompt ?


I've just installed Suse Linux 9.1 and it looks great so far.

I have a question about the “konsole” prompt. I'm new to linux, but the couple of distributions I look at have a the same prompt which is different then what Suse has.

The other prompts I've seen look like [root@localhost root]$

and Suse looks like linux:~ # also the behavior of the shell doesn't act like the other systems I've seen.

Is there a simple way to configure Suse's Konsole to look and behave like other distributions?
 
Old 10-12-2004, 12:21 PM   #2
kastorff
Member
 
Registered: Feb 2004
Location: Atlanta, GA
Distribution: SuSE 9.3 Pro, Ubuntu Hoary, Vidalinux 1.1
Posts: 65

Rep: Reputation: 15
Mine looks like this in gnome terminal and konsole:
Code:
kkastorff@hpkastorff:~>
It will only look similar to your example if you are logged is as root, and your machine is named "localhost".
 
Old 10-12-2004, 12:34 PM   #3
RestInPieces
Member
 
Registered: Aug 2004
Location: In front of a CRT monitor
Distribution: Slackware-current
Posts: 108

Rep: Reputation: 15
1.what kind of "different" shell behaviour are we talking about?
2.that terminal could be meaning that you are logged in as an user.. named linux, and that you're in it's home dir...although i'm not certain
 
Old 10-12-2004, 01:19 PM   #4
niwde
LQ Newbie
 
Registered: Oct 2004
Location: Den Haag, The Netherlands
Distribution: Suse 10.0, 9.1
Posts: 12

Rep: Reputation: 0
you can make the prompt look like anything you want... just have to know how to do it. just google on the subject to find the format for it...

in the file bash.bashrc you can change it.. though you'll see in suse it will ask you to put a change like that in the bash.bashrc.local
this is what my prompt looks like for example:
PS1="\[\e[34;1m\]\u@\[\e[32;1m\]\h\[\e[0m\]\w>\[\e[32;1m\] \$> \[\e[0m\]"

gives -->

niwde@sputnik~> $>

with user niwde on host sputnik, unfortunately it's fancy colours dont show in asci :P

good luck!
 
Old 10-12-2004, 02:11 PM   #5
RossB
Novell Adv. Tech. Training Engineer
 
Registered: Jul 2004
Distribution: SUSE 9.3 Pro/Whoppix/SLES
Posts: 46

Rep: Reputation: 15
The prompt is completely configurable, the documentation is easy to find:

$ man bash
(while in bash man page, type: /^prompting)

Read the section, and then look at your prompt to see what's similar.

I usually set it to read:

export PS1="[\u@\h \W]\\$"

This gives me a prompt that looks like:

[root@linux root] #

The first \u means the currently logged on user, the \h means the hostname and the \W means the base directory I am currently in, such as the /usr/local/bin/someapp directory would show a prompt that read:

[root@linux someapp] #

Beware of "JC Whitney Syndrome" with your prompt, it's there to inform you and help you get things done, don't put too many fuzzy dice, curb feelers and blue license plate lights on it, or you'll not get anything substantial done...

Ross
 
Old 10-13-2004, 05:12 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,689

Rep: Reputation: Disabled
For readable documentation see also http://www.dreaming.org/~giles/bashprompt/
 
Old 10-13-2004, 06:01 AM   #7
OhMyAchingGut
Member
 
Registered: May 2004
Location: Ohio
Distribution: Slackware-current/10.1/10.0, Splack 10, Suse 9.2, NetBSD 2.0, OpenBSD 3.6, Solaris 8
Posts: 85

Rep: Reputation: 15
SuSE seems to default to naming a machine "linux" which is what that prompt was...the machine, not the user. the "#" signifies that you are logged in as root, and you should ABSOLUTELY NOT RUN X AS ROOT. It looks like you're new and don't know better, so just take that as a friendly reminder...running as root is bad, you should only do it in rare instances when it is needed, such as installing new programs, or running a tool such as ethereal or kismet which needs to be run with those privileges. Even in those cases, it is better to use "su" to become superuser than to login to anything directly as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no konsole prompt in mandrake 9.1 bcf2 Linux - Newbie 4 08-06-2009 12:13 AM
Konsole prompt drguitarum2005 Linux - Newbie 1 02-21-2005 02:57 AM
How to configure Konsole bash prompt? lasindi Linux - Software 6 01-16-2005 06:38 PM
no prompt in Konsole or su in KDE on compiled 2.6.8.1 martinp26 Linux - General 19 09-21-2004 09:21 AM
Konsole prompt/commands UB_KMA Linux - Newbie 4 07-12-2002 01:31 PM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration