LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 04-11-2006, 10:18 AM   #1
nuro305
Member
 
Registered: Mar 2004
Location: New Mexico
Distribution: FC4, SuSE 9.3 Pro, SuSE 10.1, SLED 10 SDK
Posts: 128

Rep: Reputation: 15
SuSE 9.3 - USB Disapeared & Non-Root users can't shutdown system


Yes,
I read the post about the USB disk disapearing and how to mount it in FSTAB, however I have not upgraded from 9.3 Pro (only do on-line updates) I need to figure out what just changed...

I want the Plugger to auto-mount with a desktop icon like it used to. (i can see the USB disk is detected and looks OK in /var/log/messages)

Also, suddenly my normal user account does NOT have permission to shutdown the system!? I get prompted for roots password...

Have I cranked up some security setting (I do fool around in YAST) or did a recent Kernal update do this to my system ????

Any thoughts are appreciated!

Last edited by nuro305; 04-11-2006 at 12:15 PM.
 
Old 04-11-2006, 02:03 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
For your second problem, have a look at

KDE Control Center -> System Administration -> Login Manager -> Shutdown

and see if local shutdown is set to "Everybody". You need to switch to "Administrator Mode" to change the setting.

For the USB problem, check if suseplugger is running (ps ax | grep suseplugger) and if any setting in ~/.kde/share/config/susepluggerrc prevents the disk from mounting. BTW: did the disk really disappear or is just the icon missing? Does the drive appear in /media ?
 
Old 04-11-2006, 05:15 PM   #3
nuro305
Member
 
Registered: Mar 2004
Location: New Mexico
Distribution: FC4, SuSE 9.3 Pro, SuSE 10.1, SLED 10 SDK
Posts: 128

Original Poster
Rep: Reputation: 15
COol,

#1 KDE Control Center -> System Administration -> Login Manager -> Shutdown Was indeed the problem.... no idea what late night I messed with THAT one ;-O

#2 The Plugger is there but I can't understand this output:

Output of your command:
7079 ? S 0:11 suseplugger [kdeinit] suseplugger -caption SUSE Hardware Tool -icon hi22-action-hardware.png -miniicon hi22-action-hardware.png --quiet

Additionally: The command of ps -ef | grep 'automountd' returns:
myusername 10361 10352 0 14:03 pts/1 00:00:00 grep automountd

Seems like it's there but I can't tell if it's running.

I went into YAST/System/Services and found an autofs service and it was NOT running. When I tried to start it I got:
/etc/init.d/autofs start returned 6 (program is not configured):
Starting service automounter ("files nis" does not provide any mounts)..skipped

The drive NO LONGER appears in /media.

I'm now having to mount USB's and my CD manually with the mount command. So, I'm still wondering why/how I managed to turn Automount off?

Keeping in mind, this system has been mounting and working flawlessly for a year...

Additional thoughts are much appreciated!

Last edited by nuro305; 04-11-2006 at 05:16 PM.
 
Old 04-12-2006, 04:47 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I hope I am giving you correct information here, since I never used 9.3. But the automated mounting is done by subfs/submount in SUSE. What automountd does, I can't tell, but I don't think it's required for this process.

The output of your ps commands show clearly that suseplugger is up and running while automountd is not (what appears is just the grep command).

Did you make any changes in /etc/fstab, which could preven the automatic mounting?

Also check /etc/sysconfig/hotplug, if subfs is still set to be used for mounting.

Did you install a custom kernel, which may not have subfs compiled?
 
Old 04-12-2006, 03:31 PM   #5
nuro305
Member
 
Registered: Mar 2004
Location: New Mexico
Distribution: FC4, SuSE 9.3 Pro, SuSE 10.1, SLED 10 SDK
Posts: 128

Original Poster
Rep: Reputation: 15
Thanks for the continued help...

"Did you make any changes in /etc/fstab, which could preven the automatic mounting?" PZ: No, I also checked another SuSE workstation that's still working and the files are the same, even though both the CD & the USBFS are marked "noauto" I tried to change them to "auto" with no change noted.

"Also check /etc/sysconfig/hotplug, if subfs is still set to be used for mounting." PZ: Don't see any reference to subfs in that file. I cranked up the Logging and I'm looking into that.

"Did you install a custom kernel, which may not have subfs compiled?"
PZ: Nope, just YAST updates to the Kernel. I still think that's what did this.

This is the first time i'm getting frustrated with SuSE. I'm not crazy, USB devices automounting and CD automounting ALWAYS worked on this system! Now I'm reading about people complaining about no automounting and tutorials from Novell on how to do it!?!? (like this: http://www.novell.com/coolsolutions/feature/11637.html) Note: I CAN see the device with "lsusb" and in SuSE's Hardware Tool. It's just not mounted anywhere...

If anyone can tell me HOW this great feature has been lost, I'll be eternally gratefull !!!!!!!!!!!!!!

PS: SuSE 10.1 will be out at the end of the month with KDE 3.5.1 and I'm gonna waste a day and start over and see what that does for me. I'm NEVER GOING BACK TO WINDOWS!
 
Old 04-13-2006, 12:23 PM   #6
nuro305
Member
 
Registered: Mar 2004
Location: New Mexico
Distribution: FC4, SuSE 9.3 Pro, SuSE 10.1, SLED 10 SDK
Posts: 128

Original Poster
Rep: Reputation: 15
Additional Info.

I checked another SuSE 9.3 workstation at home and the /etc/fstab files are exactly the same, and the other system still automatically mounts the same USB drive and CD's.

I noticed on the working machine with the 'top' command running that 'suseplugger' jumps in and mounts the USB drive.

I do have suseplugger installed and running on the machine in question. It seems to be corrupted or something though...

Any thoughts on how to fix or reinstall it?

THX.
 
Old 04-13-2006, 12:44 PM   #7
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
What about the configuration files of suseplugger (~/.kde/share/config/susepluggerrc and /opt/kde3/share/config/susepluggerrc)? You could try to delete the one in your homedirectory (make a backup) and see if the default setting will detect the USB drive. If this doesn't help, could you please post the output of dmesg after you inserted the drive (just the last few lines, wait a few seconds for the device to be detected)?
 
Old 04-14-2006, 12:22 PM   #8
nuro305
Member
 
Registered: Mar 2004
Location: New Mexico
Distribution: FC4, SuSE 9.3 Pro, SuSE 10.1, SLED 10 SDK
Posts: 128

Original Poster
Rep: Reputation: 15
Good Thoughts, I tried deleting the local user susepluggerrc file and even replacing it with parts of one from a working machine, to no avail, aslo with the system wide one. Additionally the CD still won't auto-mount any longer and only ROOT can mount it.

Here's the dmesg output from my USB, it's definately being detected:

Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
Vendor: JetFlash Model: TS2GJF2A Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 4014000 512-byte hdwr sectors (2055 MB)
sda: Write Protect is off
sda: Mode Sense: 0b 00 00 08
sda: assuming drive cache: write through
SCSI device sda: 4014000 512-byte hdwr sectors (2055 MB)
sda: Write Protect is off
sda: Mode Sense: 0b 00 00 08
sda: assuming drive cache: write through
sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
usb-storage: device scan complete


Thanks!
Paul
 
Old 04-14-2006, 12:39 PM   #9
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
You probably don't want to hear this, but you can still mount through /etc/fstab. Together with a desctop icon, this is not even less comfortable than automatic mounting. And it works!

Just add '/dev/sda1 /media/usbdisk vfat users,umask=000 0 0' to /etc/fstab and create a link to this mountpoint on the desktop. Once the device is connected (and I guess you don't need to be notified about this fact), you canaccess it through that icon. Very simple!
 
Old 04-14-2006, 03:27 PM   #10
nuro305
Member
 
Registered: Mar 2004
Location: New Mexico
Distribution: FC4, SuSE 9.3 Pro, SuSE 10.1, SLED 10 SDK
Posts: 128

Original Poster
Rep: Reputation: 15
Yup,
I'll be doing that (that does work no problemo)

Like most of us I just want to know exactly how things work and why and it's pissin' me off that I don't know what I did or how to fix it!

Oh Well..... Thanks for the support ! The support I get in this forum is better than most support my company PAYS for! I try and give back when ever I can answer someone's question.

Thanks,
Paul
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown problem system halted suse 10.0 stork Suse/Novell 16 11-16-2005 08:56 PM
RHEL3 Mounting USB after reboot and between reboots: root and non-root users Luis Nunes Linux - Hardware 0 07-20-2005 09:32 AM
Allowing users to shutdown the system LinuxSeeker Linux - General 3 11-11-2004 10:18 AM
Whats the difference between all the crontabs (system, root, users) ? glenn69 Linux - Newbie 2 10-12-2004 08:41 PM
allowing non-root users to mount drives and shutdown rlpt Slackware 3 09-21-2002 07:35 PM


All times are GMT -5. The time now is 12:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration