LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 04-21-2005, 09:54 PM   #1
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Rep: Reputation: 0
Suse 9.3 and Network Cards


Hello all. I'm new to this whole Linux world, so bare with me. You might have to walk me through a lot details to get what you're looking for.

I just did an install of Suse 9.3 (dual boot with a fresh install of Winblows XP SP2) and am having a heck of a time trying to get them to work in Suse. I know that both cards (described below) work when I boot into XP just fine.

Onboard :
Micro-Star International RTL-8139/8139C/8139C+

PCI :
D-Link DGE-530T

What commands and outputs should I post to aid in my troubles? Thanks.

-glassman324
 
Old 04-21-2005, 10:31 PM   #2
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
Actually, let me go ahead and post what I know is needed for someone to help me out.

As root I ran ifconfig and route. Here is what each displayed.

ifconfig outputs:

eth0
Link encap:Ethernet HWaddr 00:0C:76:A1:62:F1
inet addr:192.168.13.38 Bcast:192.168.13.255 Mask:255.255.255.0
inet6 addr: fe80::20c:76ff:fea1:62f1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:309 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:94691 (92.4 Kb) TX bytes:3518 (3.4 Kb)
Interrupt:10 Base address:0x4000

eth1
Link encap:Ethernet HWaddr 00:0F:3D:F3:78:8B
inet addr:192.168.13.37 Bcast:192.168.13.255 Mask:255.255.255.0
inet6 addr: fe80::20f:3dff:fef3:788b/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Memory:ed000000-0

lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:96 errors:0 dropped:0 overruns:0 frame:0
TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7116 (6.9 Kb) TX bytes:7116 (6.9 Kb)


route outputs (formatted it so it looked neater):

Kernel IP routing table
Destination.....Gateway.........Genmask.........Flags.Metric.Ref....Use...Iface
192.168.13.0....*...............255.255.255.0...U.....0......0......0.....eth1
192.168.13.0....*...............255.255.255.0...U.....0......0......0.....eth0
link-local......*...............255.255.0.0.....U.....0......0......0.....eth1
loopback........*...............255.0.0.0.......U.....0......0......0.....lo
default.........192.168.13.1....0.0.0.0.........UG....0......0......0.....eth1
 
Old 04-22-2005, 12:40 PM   #3
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
Would it possibly be a good idea to re-install Suse 9.3 without the D-Link PCI NIC installed? Or is that just my Windows counter-part talking?
 
Old 04-22-2005, 05:03 PM   #4
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
You don't say what your problem is. It looks like eth1 is working and it is your default. Which one has YaST configured?
 
Old 04-22-2005, 06:03 PM   #5
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
I feel like a complete n00b, asking for help and not even stating the problem, lol. I simply cannot connect to the Internet. I have tried to ping the router that I am under and I get no responses. Same thing happens when I attempt to ping another computer under the router.

I believe that what I need now is a how-to on setting up a ethernet connection. I have changed so many settings X amount of times that I have no clue what to do anymore.

Some information on my home network:
Internet provided by Cable Company (Charter Communiactions) and uses a Motorola Surfboard Modem.
Modem connects directly to the back of my D-Link (DI-524) Wireless Router.
Then there are a few switches beyond that point but I'm hardlined into the Router, with the link engaged. Right now I am using my D-Link Gigabit NIC (not the onboard) to connect to the Router. Inside the router I have assigned the DHCP for that card's MAC address to 192.168.13.37 (leet obviously). The router's IP address is set to 192.168.13.1.

YaST, I believe, had configured the D-Link NIC because when I logged into the Network Card Configuration, for the first time, the D-Link was in the bottom list, Already Configured Devices. The onboard still needed to be configured. I'm not really too worried about the onboard one though. I need the speed of the D-Link Gigabit when using my Gigabit Switches.
 
Old 04-22-2005, 07:20 PM   #6
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
You can try this from the command line as root:

ifconfig eth1 up

rcnetwork restart

If you ping your router with 192.168.13.1 what happens?
 
Old 04-22-2005, 07:58 PM   #7
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
OK. I pinged 192.168.13.1 (the router) and had the output of:

From 192.168.13.38: icmp_seq=1 Destination Host Unreachable
From 192.168.13.38: icmp_seq=2 Destination Host Unreachable
......

Wait a second though.... .13.38? So I plugged the hardline into my onboard and I can connect to the Internet just fine. How does that work and what exactly did the commands just do?

Also, any clue on how to 'default' to the D-Link Gigabit? I would much rather use it. Thanks a bunch already!
 
Old 04-22-2005, 11:59 PM   #8
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
OK. Well I just restarted my computer (new in the back of my mind this would happen) and could not reconnect to the Internet with neither the onboard nor PCI NIC. I could however ping the Router after performing the EXACT steps metioned by pilotgi above with my onboard (which is eth0).

Something has to be royally screwed up somewhere I think. Anyone else have any thoughts or ideas? Thanks again pilotgi for the response earlier.
 
Old 04-23-2005, 09:58 AM   #9
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
I'm going to re-install Suse 9.3. I'll get back to everyone with my succes or stress. Thanks a bunch everyone!
 
Old 04-25-2005, 12:09 AM   #10
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
So how did it go?
 
Old 04-26-2005, 10:08 PM   #11
glassman324
LQ Newbie
 
Registered: Apr 2005
Location: Illinois, USA
Distribution: Suse 9.3
Posts: 11

Original Poster
Rep: Reputation: 0
Well it went ok I guess. I'm still not entirely sure how i got it to work, but I can tell you all the commands that I found that helped me setup and default to Gigabit card.

ifstatus - helped a lot in determining the status of a eth0 and eth1
ifup - helped to bring the network card online
ifdown - helped to bring the network down
route - helped in viewing the active connections and setting up the routing table in the kernel

I think what I basically did was the following (eth0 is the Onboard and eth1 is the PCI Gigabit):
ifstatus to see that the Gigabit was even seen
ifdown eth0 to disable the Onboard
ifup eth1 to bring on the Gigabit
route to check to see if I had a Destination for eth1 (which I didn't, which I believe is where the problem was to begin with)
route add default gw 192.168.13.1 to setup the Gateway for my computer to talk to the Internet
route (again) to check that everything was setup right
took the cable out of my Onboard and plugged it into the Gigabit and the Internet worked
restarted the computer and it seems to be defaulting to my Gigabit card now

I am still unsure if this was the correct way to do it in Linux. But I know one thing, Suse didn't like it, :-). Moving on to bigger things now, getting my ATI Radeon 9200 PCI Vid card to work. That's going to hurt. Any advice or a link to a page would be great.
 
Old 04-27-2005, 12:44 AM   #12
jess1975
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Suse 11.1
Posts: 87

Rep: Reputation: 15
I have a problem with my network cards to:

A boot up, it sees both. Next time I boot up it sees one.

?????

Really annoying
 
Old 05-27-2005, 10:05 AM   #13
box299
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
How did you get the DGE-530T driver?

For Glassman...

How did you get a driver for the DGE-530T... I just put one into an existing 9.3 machine and it does not see it.

Where did the driver come from?
 
Old 05-27-2005, 11:23 AM   #14
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Quote:
default.........192.168.13.1....0.0.0.0.........UG....0......0......0.....eth1
means that your gateway is 192.168.13.1


Quote:
eth0
Link encap:Ethernet HWaddr 00:0C:76:A1:62:F1
inet addr:192.168.13.38 Bcast:192.168.13.255 Mask:255.255.255.0
inet6 addr: fe80::20c:76ff:fea1:62f1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:309 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:94691 (92.4 Kb) TX bytes:3518 (3.4 Kb) <-------
Interrupt:10 Base address:0x4000
means that eth0 (not eth1) is working




Quote:
OK. I pinged 192.168.13.1 (the router) and had the output of:
From 192.168.13.38: icmp_seq=1 Destination Host Unreachable
From 192.168.13.38: icmp_seq=2 Destination Host Unreachable
means that you have misconfigured network. So leave SuSE 9.3 and check your network configuration
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 - How is determined which network cards becomes eth0 and which eth1 doublemax Linux - Networking 5 02-04-2005 10:25 AM
two network cards - one for local network, one for http/vsftpd server scottster Linux - Networking 1 01-20-2005 08:52 PM
Finding network cards compatible with SuSE 9.2 TrulyTessa Suse/Novell 6 01-20-2005 01:59 PM
network cards dhcp and suse 8.2 spjsm Linux - Hardware 2 05-29-2003 09:33 AM
network cards dhcp and suse 8.2 spjsm Linux - Networking 0 05-28-2003 09:22 AM


All times are GMT -5. The time now is 01:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration