LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2005, 05:20 PM   #1
t2dreamer
Member
 
Registered: May 2005
Distribution: fc3/RHE/SUSE9.3
Posts: 57

Rep: Reputation: 15
SUSE 9.3 AMD64 reduce fan speed, cool'n quiet


Hi,

I have just installed SUSE 9.3 (64bit version) on an AMD64 with Asus A8N-E mother board. All works fine but the fan is running at full speed all the time. How can I make the SUSE control the fan speed (and thus reduce it when the machine is running idle) or use the cool'n quiet option that the bios does seem to support?

Thanks for any input!
 
Old 05-30-2005, 07:57 PM   #2
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
cool'n quiet will slow down CPU to 50%. Only when compiling CPU will run at full speed. So if you have 1.8GHz it will run at 900MHz.
I never knew how it works, sometimes fan speed is controlled (0 at temp 30C and full speed at 39C), recently however fan runs at full speed even CPU temp is 32C. It does not bother me that much because it is guiet.
 
Old 05-31-2005, 02:15 AM   #3
t2dreamer
Member
 
Registered: May 2005
Distribution: fc3/RHE/SUSE9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Thanks for your response. Mine is not that quiet (if you have any tips on quiet fans I'm all ear!) and I really want to find a way to bring down the noise level! I know the hardware should support that but I just don't know how to make it work with SUSE 9.3!
 
Old 06-01-2005, 09:19 PM   #4
snakedriver
Member
 
Registered: Nov 2003
Location: North East Arkansas
Distribution: Suse 9.2 x86-64
Posts: 59

Rep: Reputation: 15
You need to turn on cool'n'quite in your bios. Suse will pick that up and then you can control/adjust it.
If you can't turn it on in your bios, then you are out of luck -- as I am.
 
Old 06-02-2005, 02:30 AM   #5
t2dreamer
Member
 
Registered: May 2005
Distribution: fc3/RHE/SUSE9.3
Posts: 57

Original Poster
Rep: Reputation: 15
I have indeed turned it on in my bios! Maybe SUSE even picks it up, it's just that my computer is NOT quiet. So either the name is misleading (and I had my hopes up for nothing) or SUSE is not picking it up (how do I check this?). Anyway, the main issue is the noise level (my fan runs like crazy always), cool'n quiet was just something I ran across in my bios settings and the name insinuates that it could do some good. Any other tips for change of hardware/software/bios/settings are very welcome!!
 
Old 06-02-2005, 06:36 AM   #6
snakedriver
Member
 
Registered: Nov 2003
Location: North East Arkansas
Distribution: Suse 9.2 x86-64
Posts: 59

Rep: Reputation: 15
Start here:
http://www-uxsup.csx.cam.ac.uk/pub/d...nage.acpi.html

go to Yast, system, powermanagement & set it up. It's all a function of how hard you are driving your CPU Use acoustic, throtling, etc = mess around

look at each with: cd to /proc/whatever then cat /proc/whatever.
to change them:
learn the echo command in the same chapter: echo /proc/whatever=something as root.
or in Yast:
System, /etc/sysconfig editor, but first read the book.

Have fun
 
Old 06-02-2005, 07:43 AM   #7
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
With cool'nquite enabled your CPU will run with half of the speed as I explained earlier.
 
Old 06-03-2005, 02:49 AM   #8
t2dreamer
Member
 
Registered: May 2005
Distribution: fc3/RHE/SUSE9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Thanks for the advise! I had already been playing with the SUSE settings but this had no effect. Yesterday I finally decided to have another look at the hardware configuration. I found that the noise is really due to the chassis fans (not the CPU or chipset fans). The reason that they do not slow down was that they were connected to the wrong power plugs on the motherboard (not the ones that are controlled by Q-Fan (ASUS)). Changing that has helped a little (the ASUS motherboard had only one Q-FAN controlled plug for the chassis fans so now I am running with a single chassis fan instead of 2 which probably gave most of the noise reduction) and the noise level is down to an acceptable one. It is still not the way I like it but I don't suppose there is much room for improvement left. At least I am not waking up the neighbours anymore when I am working late!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU Fan Speed rcracer7 Linux - Hardware 7 10-25-2005 01:20 AM
howto: control CPU fan speed and Northbridge fan speed? hedpe Linux - Software 2 04-18-2005 03:18 AM
audio playback over speed on Envy24 chipset soundcard. SuSE 9.1 AMD64 Fartwiz Linux - Hardware 8 12-26-2004 02:41 AM
pb win fan speed stefdef Mandriva 4 11-20-2004 08:14 PM
reduce speed of cdrom Santas Linux - Hardware 0 12-12-2003 01:57 PM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration