LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Suse 9.3 AMD 4400+ Dual Core installation APIC kernel panic (http://www.linuxquestions.org/questions/suse-novell-60/suse-9-3-amd-4400-dual-core-installation-apic-kernel-panic-360147/)

lostowl 09-04-2005 03:04 PM

Suse 9.3 AMD 4400+ Dual Core installation APIC kernel panic
 
I am still trying to find a way to make my AMD dual core 64 bit processor work in smp mode in 64 bits. It works in 32 bits. But on generic install, 64 bits, smp, it crashes on boot with an APIC kernel panic.

If I add the noapic line to the boot options, it will boot, but only one CPU registers in the ksysguard.

Can someone tell me:

1) Why the dual core 32 bit APIC works but not the dual core 64 bits

2) Is this something that can be resolved through a kernel patch or is this a BIOS problem (no guesses, please, I need to know who to pay for support).

3) Are their any other boot options that will make this work in dual core 64 bits?

Thanks. For the record:
Shuttle SN95G5V3
nForce3-250 chipset
2GB ram
nVidia 9800 PCI
2 SATA drives

walmartshopper 09-04-2005 05:07 PM

Well I don't know if this will solve your problem, but I had a different, but related, problem with my dual core and this solved it. There's an official Athlon64 Powernow driver from AMD through their website, but it's also included in the kernel starting with 2.6.13. If you do make menuconfig, it's Power management options > CPU frequency scaling > AMD Opteron/Athlon64 PowerNow!. Try compiling 2.6.13 with this driver included, and see what happens.

lostowl 09-05-2005 01:33 PM

That driver is included as a Module in the kernel that ships with Suse. which is 2.6.11

Is it good enough to leave as a module or should I recompile with it added into the kernel?

Also, do you think the 2.6.11 is good enough or should I get the latest? I tried the latest kernel a while ago, but I don't remember checking the power now setting.

Thanks for the suggest, but it still doesn't work. Please give me your opinion on the above questions.

walmartshopper 09-06-2005 06:55 AM

Here's from the powernow driver readme:

Version 1.50.xx of the driver can use either the
PSB table of the ACPI objects. It supports Opteron,
Athlon 64 processors, in both single and dual core
versions, for all of the 754, 939, 940, and 1207
pin packages. This driver supports SMP frequency
management but will not work on SMP or dual core
systems unless the ACPI powerstate objects are
available. It will only work on 2.6.10 and later
kernels. This driver is distributed with the
2.6.13 and later kernels.

The one that shipped with Suse might be an older version. I'm not sure if it makes any difference whether it's a module or built in. I'd suggest trying the 2.6.13 kernel and building the driver into it. If that doesn't work, I don't know what else to tell you. But it's definitely worth a try in my opinion.

lostowl 09-06-2005 02:01 PM

Hmm. Like I said, the Powernow is already there as a loadable module. I wonder what the ACPI powerstate objects are....

yarddog7-5 12-20-2006 10:53 AM

lost owl dual core problem
 
:confused: i am having same problem with dual core

:confused: Why the dual core 32 bit APIC works but not the dual core 64 bits

have you found a remendy yet ,,plz post a reply with fix if you found one thx i'll watch your original post to see if you found fix...thx :)

gerhardbartsch 12-27-2006 08:22 AM

Did anyone every figure out the solution to this issue...

...I'm seeing the same problem with multiple Linux distros and my dual core Opteron 285. (NForce 4 Pro chipset)


All times are GMT -5. The time now is 10:36 AM.