LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 12-20-2004, 08:43 PM   #1
malcontent
LQ Newbie
 
Registered: Dec 2004
Posts: 3

Rep: Reputation: 0
SUSE 9.2, Wifi doesn't work, after kernel update


After installing 9.2 Pro, and, much to my surprise, my DLink DWL-G520 worked right out of the box.

I have recently updated the kernel to the latest version on YAST, and now, my wireless card does not work. I have uninstalled it, and reinstalled it. It is correctly identified, and is set up just like before.

The onboard LAN is not configured, only the wireless card, no WEP or WPA at this time.

Any assistance anyone could provide would be greatly appreciated.

Thanks!
 
Old 12-20-2004, 10:40 PM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
My guess would be that the module your wifi card needs just hasn't been loaded. You can manually load it by running
Code:
modprobe xyz
where "xyz" is the actual module name. If you happen to have the output from running the lsmod command under the previous kernel and compare it to the output from running lsmod now, it should be relatively straightforward to determine any differences.

Note that this is just a guess, there could be other reasons for it, but this is what I'd check first. Good luck with it -- J.W.
 
Old 12-21-2004, 09:46 AM   #3
malcontent
LQ Newbie
 
Registered: Dec 2004
Posts: 3

Original Poster
Rep: Reputation: 0
After downloading and installing the kernel update, it tells me, if using LILO, to run /sbin/lilo before restarting. Even though I am running GRUB, I tried that as well, and it did not work.

After getting a response back from SUSE support telling me that wifi support is not included in the 90 day support, and that they would be happy to help me for only $40, which is 2/3rds of what I paid for the retail box, I reinstalled, updating all except the kernel. Somewhat disappointed with SUSE for them taking this position..

So, I will continue to run the un-updated kernel until I can figure this out!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get wifi card to work with SUSE 9.3 bmims Linux - Wireless Networking 5 06-01-2005 12:46 PM
after online update my SUSE 9.1 doesn't work properly cccc Linux - Distributions 0 01-30-2005 05:47 PM
Suse 9.1 Nvidia update --KDETV doesn't work 1kyle Suse/Novell 0 10-31-2004 03:58 AM
Trouble getting built in Wifi to work with Suse 9.1 (HP laptop) mello Linux - Wireless Networking 1 09-14-2004 02:24 PM
Cannot get SUSE v8 yast to work because of a security update Tazzmanian Linux - Software 1 08-15-2004 03:07 AM


All times are GMT -5. The time now is 08:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration