LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-21-2005, 01:41 PM   #1
longtex
Member
 
Registered: Aug 2004
Location: Texhuahua
Distribution: RedHat 6,7,9,EL; SuSE 9.2 Pro, Knoppix 3.4/.7/.9, Fedora Core 4
Posts: 87

Rep: Reputation: 15
SuSE 9.2 Pro: How to force -default install?


I have several computers with SuSE 9.2 Pro installed. All show OS as kernel 2.6.8-24-default.

On a new Dell POS system, SuSE installs as 2.6.8-24-smp instead. This system has a touchscreen on it, and it requires a driver from 3M (there is a "mutouch" driver included in SuSE, but it's for an older model 3M and doesn't work properly - no calibration software and horizontal motion is reversed), which will only install on 2.6.8-24-default system - their rpm has a pre-install script that specifically checks for the designation 2.6.8-24-default and since it doesn't find it, won't install.

I installed the driver on one of the other systems that does show as -default, and putting the touchscreen on that computer, it works fine.

I tried to fool the install by replacing uname with a script that reported the -default, and it seemed to go okay, although I had to manually move some files from xxx-default directories to xxx-smp ones.

But the driver doesn't run (it reports "invalid driver format"), so obviously there is some different code in the -smp installation.

3M tech support says the -smp version is for "symmetric multiple processors" and there is no way their driver will run on multi-processor machines.

The Dell POS box is NOT a multi-processor machine, and I have no idea why SuSE thinks it is and installs the version it does. Possibly the SATA drive, or perhaps the Broadcom gigabit NIC? Whatever...

What I want to do is try to FORCE an installation as -default and see if it runs the hdd and nic okay... and then try the 3M driver.

Anyone know how to force -default?
 
Old 07-21-2005, 01:57 PM   #2
dbogdan
Member
 
Registered: Feb 2005
Location: Metro Detroit, US
Distribution: Suse/Slackware/Mepis
Posts: 174

Rep: Reputation: 30
Have you tried disabling hyperthreading in the BIOS ?
 
Old 07-21-2005, 05:06 PM   #3
longtex
Member
 
Registered: Aug 2004
Location: Texhuahua
Distribution: RedHat 6,7,9,EL; SuSE 9.2 Pro, Knoppix 3.4/.7/.9, Fedora Core 4
Posts: 87

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by dbogdan
Have you tried disabling hyperthreading in the BIOS ?
Noooo. The system's in a box right now, ready to travel to client's warehouse. I'll see what's in the BIOS - I didn't actually notice hyper-threading when I changed it to boot from the DVD for installing Linux, but I'll look - thanks for the idea!
 
Old 07-23-2005, 11:30 AM   #4
longtex
Member
 
Registered: Aug 2004
Location: Texhuahua
Distribution: RedHat 6,7,9,EL; SuSE 9.2 Pro, Knoppix 3.4/.7/.9, Fedora Core 4
Posts: 87

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by longtex
Noooo. The system's in a box right now, ready to travel to client's warehouse. I'll see what's in the BIOS - I didn't actually notice hyper-threading when I changed it to boot from the DVD for installing Linux, but I'll look - thanks for the idea!
Okay, I looked at the BIOS, and hyper-threading is NOT enabled, so that's not it. I looked at all the hardware settings, and see nothing out of the ordinary.
 
Old 07-23-2005, 11:44 AM   #5
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Did you try to install the default kernel?
http://portal.suse.com/sdb/en/2004/0...nelswitch.html
 
Old 07-23-2005, 01:38 PM   #6
longtex
Member
 
Registered: Aug 2004
Location: Texhuahua
Distribution: RedHat 6,7,9,EL; SuSE 9.2 Pro, Knoppix 3.4/.7/.9, Fedora Core 4
Posts: 87

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by abisko00
Did you try to install the default kernel?
http://portal.suse.com/sdb/en/2004/0...nelswitch.html
That's what I was looking for... I've been using RedHat for some time, not used to YAST yet!

Looks like it'll work once I get rid of the -smp stuff...

******************

Yep - that was the magic. No doubt it was documented somewhere, but danged if I could find it... I'm sure I looked right past the kernels part a half-dozen times.

Thanks!!

Last edited by longtex; 07-23-2005 at 02:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Force Debian 3.1 mysql default using utf8_general_ci explorer1979 Debian 1 11-01-2005 07:36 AM
Suse 9.2 Pro Install TheGr81 Suse/Novell 6 03-30-2005 08:56 PM
default lirc support with SUSE 9.2 pro lixy Linux - Software 0 01-22-2005 09:00 AM
Need assistance installing MS Sidewinder Force Feedback Pro in Debian/KDE cast55 Linux - Hardware 1 12-03-2004 10:34 AM
Problems Partitioning XP Pro to install Suse 9.1 Pro spcmiller Linux - Newbie 1 07-27-2004 11:08 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration