LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-19-2004, 03:53 PM   #1
nanofa
LQ Newbie
 
Registered: May 2004
Posts: 11

Rep: Reputation: 0
Suse 9.2 default route wifi


Hello, I have just buy a Suse 9.2 linux OS and I find a problem with my wireless connection

I have a internal ethernet card and a pcmcia wireless card.

Both of them obtain their IP Addresses from a DHCP server but when I configure the wireless one (eth1) I receive properly the IP but the default route that I wrote doesn't appear when I type "route" command. So I have to type

route add -net 0.0.0.0 ....

everyday which is what bothers me :-(

Could you help me?

I have seen a similar thread and the best solution provided there for me I think that was the use of SCPM but I do not know how to completely disable the wired card :-(
Also I would like to see if anybody else could solve this problem using other "automatic" way :-)

Thank you very much
JAF
nanofa
 
Old 12-20-2004, 08:15 AM   #2
casperghst42
Novell Technical Support Engineer
 
Registered: Oct 2004
Location: The Netherlands
Distribution: SuSE
Posts: 18

Rep: Reputation: 0
The only reason why this could happen, is that you might have another network card which is trying to get an ipaddress. Only the first instance of the dhcp client will update the routing tables.

Try to do a ifdown eth1, ifdown <wireless card>, ifup <wireless card>. You could set all the network cards to start manually and the do an ifup ... everytime you boot, or you could use 'profile' to handle it; see Yast2....

Regards/Casper
 
Old 01-05-2005, 09:58 PM   #3
troublefunk
LQ Newbie
 
Registered: Jan 2005
Location: Alexandria, VA
Distribution: Suse 9.1
Posts: 4

Rep: Reputation: 0
DUDE!!! You just saved me HOURS of frustration. Thank you. This is an issue that many folks have been experiencing when trying to configure wireless nics with suse. My laptop has the builtin nic and the wireless card and the builtin nic always initializes first, leaving the wireless dead in the water so to speak. So now, I should be able to just disable the onboard nic so the wireless initializes and gets the routing tables updated or figure out a way to switch the order in which they initialize. Thanks again man.

Off to spread the word to others who were having problems...

t-funk


Quote:
Originally posted by casperghst42
The only reason why this could happen, is that you might have another network card which is trying to get an ipaddress. Only the first instance of the dhcp client will update the routing tables.

Try to do a ifdown eth1, ifdown <wireless card>, ifup <wireless card>. You could set all the network cards to start manually and the do an ifup ... everytime you boot, or you could use 'profile' to handle it; see Yast2....

Regards/Casper
 
Old 01-08-2005, 08:45 PM   #4
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Rep: Reputation: 30
HA!

amazing... yes saved me the very same problem. TY TY.
let me hunt down all those other posts where people are having problems with the same issue... i've seen 3 or 4 in the last couple days...

thx again, gw (good work)

-pres

ps i'm quite impressed with 9.2! keep up the gw
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse ifdown default route is removed? simand Linux - Networking 1 10-19-2005 09:51 AM
two default route - help me fabiolpi Linux - Networking 2 07-06-2005 06:35 AM
Route to subnet exists but I get "Network unreachable" when adding default route fciuffani Linux - Networking 4 08-18-2004 02:11 PM
how do you set up your Linux box to route secure wifi? richard3403 Linux - Wireless Networking 0 11-15-2003 02:40 PM
Route dialup modem packets back through dialup instead of default route cable modem jogress Linux - Networking 1 10-21-2003 03:48 PM


All times are GMT -5. The time now is 05:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration