LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 11-20-2004, 05:25 PM   #1
fight_the_$oft
LQ Newbie
 
Registered: Sep 2004
Location: Logan, UT
Distribution: Suse Linux 9.1 Professional
Posts: 3

Rep: Reputation: 0
Suse 9.1 Pro problems with yast installing rpms


I'm new to Linux and KDE but I really want this to work.

I have downloaded various rpms like firefox, alsa 1.0.6 and samba but none of them will install when yast opens. I get a message that says I have a conflict in my samba program. The vscan needs a certain package, etc. I click on ignore and remove because I don't use samba yet (I still don't have sound) and yast doesn't do anything. I have tried to install the newest samba rpm but it won't work. Do I have to compile the samba source code to get the package dependencies correct or is there an easier way. I read somewhere that I had to change my source of installation in yast but that doesn't work either. Every time I try to install alsa from the rpm it asks for the dvd so I disabled that source and added my home directory but that obviously doesn't help.

Thanks for any help you can give.

Daniel

Dell Optiplex GX270
P4 3.2GHz
1GB SDRAM
Suse 9.1 Pro/WinXP
Sound Blaster Live! Dell
Nvidia GeForce 5200
if you need more please ask
 
Old 11-20-2004, 05:47 PM   #2
Harryc
Member
 
Registered: Dec 2002
Location: New York, USA
Distribution: OpenSUSE 10.0
Posts: 220

Rep: Reputation: 32
What is the exact dependancy error?
 
Old 11-20-2004, 06:55 PM   #3
fight_the_$oft
LQ Newbie
 
Registered: Sep 2004
Location: Logan, UT
Distribution: Suse Linux 9.1 Professional
Posts: 3

Original Poster
Rep: Reputation: 0
i think i installed a different version of samba that vscan couldn't use. anyway, i rolled it back to the old version 3.0.2 and samba is fine but when i try to install the newer samba or alsa rpms yast just reinstalls the version that i already have. i set up the suse ftp site as an install source, i don't know what else to do. if this is a suse problem i'll gladly try fedora core3. i just want a linux that does what i want. like play sound!

daniel
 
Old 11-20-2004, 07:05 PM   #4
kt_leohart
Member
 
Registered: Aug 2004
Location: Earth
Distribution: Switched back to good old SuSE 9.1 :D
Posts: 30

Rep: Reputation: 15
Oh my god, same here same here. My sound worked fine at first, but then my love for Firefox took over and I decided to fetch the latest firefox package from ftp.suse.com.

However, when I tried to use Yast to install this rpm, for some reason, Yast does NOT install this version but keep installing the 0.8 version which came with the DVD . Before installation, it says: there is a dependency conflict with samba.vscan and that I can either roll samba back to a previous version or don't install firefox at all.

Of course, you know that I chose to roll back but after that the sound does not work anymore *NOOOO*, Firefox (only with online update did I get it to 0.9.3 -> but that is not enough)

I just wish that SuSE made a better effort with their rpm and ftp server, it is not even in the default online update mirror list. I used to this that Yast is number 1 but with this hmm.
 
Old 11-20-2004, 11:01 PM   #5
kt_leohart
Member
 
Registered: Aug 2004
Location: Earth
Distribution: Switched back to good old SuSE 9.1 :D
Posts: 30

Rep: Reputation: 15
Okay, I found out at this
the solution to this problem. I simply go to Control Center and then disable arts. (Type arts in search and uncheck the first check-box.

To my satisfaction, the sound system just wakes up and works like a charm. Thanks again LQ.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
In SuSE 9.1, YaST installs old RPMs kshaffer Suse/Novell 2 11-22-2004 07:49 PM
problems with RPMs and yast mannis Suse/Novell 6 10-22-2004 01:27 PM
Installing S/W from DVD using YaST (Suse 9.1 Pro) xian67 Linux - Distributions 1 07-30-2004 05:02 PM
Problems installing RPMs in suse linux 9.0 jginger Linux - Newbie 3 07-27-2004 04:13 PM
SuSE 9.1 -- Installing RPMs in YaST MrFubar Linux - Software 9 05-30-2004 04:46 PM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration