LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2005, 05:52 PM   #1
shadow126
LQ Newbie
 
Registered: Feb 2005
Location: UK
Distribution: SuSE 9.1 Pro
Posts: 4

Rep: Reputation: 0
Suse 9.1 Pro boot problem...


Hi,

I was wondering if someone could shed a little light on a boot problem i'm having. I have recently installed SuSE 9.1 Pro and was searching checking out the system when I noticed that the DMA settings where lower than I expected.

I adjusted the DMA settings with YAST, changing from DMA 66 to UDMA 100, which I knew my HD was capable of. Everything seemed fine until I rebooted the machine and now it will not boot.

When booting there are a load of errors, after Linux has been selected in GRUB. These errors are along the lines of:

/sbin/mingetty: /sbin/mingetty: cannot execute binary file
and
INIT: Id "X" respawning too fast: disabled for 5 minutes
then finally
INIT: no more processes left in run level

Looking for a solution on the web provided an idea to use the install DVD to try and repair the previous installation, I had hoped this would reset the changes I had made, but this didn't work.

Choosing Failsafe in GRUB produces the same errors.

The system is a dual boot Win 2K/SuSE 9.1 Pro machine, and Win 2K still boots fine. But I don't care about anything on the Win 2K partition. There is however some data on Suse that I would like to save preferably.

Is there anyway of fixing the problem, and if not how can I back up the data from SuSE without being able to boot? I have space on another computer on my network, a Win XP Pro machine. Is there a way I could reinstall Suse and leave the data intact? Or could I use the live SuSE to copy the files I want to the Win XP machine over the network? I would just try this but I don't want to corrupt the data an would like someone more knowledgeable than myself to reassure me that I won't lose everything.

I have been enjoying SuSE up until now but this has thrown a bit of a spanner in the works!

I am quite new to linux and would appreciate any help you can offer.

Thanks in advance

Ben
 
Old 02-17-2005, 06:53 PM   #2
Cabletalk
LQ Newbie
 
Registered: Feb 2005
Location: Netherlands
Posts: 6

Rep: Reputation: 0
Hello,

You could try it with the Suse pro dvd and then select automatic repair. That works fine with me when i have a problem like that. When this doesn't work you can try the live cd, but i don't have any experience with that, so i'm not sure.
When these two options don't work you can perform a upgrade installation, this will leave your data as it is.
Maybe there are some other options in text mode, but i don't know any right now.

Good luck!
 
Old 02-17-2005, 07:20 PM   #3
shadow126
LQ Newbie
 
Registered: Feb 2005
Location: UK
Distribution: SuSE 9.1 Pro
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for you response Cabletalk, unfortunately I've already tried the automatic repair which stopped booting in the same way as the original problem.

I've just tried the live cd, after reading that it definately wouldn't do anything to the data, but unfortunately this has failed to boot too. This time the error messages are different, a series of errors is produced:

cloop: Read and -3 uncompressing block errors
buffer I/O error device cloop0 errors
finally ending in
Kernal Panic: attempting to kill init!

If anyone can tell me how to get a direct copy of these errors that would be helpful too, i.e. where and how can I get to the logs which would store these errors.

Thanks for clearing things up about the upgrade installation too. On a side point could I upgrade to 9.2 Pro at the same time? I have a downloaded copy of this now.


Ben
 
Old 02-18-2005, 08:38 AM   #4
Cabletalk
LQ Newbie
 
Registered: Feb 2005
Location: Netherlands
Posts: 6

Rep: Reputation: 0
Hi,

Sorry to hear this didn't work. How far does it boot with the cd/dvd? If the boot sequence in the bios is set right you should be able to boot from cd/dvd without problems.
It makes no difference for your data if you make an upgrade to 9.1 or 9.2. It will leave your data untouched.
 
Old 02-18-2005, 10:38 AM   #5
shadow126
LQ Newbie
 
Registered: Feb 2005
Location: UK
Distribution: SuSE 9.1 Pro
Posts: 4

Original Poster
Rep: Reputation: 0
I'm a unsure as to which method of booting you were refering to.

With the Live CD: the problems seem to start occuring when it tries to mount the root partition. There are three partitions, as far as i can make out Win 2K, Swap and root. From what i've read the live cd tries to mount all exisiting partions as read only. Please correct me if i'm wrong about this. This is where it stops and just freezes up.

I also tried the Update Installation, this seemed to be going okay untill the following error appeared:

Root Device: /dev/hda3 (mounted oin/as reiserfs)
Module list: reiserfs

Kernal image: /boot/vmlinuz-2.6.57-145-default
Initrd image: /boot/initrd-2.6.57-145-default

Can't create lock file /etc/mtab~2748: input/output error

Then after I hit okay on this dialog box, another error cam up:

can't read pwd for user id 0

Then it frooze.

Thinking that a corrupted root partition could be the source of the problem I tried the installation repair again. The installation repair got further this time and told me that the root partition and filesystem had been corrupted. These were repaired okay, except that the repairs don't seem permanent. Next errors in the boot loader were detected, I'm working on this at the moment. I'll keep updating here untill I get a solution.

Ben
 
Old 02-18-2005, 11:36 AM   #6
shadow126
LQ Newbie
 
Registered: Feb 2005
Location: UK
Distribution: SuSE 9.1 Pro
Posts: 4

Original Poster
Rep: Reputation: 0
Been working on reinstalling the boot loader, using methods found on this and other forums as well as the net. When I try to install the bootloader it keeps freezing up whilst saving the new bootloader. I've tried a number of ways that i have found but all have failled in the same way. With no explanation, that I can see, as to why the boot loader won't reinstall (i.e. no error messages) i'm quite stuck.

I'd really like to hear from someone whom can offer some advice about how to fix/reinstall the bootloader, since the methods I have found haven't worked. I'd also like to know if i'm on the right lines to fixing the problem or if anyone can help me understand what i've done wrong. Please, if you can help in anyway with this I would really appreciate it.

If I don't get any other suggestions, I'm gona try and tackle this from a different angle. I have a spare hard disk (actually identical to this one). I was going to use it for something else, but figure I can install Win2K and SuSE on to it as before, then using the new hard drive and working SuSE, get access to my data by trying mounting the corrupted partitions. I'd appreciate any suggestions about the purposed solutions and if there are any gapping flaws in them.

Ben
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSe 9l.2 Pro Boot Problem d-kam Linux - Newbie 5 03-11-2005 06:43 AM
boot problem: NFS mounts before name server, SUSE 9.2 Pro bho Linux - Networking 0 02-07-2005 11:01 AM
Grub boot problem with Suse 9.2 Pro Steerpike Suse/Novell 12 12-19-2004 08:00 PM
Duel Boot,XP Pro+Suse 9.1 pro wont work. jonny.k Linux - Laptop and Netbook 6 11-28-2004 07:37 AM
Suse 9.0 pro won't boot :( Disketnik Suse/Novell 1 11-01-2004 10:56 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration