LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2005, 08:53 PM   #1
Kamex
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 9.3 Professional
Posts: 38

Rep: Reputation: 15
SuSE 9.1 - Can't hear any music, other sound works


When I try to play a CD with KSCD, it plays, but there's no sound. This is a bit odd, because the sound is perfect in all of the games, as well as system sounds. It says Volume 40% when playing, so the volume is apperently adjusted to the point where I should at least hear it quiet, but turning up my speakers to the max gives no result.

I noticed that other programs like Zinf aren't playing any music either. Could someone help?
 
Old 02-24-2005, 09:21 PM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
That just usually has to do with the way your CD drive is wired. There are a lot of applications that are not quite as finicky as KSCD. The one that I can recall immediately is the totem application, but there are others.

Try installing/running totem and see if you can then hear your CD.
 
Old 02-25-2005, 08:49 AM   #3
33_hertz
LQ Newbie
 
Registered: Oct 2004
Location: U.K.
Distribution: SUSE 9.2 +9.3Pro
Posts: 20

Rep: Reputation: 0
Click on extras in KsCD's panel. Put a check in ' Use direct digital playback. Click Apply. Click OK. Now the sound should be heard.
 
Old 02-25-2005, 08:52 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
http://portal.suse.com/sdb/en/2001/0...lay_kabel.html
 
Old 02-25-2005, 09:57 AM   #5
Kamex
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 9.3 Professional
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by 33_hertz
Click on extras in KsCD's panel. Put a check in ' Use direct digital playback. Click Apply. Click OK. Now the sound should be heard.
I can't find "Use direct digital playback" in the extras button. Where exactly is it?
 
Old 02-25-2005, 10:02 AM   #6
33_hertz
LQ Newbie
 
Registered: Oct 2004
Location: U.K.
Distribution: SUSE 9.2 +9.3Pro
Posts: 20

Rep: Reputation: 0
Click on Configure - KsCD. Under CD-Rom Device you'll see 'Use direct digital playback.
 
Old 02-25-2005, 12:30 PM   #7
Kamex
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 9.3 Professional
Posts: 38

Original Poster
Rep: Reputation: 15
I found it now, but it's grayed out (which is probably why I didn't spot it earlier). Why would it be grayed out?

Last edited by Kamex; 02-25-2005 at 12:32 PM.
 
Old 02-25-2005, 12:43 PM   #8
33_hertz
LQ Newbie
 
Registered: Oct 2004
Location: U.K.
Distribution: SUSE 9.2 +9.3Pro
Posts: 20

Rep: Reputation: 0
I honestly don't know why yours would be grayed out. Hmmmm.
I upgraded my 9.2 the other day and that's when I couldn't get a CD to play. Someone suggested ticking the digital playback box and I was up and running again.
Possibly someone else here can shed some light on this.
 
Old 02-25-2005, 01:23 PM   #9
33_hertz
LQ Newbie
 
Registered: Oct 2004
Location: U.K.
Distribution: SUSE 9.2 +9.3Pro
Posts: 20

Rep: Reputation: 0
I'm on 9.2 and using KDE 3.3 so my system is more up to date than yours possibly. If you don't want to upgrade to KDE 3.3 then you'll have to install the audio cable from the CD-ROM to the mainboard.
 
Old 02-25-2005, 04:14 PM   #10
Kamex
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 9.3 Professional
Posts: 38

Original Poster
Rep: Reputation: 15
I'll add the cable then. I'll let you know how it turns out. I don't want to upgrade KDE for fear of messing up my stable setup.
 
Old 02-25-2005, 04:52 PM   #11
33_hertz
LQ Newbie
 
Registered: Oct 2004
Location: U.K.
Distribution: SUSE 9.2 +9.3Pro
Posts: 20

Rep: Reputation: 0
That's understandable. Yes, let us know if the cable works ok.
 
Old 02-25-2005, 05:48 PM   #12
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
If you have any trouble with the cable, I was able to determine that the totem application I mentioned earlier will play your CD's without that additional hardware. It is a part of your base SuSE install CD contents and is available for install in YaST.
 
Old 02-25-2005, 09:02 PM   #13
Kamex
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 9.3 Professional
Posts: 38

Original Poster
Rep: Reputation: 15
I tried to TotemPlayer, and yes, it did indeed work great! Thank you for your advice.

One more thing, is there a way to rip CDs in Linux? I don't disribute them or anything, it's just for personal use.
 
Old 02-26-2005, 06:14 PM   #14
youngtom
Member
 
Registered: Feb 2005
Location: Rio de Janerio
Distribution: suse 9.1, suse 9.2, redhat enterprise, ubuntu, kubuntu
Posts: 104

Rep: Reputation: 15
Do you have 2 sound cards? ie 1 on the motherboard and an external soundcard then you want to make sure that the one in the bios is turned off

http://www.linuxquestions.org/questi...hreadid=293921
 
Old 02-26-2005, 06:29 PM   #15
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
Quote:
Originally posted by youngtom
Do you have 2 sound cards? ie 1 on the motherboard and an external soundcard then you want to make sure that the one in the bios is turned off
This event would happen to anyone who does not have the specific hardwiring that KSCD requires.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UT can barely hear music. TheJkWhoSaysNi Linux - Games 2 04-04-2005 02:42 AM
sound card configured. can hear testsound. cant hear cd's tdr_nj Red Hat 2 04-19-2004 10:36 PM
SoundBlaster Audigy..ALSA drivers... mic works but cant hear any sound. punk Linux - Newbie 1 03-25-2004 07:29 PM
I can hear music from a CD, but nothing else.... ttaylor Linux - General 1 08-06-2001 01:31 AM
Can't hear music off of cd-rom fantomlord Linux - Newbie 5 07-06-2001 05:33 PM


All times are GMT -5. The time now is 06:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration