LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 01-11-2006, 12:09 PM   #1
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
SUSE 10 won't allow me to use GRUB as a bootloader


If I use YaST to setup GRUB as a bootloader, it will allow me to select all the options I want. However, when I click on Finish, it just gets stuck on the 2nd of the list of processes to complete and gets stuck on 50%. I have waited for as long as 30 minutes for it to complete but I eventually had to kill the process. LILO on the other hand takes less than 30 seconds to complete the whole process.

Is it likely that GRUB would work if I install from the command line?
 
Old 01-11-2006, 01:10 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Is the grub rpm installed?

And yes, it works from command line as well. See:http://portal.suse.com/sdb/en/2002/0..._overview.html
 
Old 01-11-2006, 01:43 PM   #3
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Yeh the rpm is installed.

[edit] I notice that YOU is installing a GRUB patch as I type. Hopefully that will fix it.

Last edited by Jongi; 01-11-2006 at 01:49 PM.
 
Old 01-12-2006, 03:20 AM   #4
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Well that didn't fix it at all.
 
Old 01-12-2006, 01:55 PM   #5
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
In fact I re-installed and tried to setup GRUB. However I got a grub 17 error when SUSE reboots after completing the 1st disk install.
 
Old 01-13-2006, 02:14 AM   #6
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
So I did a re-install last night.

1. The bootloader I was using before the re-install was LILO (SUSE on hdc1 and the bootloader on the MBR of had).
2. As stated in the post above, I chose GRUB as the bootloader during the install process.
3. When it reboots after the install of Disc 1, I got a GRUB Loading error 17.
4. I then booted the installed system (SUSE 10) from the DVD to continue the install process. That finished without a further hitch.
5. Once install completed, I tried to reinstall GRUB as a bootloader both from the Repair section when loading from the DVD and from the Bootloader section in YaST. Interestingly both times it would complete and not hang at the 50% mark.
6. I then decided to load the XP Recovery Console of the XP disk and run fixmbr.
7. XP loaded without problems after that.
8. So I got frustrated by GRUB at this stage and installed LILO from the repair option (I now wish I had installed GRUB at this point to see what would have happened). LILO installed without hassle and I was able to boot into SUSE from the LILO boot menu.
9. I then ran YOU and patched the kernel amongst other things. I then thought let me try and see what happens when I try install GRUB after having run fixmbr. The process got stuck at the 50% mark.
10. So this got me wondering whether this is something to do with the kernel patch?

What I will do this evening is run fixmbr of the XP Recovery Console again. And this time I will try and install GRUB from the repair section and see what happens.
 
Old 01-13-2006, 02:25 PM   #7
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Well tried the last bit and still got a Grub Loading error 17.

I noticed that when I run mkinitrd and I run /sbin/lilo, the following appears:

Code:
The boot sector and map file are on different disks.
Might this have anything to do with the problem?
 
Old 01-18-2006, 03:53 AM   #8
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Interestingly, I installed a second Linux distro and it's GRUB worked.
 
Old 01-18-2006, 04:03 AM   #9
randrake
Member
 
Registered: Mar 2004
Location: P.E.I. Canada
Distribution: Any nix or other OS I can get my hands on!
Posts: 156

Rep: Reputation: 30
Same thing on my machine.
 
Old 01-18-2006, 05:45 AM   #10
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Would using map (hd0) (hd2) work? [XP on hda(1) and SUSE being on hdc(1)]

Or changing the bootorder in the BIOS to boot from HDD-2 and then installing GRUB on hdc?
 
Old 02-15-2006, 03:13 AM   #11
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
no unless you have 3 drives....see my tut for how to trick MS with the map command but its
map (hd0) ....space....(hd1)
map (hd1) (hd0)

2) there is nothing stopping you having bios boot order changed so that you use mbr drive 0 to go to its mbr and then changing to drive 1 and its mbr on a reboot....not sure that is more efficient but can be used for trouble shooting if all else fails

3) your lilo report I can not be exact as donīt use it but is suggests that when you installed grub or lilo that you put it in the PARTITION and not into the MBR otherwise lilo can not complain about boot sector.....

roughly speaking bios boots to a drive...then to its mbr then because it is too tiny (512 bytes) it jumps to the balance of its booting files....this is true of ntldr.exe and grub and me thinks lilo
 
Old 02-15-2006, 09:12 AM   #12
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Well, based on some recent experience myself... somehow when I changed the drive order even after a reinstall things show up one way druing install, another upon boot. In theory the lineup should match up evenly and cleanly, both based on boot order like this:

/dev/hda = hd0
/dev/hdb = hd1
/dev/sda = hd2

Now in my case I had something more like this because of my boot order and having two SATA drives, one of which I want as the main drive:

/dev/sda = hd0
/dev/sdb = hd1
/dev/hda = hd2

But, due to a weird thing, after I installed SuSE, gentoo, and a few other things to test around waiting for the release of SuSE 10.1 the booting was a little odd and would sometimes freeze on a reiserfs drive if my main drive wasn't set first in the boot order. I wanted my boot order to match after I did a little hardware swap(changed the SATA drives physically to SATA 0 and 1, I swapped them). I figured no big deal.

Somehow now, on Kubuntu, SuSE, and Gentoo, the boot order doesnt' match up quite right during the grub thing, with during install. During install it sees how it used to be. But upon rebooting, it sees the new proper ordering:
/dev/sdb
/dev/sda
/dev/hda

This causes an Error, and thus I have change that from the grub console to match the new hd0, hd1, and hd2.(used to be hd2, is now hd0) Go figure.
 
Old 02-16-2006, 06:43 AM   #13
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
Redshirt thanks for your experience....if raided (hardware raided) grub should see the 2 raided as one drive so if you have 3 real drives it should only be hd0 and hd1.

its can be different if you use software raid and if you get a chance to see a number of motherboards say they are have in built raid but are really just software ....there is a good post at gentoo on this HYBRID raid.....yet again us mugs are tricked by the manufacturers....so I hope you have a true hardware raid card.

you may want to see if you mobo manual offers alternative raid setups in case that solves your issue....being now a cynical old man me thinks you have a hybrid raid and I have been known to be wrong heh heh
 
Old 02-17-2006, 07:47 AM   #14
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
The problem was resolved by changing the Acces Mode in the BIOS from Auto to Large. The drive is a 250GB so I am guessing having left that on Auto was causing some problem. It's probably time to update my BIOS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub bootloader johnny_00 Linux - Software 5 10-14-2005 05:17 PM
How can I disable the grub bootloader and enable the lilo bootloader? abefroman Linux - General 1 08-06-2005 09:53 AM
GRUB bootloader spits out "GRUB hard disk error" Crampedson Linux - Software 2 01-26-2005 07:34 PM
help booting windows on Suse 8.2 Grub bootloader intenseprod Linux - Newbie 1 07-27-2003 11:35 PM
Grub bootloader - Help!! TheChos3n1 Linux - Newbie 2 06-11-2003 03:51 PM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration