LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-26-2006, 01:51 PM   #1
btberlin
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
Suse 10.2 CIFS permissions problem


I have just upgraded Suse 10.0 to 10.2
10.2 uses CIFS, and SMBF seems to be deprecated.
Our networked Linux file server runs Samba. When I mount a Samba share that has restricted permissions, the share has a "lock" icon visible in Konqueror. the same share was perfectly accessible with my same credentials in /etc/fstab with Suse 10.0. Using the same credentials in 10.2 however, I cannot access the restricted shares. The shares are mounted OK though. All other shares which do not have the same permission restrictions, work fine, and I can read, write and execute in those.

Any ideas as to how to solve this would be greatly appreciated.

The /etc/fstab entry looks like this:

//192.168.1.9/** /home/bert-berlin/** cifs rw,username=*******,password=******,file_mode=0777,dir_mode=0777,uid=1000,gid=100

bert
 
Old 12-27-2006, 07:02 AM   #2
Shaddy
Member
 
Registered: Apr 2003
Location: Germany
Distribution: PC1: Xandros 4 Prof, PC2: Debian Sarge, NB: SLED10+Windows XP
Posts: 39

Rep: Reputation: 15
Hi,

it's not clear for me why you give arguments like "file_mode" and "dir_mode". These options should be set on server side in /etc/samba/smb.conf

Dis you check the file system permissions? I had often the problem I could not access a samba share, configured by samba a thousand times, and the local directory and file permissions were not set propper.

Greets

Shaddy


P.S. Why did you give your password as argument in fstab? That is very unsafe :-) I think there a better solutions where you can write a hash of your password to an external file, which can be named at mount time. Look at smbpasswd
 
Old 12-28-2006, 09:25 AM   #3
btberlin
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Original Poster
Rep: Reputation: 0
noperm option fixes permissions check problem in Suse 10.2

Just to close this - I added the option noperm to the entry in fstab, such as . . . rw,noperm,etc
and removed unnecessary part,e.g. file_mode=0777,dir_mode=0777,uid=1000,gid=100 0 0

The line now reads:
//192.168.1.9/it /home/bert-berlin/it cifs rw,noperm,username=bert-berlin,password=****

Since I am not concerned about theft of my password on our Company network, there is no reason to use Shaddy's suggestion for protecting the password.

The addition of noperm seems to prevent the Suse client from doing unnecessary permissions check (which fails). The server side remains unchanged (it is properly managed by an IT specialist).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cifs "mount error 13 = Permission denied" CIFS SUCKS humbletech99 Linux - Networking 40 10-31-2012 08:50 AM
problem for cifs access suezo Linux - Networking 0 05-19-2006 02:55 PM
Fedora 5 mount.cifs showing incorrect permissions Peter Gordon Linux - Software 0 04-18-2006 01:15 AM
scanner permissions [suse 10] problem david@linuxquestions Linux - Software 2 11-05-2005 02:23 AM
CIFS Mounting Problem victorhe Linux - Networking 0 03-29-2004 12:49 PM


All times are GMT -5. The time now is 06:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration