LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 01-18-2007, 08:29 PM   #1
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,016

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Unhappy SuSE 10.2. Can't establish connection with my wireless router


Hi all, I'm using an Edimax EW-7128g wireless card to connect to my router (an advantek networks router). The wireless card uses the Ralink rt2500 driver (Suse detects it perfectly). I can connect fine from Ubuntu Dapper, Ubuntu Edgy and Elive (using network-admin) and winXP, but on SuSE 10.2 I set all the necessary values in Yast, but it can't connect whether using ifup or NetworkManager (I managed to establish the connection a couple of times with NetworkManager but after that, I haven't been able to connect). I'm using a WEP key (64 bits) (yes, I know it's a very weak encryption type but it's how I've managed to connect from all the other distros I have installed on my HD ). The weird thing is that after I set all the proper values on Yast to connect to my router, when I run iwconfig I get this:

Code:
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wmaster0  IEEE 802.11g  Frequency:2.412 GHz  
          RTS thr:off   Fragment thr=2346 B   
          
wlan0     IEEE 802.11g  ESSID:"MYESSID"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          RTS thr:off   Fragment thr=2346 B   
          Encryption key:off
As you can see, there seems to be two wireless interfaces (wlan0 and wmaster0), even if I'm using only one wireless card; and wlan0 (the 'right' interface) shows 'Encryption key: off', so I guess there must be something wrong with the configuration. Does someone know how to establish the connection with my router using a wep key and set SuSE to connect on boot (for example, which files should I edit, etc)??

Thanks in advance.
 
Old 01-18-2007, 09:09 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
At first glance, it seems to me that there may be two competing kernel modules that are enabled. A google search for wmaster0 showed this however:
Quote:
Suse 10.2 contains a faulty release of the rt61 driver. Just follow this link to ft2x00.serialmonkey.com go to downloads download Rt2x00 driver after downloading it tar -zxvf rt2x00-cvs-daily.tar.gz the file cd into the new directory and type make and after that finishes type make install. Reboot the system and you should be all set the latest release works great.
However, not having your card, I don't know if any of this is correct.
Did you configure the card in YaST? On the bottom of the network devices config page, there are advanced config options. Clicking on the hardware options, make sure that the correct name is entered for the kernel module name. Starting and stoping an interface in SuSE, try using "sudo /sudo/rcnetwork <device> <start|stop|restart>" instead. Sometimes the best way to fix a problem is to remove the device from the yast devices list, and then add it again and reconfigure it fully. That should clear out the old /etc/sysconfig/network/ifcfg-<device> file and create a new one.
(I've used this approach in windows as well.)

Something else to try is to run "sudo /usr/sbin/iwlist scan". If one of the two devices shows a scan of local APs, that is probably the one that works and see if the other one needs to be blacklisted. Or maybe simply removing the /etc/sysconfig/network/ifcfg-<device> could prevent two device configurations from interfering.

Back to the YaST configuration, after the device edits, pressing next gets you to the encryption setup page. This information ends up in the /etc/sysconfig/network/ifcfg-<device> script, which is used to set variables used by the rcnetwork script and its call of the ifup script.

Hope this helps some. Good Luck!

Last edited by jschiwal; 01-18-2007 at 09:12 PM.
 
Old 01-19-2007, 09:50 AM   #3
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,016

Original Poster
Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Talking

Hi jschiwal, thanks a lot for your answer; you've saved me from giving up to SuSE!! . I used the latest beta driver from serialmonkey and it finally worked!! However, I noticed something: I used the guide in your link and this guide ; the second guide said I had to manually add the card in yast, specifying the module name (rt2500), however, I tried and I tried and it didn't work. I finally decided to use the card listed in Yast (the Ralink rt2500 card) checked the hardware details options and the module name was 'rt2500' (before installing the driver it was 'rt2500pci'), so I guessed Suse was automatically detecting the card with the new driver (I had previously uninstalled the package that provides the driver for my wireless card (wlan-kmp-*)); configured my card and it worked like a charm.

Thanks again for your help!!
 
Old 02-17-2007, 09:55 AM   #4
garthkh
LQ Newbie
 
Registered: Feb 2007
Posts: 13

Rep: Reputation: 0
I have read your installation with interest and have been trying to install my Ralink USB wireless adapter on my laptop without success. I'm running Suse 10.2. The USB adapter is a Canyon product and in MSWindows it loads saying its a RT73 device. I can't find such a device at Ralink so assume its part of the rt2500 drivers.
I have downloaded the rt2x00 from your message and followed your unzip and make procedures. I get past the unzip and I cant run the make command.

This is what I get:

garthlaptop:/home/garth/Ralink/rt2x00-cvs-2007021706 # make
Makefile:62: /lib/modules/2.6.18.2-34-default/build/.config: No such file or directory
make: *** No rule to make target `/lib/modules/2.6.18.2-34-default/build/.config'. Stop.
garthlaptop:/home/garth/Ralink/rt2x00-cvs-2007021706 #

I have made huge strides to get Suse working at home and in the office but there are still many frustrating things when installing stuff.

Hope you guys can help.
 
Old 02-17-2007, 11:42 AM   #5
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,016

Original Poster
Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Hi garthkh. First, since you're using a rt73 device, I'd suggest you to get the propper driver: http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz, since the rt2x00 is experimental and doesn't seem to be done for your usb adapter. Second, open yast, look for 'rt73' and delete the package that provides the driver (it worked in my case because SuSE 10.2 came with a rt2500 faulty driver). Third, follow this guide and/or this other one (they're pretty much the same); basically, what you have to do is to install the kernel-source, gcc and make packages, then execute the following commands as root:

Code:
cd /usr/src/linux
make mrproper
make cloneconfig
make modules_prepare
This will probably solve your problem with the .config file not found on "/lib/modules/2.6.18.2-34-default/build/".

After you're donde with this, install the rt73 driver from my link above (read the README and INSTALL files for detailed information on how to install it). Then open Yast and configure the card. That's all, you should not have problems, I guess.

Regards.
 
Old 02-18-2007, 03:13 PM   #6
garthkh
LQ Newbie
 
Registered: Feb 2007
Posts: 13

Rep: Reputation: 0
Thanks for the info. I have followed the instructions and the rt73 driver has loaded as it should. I used YAST to set up the device but nothing is working yet. Not even the LED on the USB device flashes. If I unplug the device my laptop freezes and I have to do a power off to to reboot.
I have done the ifconfig and no ra0 is shown. Here are my ifconfig and iwconfig listings below - something is still not right.

garthlaptop:/home/garth # ifconfig
eth0 Link encap:Ethernet HWaddr 00:0F:B0:62:E6:1D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:209 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:59 errors:0 dropped:0 overruns:0 frame:0
TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5221 (5.0 Kb) TX bytes:5221 (5.0 Kb)

garthlaptop:/home/garth # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

wmaster0 IEEE 802.11g Frequency:2.412 GHz
RTS thrff Fragment thr=2346 B

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
RTS thrff Fragment thr=2346 B
Encryption keyff

garthlaptop:/home/garth #
 
Old 02-18-2007, 06:35 PM   #7
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,016

Original Poster
Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
I'm not sure, but there seems to be two wireless extensions when you invoke iwconfig: wmaster0 and wlan0 (that's the problem I had when I started this thread). On my SuSE installation, after uninstalling the rt2500 driver that came with SuSE and installing the rt2500 driver from serialmonkey, I only get wlan0 when I execute iwconfig (no ra0; Suse names the interface as wlan0). Try the following: Open yast, then go to 'Software>Install/Uninstall software', then on the search field look for the keyword 'wireless'; there you'll see several wlan-kmp-* packages; the one that is showed as installed must be the package that contains the Suse default driver for your card; uninstall it and configure your card again... I guess there must be some type of conflict between the SuSE driver and the driver from serialmonkey. NOTE: you'll probably have to reinstall the driver from serialmonkey after you delete the driver that comes with SuSE.
 
Old 02-22-2007, 10:00 AM   #8
garthkh
LQ Newbie
 
Registered: Feb 2007
Posts: 13

Rep: Reputation: 0
Okay. I've taken out the wlan-kmp-default using YAST software update. I'm left with
atmel-firmware
ipw-firmware
openvpn
wireless-tools

I re-ran the make and make install
I re-edited the RT73 settings in YAST Network Devices
(What I found here now is that this editing now jumps over the set-up screen for the wireless security, which it didn't do when the wlan-kmp-default was still in.
Here is the listings of the make etc and the ifconfig and iwconfig.
As you can see I now have a rausb0 entry
There is still no flicker from the LED on the USB dongle to say that it's trying to transmit or receive.
I hope this is taking us somewhere. I've sent you all I can think of.
Garth

==============

make -C ../../../linux-2.6.18.2-34 O=../linux-2.6.18.2-34-obj/i386/default modules_install
INSTALL /home/garth/Ralinkdriver/rt73-cvs-2007021811/Module/rt73.ko
DEPMOD 2.6.18.2-34-default
make[1]: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/i386/default'
/sbin/depmod -a
garthlaptop:/home/garth/Ralinkdriver/rt73-cvs-2007021811/Module #

=============================================

garthlaptop:/home/garth/Ralinkdriver/rt73-cvs-2007021811/Module # ifconfig
eth0 Link encap:Ethernet HWaddr 00:0F:B0:62:E6:1D
inet addr:192.168.0.3 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::20f:b0ff:fe62:e61d/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1229 errors:0 dropped:0 overruns:0 frame:0
TX packets:1273 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1133516 (1.0 Mb) TX bytes:171758 (167.7 Kb)
Interrupt:209 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1544 (1.5 Kb) TX bytes:1544 (1.5 Kb)

garthlaptop:/home/garth/Ralinkdriver/rt73-cvs-2007021811/Module #
garthlaptop:/home/garth/Ralinkdriver/rt73-cvs-2007021811/Module # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

rausb0 RT73 WLAN
Link Quality:0 Signal level:135 Noise level:145
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

sit0 no wireless extensions.

garthlaptop:/home/garth/Ralinkdriver/rt73-cvs-2007021811/Module #
 
  


Reply

Tags
suse, wep


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to establish internet connection using Linksys WRT54G Router on Mandrake 10 djynen Linux - Networking 3 11-25-2006 11:01 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 07:25 AM
I can't establish a connection in my router Murilo Linux - Wireless Networking 1 08-18-2005 03:04 PM
SuSE 9.2 wireless connection loss when SSID broadcast disabled on router cheapuser Suse/Novell 0 01-30-2005 01:03 AM
wireless router to wireless router connection questions mister_math Linux - Wireless Networking 0 08-06-2003 02:50 PM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration