LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-17-2009, 02:25 PM   #1
paulikus
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Rep: Reputation: 0
Suse 10.2 autofs not working reliably


I have a Suse 10.2 box running autofs5-5.0.2-0.3 which automounts 400+ machines in different subnets. there a bunch of cron jobs that access these mounts. found that the jobs fail intermittently with 'no such file or directory' when going to various mount points. right after that, I cd to that dir do an 'ls' and the mount is fine. Seems I stopped this by setting timeout=0 {do not unmount} on the automounts. but this seems rather counter to the purpose of automount, plus I'm concerned as to how this may effect the system performance, etc over time.

since doing this, I see some occasional/transient "NFS Stale file handle" from jobs, but again, you go to the mount point and it's all good.

Has anyone seen similar?

This same setup runs on a Solaris box without issue.
 
Old 11-18-2009, 09:41 AM   #2
Angus
LQ Newbie
 
Registered: Nov 2009
Location: Montreal, Canada
Distribution: Suse 11, Ubuntu
Posts: 10

Rep: Reputation: 0
I've had a similar problem, if "things don't work too well in 10.2 anymore" counts as "similar". The last time I checked 10.3 was supported. Is there any chance of upgrading to that?
 
Old 11-18-2009, 12:46 PM   #3
paulikus
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Can you shed more detail on the similar problem you experienced? I don't have a hard stop/rule against upgrading to Suse 10.3, but I want to do it only if there is a known fix for automount and not just upgrade to see if it fixes the problem. Do you have some evidence?

thanks
 
Old 11-20-2009, 09:47 AM   #4
Angus
LQ Newbie
 
Registered: Nov 2009
Location: Montreal, Canada
Distribution: Suse 11, Ubuntu
Posts: 10

Rep: Reputation: 0
I'm sorry, I can't help you w/autofs, quite. It's just that getting things to run in 10.2 is very difficult often. I haven't been able to find any repositories that are still active, so there are no updates to get. This might not be such a problem if you'd been keeping updates regularly when they were available, but what happens when you want to install a new package from your distro discs, but it's way out-of-date?
I've used both 10.2 and 10.3, and from my experience, there was nothing to prefer in 10.2. However if you do find that 10.3 is unacceptable, you won't be able to go back to the 10.2 system you had, unless you are running it in a virtual machine, and you've taken snapshots.
 
Old 11-24-2009, 09:07 AM   #5
Angus
LQ Newbie
 
Registered: Nov 2009
Location: Montreal, Canada
Distribution: Suse 11, Ubuntu
Posts: 10

Rep: Reputation: 0
Sorry, forget what I said about upgrading to 10.3. I just read that support for it has been discontinued for almost a month. If you do find yourself an iso, and upgrade using it, you will undoubtedly have a world of headaches, having a system full of packages that are completely unupdated.
 
Old 12-03-2009, 03:11 PM   #6
paulikus
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0
pretty sure solved.

increased the # of available ports for use by NFS by lowering kernel parameter 'sunrpc.min_resvport' to 200. it was 650 prior. left 'sunrpc.max_resvport' at 1023.
did this dynamically with 'sysctl -w sunrpc.min_resvport=200'

add 'sunrpc.min_resvport=200' to /etc/sysctl.conf so system gets it on reboot.
 
Old 12-21-2009, 12:27 PM   #7
paulikus
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0
meant to get back to this, yes, increasing the number of ports allocated for NFS resolve my issue, though you can run into conflicts with other ports, such as samba; port 445 which you have to watch out for. though newer patch levels of the Suse 10.2 kernel include a parameter; 'sunrpc.max_shared' which allow you to multiplex several multiple NFS connections over the same port. Default value is 1, but you can increase accordingly.
 
Old 10-05-2010, 02:09 PM   #8
paulikus
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0
sunrpc.max_shared in 2.6.16.60-0.33

I found that the kernel-bigsmp-2.6.16.60-0.33 includes the sunrpc.max_shared kernel parameter.
 
Old 11-09-2011, 12:15 PM   #9
rhel5
Member
 
Registered: Mar 2009
Location: Bay Area, CA
Distribution: Redhat Enterprise Linux
Posts: 53

Rep: Reputation: 15
Sorry to resurrect this thread.

I am also having this issue on my SUSE SLES 10 SP2 box. At times when running my jobs, I will get a 'no such file or directory' error. But when I cd into the directory, the file is there. Running it the second time passes fine.

Here are my sysctl settings by default.
suse9:~ # sysctl -a | grep -i sunrpc.max_shared
sunrpc.max_shared = 1
suse9:~ # sysctl -a | grep -i 'sunrpc.min_resvport'
sunrpc.min_resvport = 665

The solution call for lowering 'sunrpc.min_resvport' to 200. Any suggestion for the max? It is currently set to 1...

Can someone explain what the 2 kernel parameters play a role in this issue?


Thanks much everyone...
 
Old 11-12-2011, 08:53 AM   #10
wagscat123
Member
 
Registered: Jan 2009
Location: Westminster, Maryland USA
Distribution: openSUSE 13.1, LinuxMint 13 and tons more in VirtualBox
Posts: 192
Blog Entries: 7

Rep: Reputation: 21
I strongly recommend you create a new thread since your problem seems different and it will attract more attention.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
autofs problem on SuSe 10 sunilvadranapu Suse/Novell 2 01-06-2009 07:31 AM
NIS and autofs clients not working on Fedora 9 heberrdacruz Linux - Networking 2 11-28-2008 07:13 AM
Special function (Fn) keys don't work reliably in Suse 10.1 on Evesham laptop Paul Williamson Linux - Laptop and Netbook 0 02-10-2007 09:57 AM
automounting with autofs not working.. logicalfuzz Linux - Networking 2 11-21-2005 05:41 AM
autofs not working in Fedora Core 2 mle Fedora 1 03-04-2005 09:40 AM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration