LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 07-13-2006, 06:00 PM   #1
craigs80
LQ Newbie
 
Registered: Sep 2004
Location: Scarborough, UK
Distribution: Suse / Ubuntu
Posts: 16

Rep: Reputation: 0
Question Suse 10.1 Shutdown causes system to hang


I have a problem when i shutdown suse 10.1 intermittantly my system will just hang, the last service to stop is the syslog services which completes ok, no error logs or anything the system just freezes and then obviously on a reboot after physically killing power this forces a disk check. Does anybody have any ideas on how to narrow down the problem?

Shutting down syslog services does complete sucessfully by the way and according to my runlevel listing the only service enabled left to shutdown is xdm.

Not sure if the runlevel listing is in the same order as it is on shutdown??
 
Old 07-13-2006, 06:13 PM   #2
jpneron
LQ Newbie
 
Registered: Jul 2006
Location: Winnipeg, Canada
Distribution: SuSE
Posts: 12

Rep: Reputation: 0
Not sure why it hangs, but I can shed some light on the shutdown process.

The runlevel listing in Yast is alphabetical, and doesn't really indicate the order of starting or stopping. Look in your /etc/init.d/rc5.d directory. These are the scripts that are run when entering or leaving run level 5 (the full X-Windows system). The scripts starting with 'S' are the ones run when starting, and the ones starting with "K" are the ones run when ending. These are executed in the order you see them in. So, try to find what script is being run when it hangs, or what script comes next. That might help narrow it down. BTW: These scripts are just links that point to the actual scripts in /etc/init.d.

HTH.

Jean
 
Old 07-13-2006, 06:23 PM   #3
craigs80
LQ Newbie
 
Registered: Sep 2004
Location: Scarborough, UK
Distribution: Suse / Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Smile My understanding grows everyday

Thanks for that information, its like gold dust. Should have guessed really it was in alphebetical order. durr.
;-)

Have now found that its hanging on network. I know i have had alot of problems getting my wireless connection up on everyboot with knetworkmanager. kept asking for my wep key everytime and got totally sick of entering a password everytime for kwallet so set it with no password, seemed to work but think its causing problems on the shutdown process now. Not sure if it will be kwallet or knetworkmanager causing the problem. Shame i cant get ifup to work with a 40bit wep key.

Thanks for your help, its much appreciated.
 
Old 07-14-2006, 10:46 AM   #4
jpneron
LQ Newbie
 
Registered: Jul 2006
Location: Winnipeg, Canada
Distribution: SuSE
Posts: 12

Rep: Reputation: 0
Maybe try reconfiguring your network card with Yast? I'm surprised you're having problems using the ifup method with a 40 bit key, that shouldn't matter.

Jean
 
Old 07-14-2006, 01:49 PM   #5
craigs80
LQ Newbie
 
Registered: Sep 2004
Location: Scarborough, UK
Distribution: Suse / Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Have tried with yast with suse 10.0 had no problems with ifup but 10.1 seems to only allow 128bit security, i think the answer to is is for me to change my wep key to something longer.
 
Old 07-14-2006, 02:12 PM   #6
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 349

Rep: Reputation: 42
Same here - sometimes it stops while shutting kde/m manager.
I have just installed - Will check out log files and others.
 
Old 07-16-2006, 11:51 PM   #7
jpneron
LQ Newbie
 
Registered: Jul 2006
Location: Winnipeg, Canada
Distribution: SuSE
Posts: 12

Rep: Reputation: 0
FWIW: I'm using a 40 bit wep key with 10.1, and it works fine. The Authentication Mode is 'Open', and I entered the 10 hex digits for the key.

Of course, 40 bit keys are acknowledged to be much too weak, and we should both upgrade to 128 bit ... :-)

Jean
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown problem system halted suse 10.0 stork Suse/Novell 16 11-16-2005 08:56 PM
System hang whilst directory listing on SuSE 9.3 GUI console pdqsw Linux - General 3 10-24-2005 04:10 AM
(suse)select the system to be booted after shutdown/reboot!? mikeM Linux - Distributions 2 05-02-2004 03:32 AM
shutdown hang during eth0 shutdown kurtisw Linux - Networking 5 10-30-2003 03:49 PM
RH8: System Hang with shutdown -r now then Linux - Distributions 4 12-22-2002 02:07 PM


All times are GMT -5. The time now is 10:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration