LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 06-15-2006, 04:52 PM   #31
dasy2k1
Member
 
Registered: Oct 2005
Location: 127.0.0.1
Distribution: Ubuntu 12.04 X86_64
Posts: 958

Rep: Reputation: 35

the one thing i cant find is yast sources for all the closed source codecs,
libxine1, libdvdcss and win32codecs-all spring to mind (not sure about the spelling of the last one)
if anyone knows of any reposotorys with them in then i would be gratefull!
 
Old 06-15-2006, 04:53 PM   #32
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
Quote:
Originally Posted by dasy2k1
the one thing i cant find is yast sources for all the closed source codecs,
libxine1, libdvdcss and win32codecs-all spring to mind (not sure about the spelling of the last one)
if anyone knows of any reposotorys with them in then i would be gratefull!
Packman repository..

Packman is listed on Novell's site
 
Old 06-15-2006, 06:49 PM   #33
dasy2k1
Member
 
Registered: Oct 2005
Location: 127.0.0.1
Distribution: Ubuntu 12.04 X86_64
Posts: 958

Rep: Reputation: 35
Quote:
Originally Posted by EclipseAgent
Packman repository..

Packman is listed on Novell's site
if i can find it....
i have tried 2 mirrors allready and got errormessages saying yast coudent ass them as an update source

coudl you give me an URL to one that works? as i cant seme to find one anywhere sespite much searching and googling

Last edited by dasy2k1; 06-15-2006 at 06:54 PM.
 
Old 06-15-2006, 10:24 PM   #34
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
http://packman.iu-bremen.de/suse/10.1
 
Old 06-17-2006, 03:28 AM   #35
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,839

Rep: Reputation: 48
10.1 works great on my laptop but I can't update because the updates for the update manager fail on a dependency check.

EDIT: Okay, so I try a reboot. Suse "forgets" there were any updates. I click the update tool and it finds them again but fails again. I do a CTRL-ALT-F2, log on as root, type "you", and install the updates.

Last edited by 2damncommon; 06-17-2006 at 03:43 AM.
 
Old 06-17-2006, 09:58 PM   #36
alek66
Member
 
Registered: Apr 2004
Location: Argentina
Distribution: netBSD/Linux
Posts: 256

Rep: Reputation: 30
I still cant figure out what or how to update my yast cause It works pretty bad. help me
 
Old 06-18-2006, 03:12 AM   #37
Jersoncito
LQ Newbie
 
Registered: Jun 2006
Posts: 1

Rep: Reputation: 0
Open Yast/add softwares
Install Smart, smart --gui and use it.
After instalation you will find it on system aplications.
Smart will detect your current repositories, click on update/upgrade all
Hopefully Smart will resolve your dependencies problems.
 
Old 06-18-2006, 06:02 AM   #38
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Jersoncito
Open Yast/add softwares
Install Smart, smart --gui and use it.
After instalation you will find it on system aplications.
Smart will detect your current repositories, click on update/upgrade all
Hopefully Smart will resolve your dependencies problems.
Even better choice is to use Gurus updated Smart packages. Gurus smart rpms have repositories added automatically.

wget the packages

Code:
wget http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1/RPMS/i686/smart-0.41-28.guru.suse101.i686.rpm

wget http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1/RPMS/i686/smart-addons-0.41-28.guru.suse101.i686.rpm

wget http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1/RPMS/i686/smart-gui-0.41-28.guru.suse101.i686.rpm
and install with rpm . (with root)

Code:
rpm -ivh smart*.rpm
 
Old 06-18-2006, 06:12 AM   #39
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by alek66
I still cant figure out what or how to update my yast cause It works pretty bad. help me
1) Install smart as told above

2) Update packages offered with smart ( the sl 10.1 update repository)

2.1) K menu ->system -> configuration -> smart package management
2.2) Click EDIT -> CHANNELS -> Check only rpm-sys and SUSE-update, uncheck others
2.2) Click FILE -> Update Channels.
2.3) Click EDIT -> Upgrade ALl

3) I recommend a reboot at this point , YAST/ZMD/ZEN/RUG should work now normally with updated rpms
 
Old 06-18-2006, 01:57 PM   #40
alek66
Member
 
Registered: Apr 2004
Location: Argentina
Distribution: netBSD/Linux
Posts: 256

Rep: Reputation: 30
Quote:
Originally Posted by onjoo
1) Install smart as told above

2) Update packages offered with smart ( the sl 10.1 update repository)

2.1) K menu ->system -> configuration -> smart package management
2.2) Click EDIT -> CHANNELS -> Check only rpm-sys and SUSE-update, uncheck others
2.2) Click FILE -> Update Channels.
2.3) Click EDIT -> Upgrade ALl

3) I recommend a reboot at this point , YAST/ZMD/ZEN/RUG should work now normally with updated rpms
I did as you told me... smart tells me on the bottom "no interesting upgrades avaliable!"
On channels the only thing that is there is:
alias: rpm-sys
type: rpm-sys
Name: Rmp System

I dont have suse-update! where can I add that one?
 
Old 06-18-2006, 02:10 PM   #41
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by alek66
I did as you told me... smart tells me on the bottom "no interesting upgrades avaliable!"
On channels the only thing that is there is:
alias: rpm-sys
type: rpm-sys
Name: Rmp System

I dont have suse-update! where can I add that one?
It should be automatically added, if you have run the update configuration in YAST.

IT can be added also from commandline to smart :

smart channel --add suse-update type=rpm-md name="suse-update" baseurl=http://ftp.gwdg.de/pub/suse/update/10.1/
 
Old 06-19-2006, 05:29 PM   #42
husten
Member
 
Registered: Apr 2006
Distribution: Suse 11.4
Posts: 48

Rep: Reputation: 16
Suse 10.1 updater solution

How do you update a broken updating tool??
That was my problem until I came across this post (see at the end of this message).
The problem is the ZEN updater runs on a Microsoft DotNET clone (Mono). Getting away from this crap was one of the reasons why I am in Linux.

So if you uninstall "mono" in yast and with it it's dependent zen, zmd, rug etc...you will be left with a normally and fast operating Yast. I am fed up with being a guinea pig for Novell.

P.S. I am prepared to pay good money for the "supported" version of Suse if they promise beforehand to support my hardware.
husten

>Kommentar eines Lesers auf Pro-Linux
>URL der Nachricht: http://www.pro-linux.de/news/2006/9815.html
>=====================================================
>
>Re[2]: Geht nicht...
>Einsender: Harald - Mo, 12. Jun 2006, 22:32
>
>Nur mal so...
>
>
>Habe bei der Installation mal "mono" deselektiert und alle
>Abhängigkeiten mit "will ich nicht" aufgelöst. Bislang
>überhaupt keine Nachteile - eher im Gegenteil: kein nervender
>Beagle, kein ZMD, Online-Update funktiniert, ... ;-)
>
>=====================================================
 
Old 06-19-2006, 05:49 PM   #43
zenarcher
Member
 
Registered: Sep 2004
Location: Miami, Oklahoma
Distribution: Fedora Core 6
Posts: 40

Rep: Reputation: 15
First, download and install the appropriate SMART packages....SMART, SMART Add-On's and SMART GUI from here....

http://linux01.gwdg.de/~pbleser/rpm-...=System/smart/

Then, check the Channels...making sure all Channel boxes are checked....Update Channels and at least update all the ones related to YAST....I updated all packages, myself.

Then, read and follow the instructions here...and your YAST system will be working as it should...

http://www.desktoplinux.com/news/NS3687730057.html

Cheers,
zenarcher

Last edited by zenarcher; 06-19-2006 at 05:51 PM.
 
Old 06-19-2006, 06:09 PM   #44
alek66
Member
 
Registered: Apr 2004
Location: Argentina
Distribution: netBSD/Linux
Posts: 256

Rep: Reputation: 30
Everything worked like a charm! Thx everbody
 
Old 06-21-2006, 03:55 AM   #45
eagle17x
LQ Newbie
 
Registered: Jun 2006
Posts: 2

Rep: Reputation: 0
Hi !! im kind of new here, and got a problem with some kde themes. I already install them but the minimize, maximize, close buttons and scroll bars didn't change at all. These are the names of the themes Tuxintosh and Mac Baghira, downloaded from kdelook.org . Wonder if someone knows why this is happening. Hope you can help guys !!
 
  


Reply

Tags
howto, packages, repository, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where are the Suse 10.0 eval repositories? Cinematography Suse/Novell 2 01-20-2006 11:39 AM
suse 10.0 (eval) repositories theeil Suse/Novell 1 12-18-2005 03:45 PM
What happened to my SuSE 9.3 Repositories? BDiddy Suse/Novell 3 10-15-2005 02:12 PM
Suse 9.1 & 9.2 Maintenance Repositories zparihar Suse/Novell 2 07-24-2005 02:17 AM
apt-get repositories, howto feetyouwell Linux - Software 2 05-26-2004 09:47 AM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration