LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-14-2006, 10:44 PM   #1
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
SuSE 10.1 Intel Centrino M only uses about 1/2 of processor.


My SuSE 10.1 installation when I show "sysinfo:/" it shows my CPU as using 598.59 of my 1.6GHZ Processor.

In KPowersave it shows that it is also using 100% of 598mhz.

Why wouldn't it be reporting the full 1.6GHZ, or how can I make sure my computer uses the full CPU?
 
Old 05-15-2006, 07:49 AM   #2
rjwilmsi
Member
 
Registered: Mar 2005
Location: UK
Distribution: opensuse 12.2 x86_64
Posts: 563

Rep: Reputation: 38
SUSE might have defaulted to a 'Dynamic' or 'Powersave' mode - set KPowerSave to use 'Performance' mode to get 1.6 GHz all the time.
 
Old 05-15-2006, 09:17 AM   #3
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by rjwilmsi
SUSE might have defaulted to a 'Dynamic' or 'Powersave' mode - set KPowerSave to use 'Performance' mode to get 1.6 GHz all the time.
I have done this, and it still runs at 598MHZ, and not the full 1.6GHZ. I have tried all power settings.
 
Old 05-15-2006, 09:58 AM   #4
1madstork
Member
 
Registered: Aug 2004
Location: Southaven, Mississippi, USA
Distribution: Debian Etch
Posts: 108

Rep: Reputation: 15
The Pentium M's use 'Speedstep' technology. What this does is run the processor at a lower frequency until you put a strong enough load on it to warrant a raise. My 1.4GHz Pentium M is running at 598MHz right now but if I burn a cd or watch a movie it runs at 1400MHz or 1.4GHz. This is set up to save battery power and, ultimately, computer life by not running at full speed when you don't need it.

You can disable Speedstep in the BIOS on most laptops. Also, when you type dmesg in a shell you'll see something that pertains to speedstep somewhere in the long list of devices.
 
Old 06-08-2006, 03:25 PM   #5
cevans
LQ Newbie
 
Registered: Jan 2003
Distribution: Debian (ppc and x86) with Gnome CVS HEAD
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by 1madstork
The Pentium M's use 'Speedstep' technology. What this does is run the processor at a lower frequency until you put a strong enough load on it to warrant a raise. My 1.4GHz Pentium M is running at 598MHz right now but if I burn a cd or watch a movie it runs at 1400MHz or 1.4GHz. This is set up to save battery power and, ultimately, computer life by not running at full speed when you don't need it.

You can disable Speedstep in the BIOS on most laptops. Also, when you type dmesg in a shell you'll see something that pertains to speedstep somewhere in the long list of devices.
No, this isn't the problem here. I have it on Ubuntu Dapper as well. CPU scaling doesn't work, and the system remains pinned at the lowest frequency. It never changes, no matter what governor is used. Looking around in /sys, scaling_max_freq is the same as scaling_min_freq (600000 on a 1.6GHz CPU). dmesg shows the kernel as detecting the CPU as a 597MHz CPU, with a correspondingly low BogoMIPS value.
 
Old 06-08-2006, 03:39 PM   #6
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by cevans
No, this isn't the problem here. I have it on Ubuntu Dapper as well. CPU scaling doesn't work, and the system remains pinned at the lowest frequency. It never changes, no matter what governor is used. Looking around in /sys, scaling_max_freq is the same as scaling_min_freq (600000 on a 1.6GHz CPU). dmesg shows the kernel as detecting the CPU as a 597MHz CPU, with a correspondingly low BogoMIPS value.
Man i've been busy, and haven't been able to try to investigate our issue more. Hopefully this week I will..

But glad (well not glad) that someone else is getting it.
 
Old 06-09-2006, 12:08 AM   #7
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1600MHz
stepping : 5
cpu MHz : 598.567
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 1198.3

You can see there, that it is also still pegged at the 598MHZ.
 
Old 06-09-2006, 04:36 AM   #8
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
I'm surprised as mine works perfectly
I'm on a HP Pavilion DV1000 laptop

Here's the output of cat /proc/cpuinfo when running NOTHING - I'm in the KDE desktop with nothing executing except the console command

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.73GHz
stepping : 8
cpu MHz : 1729.813
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx est tm2
bogomips : 3464.18



Cheers

-K

Last edited by 1kyle; 06-09-2006 at 04:41 AM.
 
Old 06-09-2006, 10:06 AM   #9
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
You are stepping at 8 where as I am stepping 5.. I wonder if mine is actually a speedstep issue, and it doesn't go over 5 (Dunno, I don't know much about speedstep and ACPI).

Are you running SuSE 10.1? Nothing different about it?

The only differences I see are of course the name, the model, the bogomips and stepping, and I am sure stepping is proportional to bogomips..

Wonder why the model:9 doesn't work correctly.
 
Old 06-09-2006, 11:45 AM   #10
1madstork
Member
 
Registered: Aug 2004
Location: Southaven, Mississippi, USA
Distribution: Debian Etch
Posts: 108

Rep: Reputation: 15
Quote:
# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1600MHz
stepping : 5
cpu MHz : 598.567
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 1198.3

You can see there, that it is also still pegged at the 598MHZ.
Is it still at 598MHz when you're burning a cd or watching a video? Mine pretty much stays there except when I'm really pushing it.

Here's my /proc/cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1400MHz
stepping : 5
cpu MHz : 256.347
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 507.31

It still runs well even at this low frequency.

Here it is again with some more processes running:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1400MHz
stepping : 5
cpu MHz : 598.144
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 1183.74
 
Old 06-09-2006, 11:56 AM   #11
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by 1madstork
Is it still at 598MHz when you're burning a cd or watching a video? Mine pretty much stays there except when I'm really pushing it.

Here's my /proc/cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1400MHz
stepping : 5
cpu MHz : 256.347
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 507.31

It still runs well even at this low frequency.

Here it is again with some more processes running:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1400MHz
stepping : 5
cpu MHz : 598.144
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 1183.74
So you are going from about 300mhz to 600mhz.. still less then 50% of what your processor should do.

But I did your suggestion and in top it showed I was at about 100% CPU usage, and ran cat /proc/cpuinfo and stil came up with the exact output as before
 
Old 06-09-2006, 03:02 PM   #12
1madstork
Member
 
Registered: Aug 2004
Location: Southaven, Mississippi, USA
Distribution: Debian Etch
Posts: 108

Rep: Reputation: 15
I would think that you probably have to compile a kernel but I'm no expert. If you'd like, I can give you my config. My cpu does clock up to 1400MHz but only when I'm doing something intensive.
 
Old 06-09-2006, 04:02 PM   #13
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by 1madstork
I would think that you probably have to compile a kernel but I'm no expert. If you'd like, I can give you my config. My cpu does clock up to 1400MHz but only when I'm doing something intensive.
I don't think it's a Kernel issue, but more of a ACPI issue. I have tried a few things and still nothing, I have put in a BUG report to Novell, but I think it's an issue with ACPI personally.
 
Old 06-12-2006, 11:18 PM   #14
cevans
LQ Newbie
 
Registered: Jan 2003
Distribution: Debian (ppc and x86) with Gnome CVS HEAD
Posts: 6

Rep: Reputation: 0
I've narrowed this problem down to the cpufreq_verify_within_limits call inside acpi_processor_ppc_notifier in drivers/acpi/processor_perflib.c in the kernel. I'm not quite sure why the maximum value gets set to the minimum value, but my guess is that for some reason, ppc is getting set to the lowest frequency state instead of the highest frequency state. I've stuffed some printk's in the code and will try to see if this is the problem the next time I reboot.

You can fix this in a hackish way by setting the third argument to that call to your maximum frequency *in kHz* (in my case, 1600000) and compiling the kernel. This should fix the problem, but certainly won't allow a patch to be made for general use.
 
Old 06-13-2006, 12:00 AM   #15
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
What Kernel are you using? I have seen this issue in my current kernel of:

# uname -r
2.6.16.13-4-default

and have also had the same thing with 2.6.16.18-20-default (or about that, forget the exact thing).

I will check the file that you have talked about.. once i finish cooking my lunch for tomorrow.
 
  


Reply

Tags
kpowersave, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
intel mobile centrino scripttron75 Linux - Networking 2 03-29-2006 02:35 AM
LXer: Psychsoft announces the 64 Bit Psyborg Extreme Workstation with Intel Dual Core Processor featuring SUSE Linux 64 LXer Syndicated Linux News 0 02-02-2006 05:01 AM
Can't Connect To Access Point On SuSe 9.2 Personal With Intel Centrino 2200BG dac0braman Suse/Novell 11 02-16-2005 08:26 PM
Intel Centrino Petition forceflow2 Linux - Laptop and Netbook 2 08-01-2003 02:31 PM
Centrino Mobile processor Jane Delawney Linux - Laptop and Netbook 2 06-12-2003 02:31 AM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration