LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 04-11-2006, 11:56 PM   #1
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Rep: Reputation: 15
Question SUSE 10.0 (OSS) - Sound cards/hydrogen/jack... basically multimedia!


Hi All

I've just installed SUSE 10.0 (OSS) and all went well... me thinks! Desktop is KDE.

My PC has two sound cards - onboard sound and a PCI card. Onboard sound uses the intel_x80 driver, the PCi is a MAudio Delta 24/96 using ICE1712 driver.

I have some cheap speakers attached to the onboard sound.

The system sounds can be heard (shutdown, etc) but when I use hydrogen a warning message appears that "no sound cards configured or no sound device...". I start up QJackctl before hydrogen and I can start the sound server... but still get the warning message. Worse still is when I continue (message allows me to continue or abort) hydrogen crashes...

Regarding the "no sound cards" configured I can open the Envy24Control (application for the MAudio sound card) and all is well.

I've run alsaconf and can select either of the two detected sound cards and configure these... still to no avail with hydrogen.

Anyone got any ideas?

All works ok with my Gentoo installation...
 
Old 04-12-2006, 08:41 PM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
You have to shutdown the artsd sound system, which is enabled by default in KDE (bad idea, imho).
You can do it in kcontrol.
Then start jack and select jack audio driver in hydrogen and pa ta poum!
 
Old 04-12-2006, 10:42 PM   #3
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Cool! I was thinking along those lines... late last night but didn't get a chance to try it.

Thanks for the advice . I will do it tonight when I get home from work and post back results.

Will I also be able to turn it off permanently in kcontrol?

cheers!
 
Old 04-12-2006, 11:15 PM   #4
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Yes. If you like music programs, you should try this live-cd:
http://www.dynebolic.org/
This is a full home-studio, from recording to cd burning.
Oh, btw, i also have an ICE1712, the audiophile one. Very good chipset .

Last edited by Linux.tar.gz; 04-12-2006 at 11:17 PM.
 
Old 04-12-2006, 11:49 PM   #5
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
I'll check out that link you gave me, thanks a lot!

Yep the audiophile card is a nice one - a card that lies somewhere between a professional and consumer one. Good choice!

Another question - in my Gentoo installation when I open Kamix both cards are displayed for tweaking. But I don't think this is the case in my SUSE installation. Any ideas?
 
Old 04-15-2006, 08:32 AM   #6
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Hmmm.. I turned off the arts sound in kcontrol and rebooted.. but hydrogen still shuts down on me...

If I select the onboard sound in my jack setup then hydrogen gives me the same error as before "Direct access to the Sound Device Not Possible": No sound card available or sound support is not configured yet... I can continue but hydrogen bombs out.

If I select the MAudio card I don't get the above message when I start hydrogen but it still bombs out.

Any ideas?

BTW I downloaded that dynebolic iso and tried it - very nice.. at least hydrogen works there without a hitch!
 
Old 04-18-2006, 09:41 AM   #7
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Still haven't found a solution to this...

If I start hydrogen from x-term as such: hydrogen -V -d alsa (or jack) then when I go past the first info screen and then the app bombs with the following message:
terminate called after throwing an instance of 'std::logic_error'
what(): basic_string::_S_construct NULL not valid
Aborted

Any ideas anyone? Am I missing some dependancy?
 
Old 04-18-2006, 02:38 PM   #8
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Try to compile from sources.
 
Old 04-19-2006, 01:35 AM   #9
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15


Linux.tar.gz... Are you reading my mind? Amazing waht can be done with Linux!

Yep was going to do that. Will try tonight or as soon as possible and post reply.

Thanks!
 
Old 04-19-2006, 06:40 PM   #10
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Well I installed from source and also needed to install libsndfile and flac from source as well (???)... Still have the same issue - Hydrogen bombs.

Strangely enough I had it working once a few days ago. I turned off arts in kcontrol (is now permanently off). I didn't start jack and then fired up hydrogen... it opened ok. Then I selected jack audio driver from within hydrogen. I shut down hydrogen to do something else and when I tried it again it once again bombed and has done so since.

Any ideas anyone?
 
Old 04-20-2006, 11:17 PM   #11
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Usually, you have to start jack, then hydrogen. Don't forget to connect hydrogen output to alsa input in qjackctl.
 
Old 04-21-2006, 01:16 AM   #12
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Thans for the tips... But I hydrogen still crashes.

Maybe a library conflict?
 
Old 04-21-2006, 10:46 AM   #13
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
I don't know. I recompiled the latest hydrogen this morning and it worked.
Launched "qjackctl", then "hydrogen".
 
Old 04-25-2006, 07:13 AM   #14
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Hmmm. I do the same but hydrogen still crashes.

Seeing that my SUSE install is very fresh and under-utilised I'm very tempted to re-install it again...
 
Old 04-26-2006, 09:06 PM   #15
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Well if you want to go deeper into Linux, try some Slackware. I swear you won't regret it.
 
  


Reply

Tags
kde, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Sound under OSS SUSE 10.0! SuSE_Lamer Suse/Novell 1 12-25-2005 05:08 PM
Suse 10.0 OSS multimedia problem winsnomore Suse/Novell 25 11-23-2005 06:21 PM
Multimedia Framework: Jack masand Linux - Software 2 12-07-2004 10:34 AM
formatting multimedia cards, flash cards bigearsbilly Linux - Hardware 0 03-10-2004 09:52 AM
hydrogen and starting the OSS driver Pwcca Linux - Software 0 07-03-2003 01:18 AM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration