LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2005, 04:39 PM   #1
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Rep: Reputation: 15
Suse 10.0, no switch user in KDE?


I just installed opensuse 10.0, and when using KDE I can not switch users while leaving the previous user logged in, like I could with 9.2. What's up with that? Am I just missing the switch user- button or what? In Gnome, it works just like it's supposed.
 
Old 10-18-2005, 10:50 PM   #2
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
The problem is the version of the KDE.

Not all versions of KDE have the switch user button.
I guess upgrading KDE to a higher stable version should solve the problem.


The following idea should solve your problem. (Submitted straight from the Cent OS Mailing list.)

First, you lock your screen, then you press ctrl-alt-F2 (or ctrl-alt-f3,
f4, f5) and allow the other user to login at the console as the user you
want.

Then issue the command:

xinit /usr/bin/gnome-session -- :1

OR

xinit /usr/bin/startkde -- :1


You would then use (one of these) ctrl-alt-f8, f9, f10, f11, f12 to
access the session ... and ctrl-alt-f7 for your orginal session.

For a third user, pick a console (ctrl-alt-f3) and do:

xinit /usr/bin/startkde -- :2

(or you could do gnome)

and it should go to the graphical console (ctrl-alt-f9).

that will work easily for up to 5 users ... if you need more than that,
other things would need to be done.
 
Old 10-19-2005, 02:38 AM   #3
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
OK, thanks.
 
Old 10-23-2005, 04:56 PM   #4
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
Update: it seems that the problem was somehow caused by my window manager. I had gdm set as default window manager, when I changed that to kde, the switch user button magically re-appeared.
 
Old 10-23-2005, 10:24 PM   #5
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
>Update: it seems that the problem was somehow caused by my window manager. I had gdm set as default window manager, when I changed that to kde, the switch user button magically re-appeared.


Virtually impossible.
Did you upgrade KDE to a later version?
 
Old 10-24-2005, 03:03 AM   #6
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
No, I didn't update anything. I changed the default window manager via YAST's system configuration editor, rebooted, and voila. I found something pointing me that way here:
http://mail.kde.org/pipermail/kde-ki...ch/001211.html
 
Old 10-24-2005, 06:26 AM   #7
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Good one.
 
Old 10-27-2005, 11:54 PM   #8
JDRay
LQ Newbie
 
Registered: Oct 2005
Location: Portland, Oregon
Distribution: OpenSUSE
Posts: 2

Rep: Reputation: 0
A closer look...

Quote:
Originally posted by badbunny
No, I didn't update anything. I changed the default window manager via YAST's system configuration editor, rebooted, and voila. I found something pointing me that way here:
http://mail.kde.org/pipermail/kde-ki...ch/001211.html
A closer read of the linked post shows that you have to change the DISPLAYMANAGER setting to kdm instead of gdm. This setting is independent of the DEFAULT_WM setting. I tried your method first to no avail. Changing the DISPLAYMANAGER to kdm worked, though.

So, what's your experience using the Switch User function? I tried it in 9.1 with little success. I'm running on a Thinkpad R40 (1.6 GHz Celery w/ 384 MB).

Last edited by JDRay; 10-27-2005 at 11:59 PM.
 
Old 10-28-2005, 12:43 AM   #9
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
>I tried your method first to no avail.


Whos that to?
 
Old 10-28-2005, 01:11 AM   #10
JDRay
LQ Newbie
 
Registered: Oct 2005
Location: Portland, Oregon
Distribution: OpenSUSE
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by duffmckagan
>I tried your method first to no avail.


Whos that to?
I quoted badbunny. His (?) method of changing the default window manager didn't work, but the article he (?) linked mentioned changing the display manager.
 
Old 10-28-2005, 01:43 AM   #11
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
ok.

My method was a temporary and a quick workaround.
 
Old 10-28-2005, 01:58 AM   #12
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
Re: A closer look...

Quote:
Originally posted by JDRay
A closer read of the linked post shows that you have to change the DISPLAYMANAGER setting to kdm instead of gdm. This setting is independent of the DEFAULT_WM setting. I tried your method first to no avail. Changing the DISPLAYMANAGER to kdm worked, though.

So, what's your experience using the Switch User function? I tried it in 9.1 with little success. I'm running on a Thinkpad R40 (1.6 GHz Celery w/ 384 MB).
Umm, well, it is remotely possible that I messed the two up... The evidence seems to point that way.
It worked fine in 9.2 and now it works in 10.0.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kde 3.4.2 switch user crashes system beeone Linux - Software 1 08-18-2005 05:25 PM
KDE 'switch user' command not appearing fyhuang Linux - Software 3 07-10-2005 03:04 AM
switch user in suse 9.1 invasian Linux - General 7 10-03-2004 09:59 AM
SuSE 9.1 'Switch User' when screensaver is locked Cichlasoma Linux - Distributions 1 07-20-2004 07:49 AM
switch user for the whole KDE session, not just the Konsole glock19 Linux - General 2 12-12-2001 02:31 PM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration