LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 01-25-2006, 11:38 PM   #1
tamere
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Rep: Reputation: 0
SUSE 10.0 extremely slow internet connection! what is wrong?


Hi,


I know there are a few threads arround but I haven't found one that solved my issue.

I have 3 computer connected to my router that is connected to my cable modem.
one laptop, Dell latitude c810, and 2 custom PC.
I installed Suse 10.0 on the laptop and one of the two desktop. In both cases I formated the hd and did a clean install.

before the Install all pc where running windows XP and internet speed was normal.

after a fresh suse 10.0 install and no additional setup or configuration on the laptop and one of the two desktop::

My pc running windows xp internet speed is normal.
The laptop internet speed is normal.

But the Suse 10.0 desktop internet speed is sllllllllllllllow!

Using any web browser when I type a address, the browser is taking a long time looking up then a long time transfering...

I used Firefox 1.07 and konqueror 3.4..2.

Transfering files between the 3 computer seem hapenning at normal speed, Only the internet
speed is slow.

Does anybody know why since I installed suse 10.0 on my desktop I am having poor internet speed? When it was a windows xp box the internet speed was fine.


Please I need help!!!

Alex

Last edited by tamere; 01-25-2006 at 11:50 PM.
 
Old 01-26-2006, 02:00 AM   #2
runlevel0
Member
 
Registered: Mar 2005
Location: Hilversum/Holland
Distribution: Debian GNU/Linux 5.0 (“Lenny”)
Posts: 290

Rep: Reputation: 31
Check your firewall, disable it as your router already has a quite good one.
Disable virus scanners, there are on by default (?) on SUSE 10.0.

Also: Check your running services and disable the firewalls you could find upstream in ypour network.

I would also advice getting a Switch and connecting every machine to the router in an independent way. It's not that they would get faster, but debugging your network is easier: Just attach the router to the switch and attach the rest of the boxes also to the switch. It's the way I use my home network, which is very similar to yours (Gentoo+Kubuntu+SUSE).

More stuff:
Open a terminal (Konsole or Gnome-Terminal) and try pinging www.google.com, write the IP down and try to see wether you get better timings using the IP than using the hostname. In this case the problem is in the DNS service, try disabling dns caching, bind and squid.

Also, if you are using NAT or some kond of bridging, test all teh stuff again on the NAT server or bridged machine.

Last edited by runlevel0; 01-26-2006 at 06:29 AM.
 
Old 01-26-2006, 09:32 AM   #3
sparton
Member
 
Registered: Nov 2003
Location: Cincinnati, Ohio
Distribution: Ubuntu 6.06 /SLED10
Posts: 45

Rep: Reputation: 15
Are you using a DCHP IP or a Static. If your using a static ip be sure to check your router and see if its detecting the same IP as your system. I had the same problem using a static IP and after i changed it mine worked great.
 
Old 01-26-2006, 10:14 AM   #4
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Quote:
Disable virus scanners, there are on by default (?) on SUSE 10.0.
this is crap

Anyway, you have three possible problems:
1) disable IPv6 (all linux distros with 2.6 kernels wahe thi one on)
2) double check network configuration
3) obviously hardware



However good news:
Quote:
Using any web browser when I type a address, the browser is taking a long time looking up then a long time transfering...
indicates problems caused by ipv6.
disable it and you should be fine.
Open terminal window and enter:
#echo "alias net-pf-10 off" >> /etc/modprobe.conf
#echo "alias ipv6 off" >> /etc/modprobe.conf

restart computer

You may disable ipv6 in FF only:
anter in FF address bar:
about:config
(no spaces above)
in the search bar inter ipv6
change the vaule of
network.dns.disableIPv6
from false to true

This will resolve dns lookup problems in FF

Last edited by broch; 01-26-2006 at 10:15 AM.
 
Old 01-26-2006, 11:42 AM   #5
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Actually taking a long time to look up addresses would tend to indicate DNS errors in my experience. Maybe you could hardset the DNS servers for your ISP in your network card configuration with YAST. That would help assuming the problem is what I think it is, which is DNS. Linux in my experience is very DNS picky.
 
Old 01-26-2006, 03:32 PM   #6
runlevel0
Member
 
Registered: Mar 2005
Location: Hilversum/Holland
Distribution: Debian GNU/Linux 5.0 (“Lenny”)
Posts: 290

Rep: Reputation: 31
Quote:
Originally Posted by RedShirt
Actually taking a long time to look up addresses would tend to indicate DNS errors in my experience. Maybe you could hardset the DNS servers for your ISP in your network card configuration with YAST. That would help assuming the problem is what I think it is, which is DNS. Linux in my experience is very DNS picky.
Ups, yes, this is prolly the answer which makes sense.

I forgot to say that I was trying to troubleshoot disabling DNS stuff, and that you shuld re-enable it once the culprit was isolated.At 8:30 in the morning my brain is still jelly, LOL
Having a caching DNS server is a good idea.

BTW, I have my SUSE with IPV6 only and have no problem riding WiFi hotspots through Utrecht, neither speed nor complaints, it runs a bloody hell of fine
 
Old 01-26-2006, 03:41 PM   #7
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Quote:
Originally Posted by RedShirt
Actually taking a long time to look up addresses would tend to indicate DNS errors in my experience. Maybe you could hardset the DNS servers for your ISP in your network card configuration with YAST. That would help assuming the problem is what I think it is, which is DNS. Linux in my experience is very DNS picky.
What does this mean?

And how would one go about doing what you suggest?
 
Old 01-26-2006, 04:46 PM   #8
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Well the easy way is this:

1) Find ISPs DNS... How to do this?
a) You can check your router, see what it pulled as DNS.
b) You can check your modem and see what DNS you are assigned.
c) You can call your ISP(or check their online gateway) and see if they will tell you DNS locations. Some also give you them in setup guides.

2) Yast > Network Devices > Network Card
a) Assuming you are using 9.1-10.0 it will go right away.
b) Assuming you are using 10.1 you need to select traditional with ifup, not Network Manager.(that is auto config and doesn't allow DNS setup.

3) Select your current Network Card. Choose "Edit" of the bottom buttons.

4) You should see a bunch of settings, and further menu options accessable via buttons. Choose "Hostname and Host Server".

5) There are 2 sections. The first is your domain information, and information about your computer. Like its Name. For instance "Hostname" and "Domain". The second section is Name Servers and Domain Listings. You should see Name Servers(3 of them) and a field either called "Search List" or something else on the right hand side. You need to change the name servers(which you will have to turn on the little manually configure box. You can't pull through DHCP.

6) Set the Nameserver #1 as the primary DNS server your ISP uses. Set the Nameserver #2 as the Secondary DNS server your ISP uses. Set Nameserver #3 as your Router/Gateway/Modem.

7) Make sure the top box on the right in that section is set as "site"

8) OK, NEXT, NEXT...etc Until it configures the settings and runs the little SuSE config stuff.

You are done, you should now have happy DNS and direct line to the servers so you don't have to try to get the info through router/gateway which seems to not work so well in linux with home routing equiptment.
 
Old 01-26-2006, 07:51 PM   #9
tamere
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by broch
this is crap

Anyway, you have three possible problems:
1) disable IPv6 (all linux distros with 2.6 kernels wahe thi one on)
2) double check network configuration
3) obviously hardware



However good news:


indicates problems caused by ipv6.
disable it and you should be fine.
Open terminal window and enter:
#echo "alias net-pf-10 off" >> /etc/modprobe.conf
#echo "alias ipv6 off" >> /etc/modprobe.conf

restart computer

You may disable ipv6 in FF only:
anter in FF address bar:
about:config
(no spaces above)
in the search bar inter ipv6
change the vaule of
network.dns.disableIPv6
from false to true

This will resolve dns lookup problems in FF

You rock!

I did read a few suse 9.0 threads that mentioned about the
ipv6 but I was so tired I must have never rebooted the computer... doh!
I just reverted to my modified modprobe.conf (same lines you sugested)
rebooted and my internet speed is now normal.

Thanks Broch!! and thanks everyone for helping me to resolve this problem.

Last edited by tamere; 01-26-2006 at 07:53 PM.
 
Old 01-27-2006, 08:48 AM   #10
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Quote:
Actually taking a long time to look up addresses would tend to indicate DNS errors in my experience. Maybe you could hardset the DNS servers for your ISP in your network card configuration with YAST.
Quote:
Ups, yes, this is prolly the answer which makes sense.
No actually this makes no sense at all. But it does not matter does it? Problem is resolved.
 
Old 01-27-2006, 10:31 AM   #11
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
It makes plenty of sense. Every linux box I have run, no matter the distro seems to be slow as hell at resolving DNS through routers and gateways on full DHCP(home, not enterprise stuff). And whether IPv6 is the cause, or it is just some kind of issue with the kernel, hardsetting DNS fixes it.

I could try around later tonight to see if IPv6 or DNS are really at fault, but either way I have found DNS fixes it.
 
Old 01-27-2006, 10:52 AM   #12
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
"hardsetting" does not exist
also maybe check your /etc/resolv.conf file
This is one of plenty semi "proffesional" myths.

You don't need to "check" anything (IPv6), simply read this:

http://www.ietf.org/rfc/rfc4074.txt

Excerpt:
Quote:
Ignore Queries for AAAA

Some authoritative servers seem to ignore queries for an AAAA RR, causing a delay at the stub resolver to fall back to a query for an A RR. This behavior may cause a fatal timeout at the resolver or at the application that calls the resolver. Even if the resolver eventually falls back, the result can be an unacceptable delay for the application user, especially with interactive applications like web browsing.
So it is well know fact since ... 199x (NetBSD KAME project. Check KAME site for history).
You may or may not encounter this, author of first post did.
 
Old 01-27-2006, 02:47 PM   #13
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Quote:
"hardsetting" does not exist
So wait, you mean I cannot directly input my DNS addresses as Name Servers? You had better let my 3 computers currently doing it in SuSE 10.0, SuSE 10.1 beta, and SLICK know, cause if they are doing it, I am really worried then. You may also want to send a memo back in time over the past 3 or 4 years to me about the 30 distros I have used and tried it with before settling on SuSE, cause I did it with all them too. Or wait, does that just mean I accomplished the unpossible! ME 4 TEH WIN!

I meant that in all cases for me, I never bothered to look at IPv6 as a possible culprit, mostly because I had never cared about IPv6 or even frankly known whether or not I was usign it. In some cases had the same issue on multiple distros, some of which do not have IPv6 support(or at least didn't when I tried them) I had the same issue of resolving DNS. But whether the issue is resolving DNS through DHCP or IPv6 is at fault, telling my network connections in every distro I have tried the DNS servers I want them to use, has corrected the issue of long resolving. It would actualy be interested, if only for my self, in knowing whether or not IPv6 is the culprit, or Linux at large, and that I was planning to test that out by turning of IPv^ and letting my network connection try to fully DHCP itself.
 
Old 01-27-2006, 03:03 PM   #14
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Quote:
I had never cared about IPv6 or even frankly known whether or not I was usign it.
That's summarizes this.
About hardsetting, I answered this before.
I don't think that there is reason to argue.
 
Old 01-27-2006, 03:29 PM   #15
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Quote:
Originally Posted by broch
That's summarizes this.
About hardsetting, I answered this before.
I don't think that there is reason to argue.
Not really arguing, just curious why would you say something like "it doesn't exsist" when it quite obviously does and many of us use it as a solution to this problem and others which revolve around nonresolving DNS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 04:29 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
Extremely Slow Internet (DNS problem?) AdmiralFreezbee Linux - Networking 1 04-02-2005 09:18 AM
Slow wireless internet connection DWL 650+ Suse 9.1 ksgill Linux - Wireless Networking 14 07-22-2004 06:11 PM
Extremely slow kppp internet connection msisto Linux - Newbie 2 09-10-2003 03:57 PM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration