LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-09-2005, 07:03 PM   #1
foolishone
LQ Newbie
 
Registered: Nov 2005
Location: Boondocks
Posts: 2

Rep: Reputation: 0
SUSE 10 | Disabling PAP & CHAP w/ pppd


After unsuccessfully trying to connect my dialup internet connection on a SUSE 10 box, I contacted my ISP for help. They kindly suggested that I disable this 'PAP' and 'CHAP' thing with/in pppd, as it conflicted with what ever they do over there.

How would I go about doing this? Is there another thread that I could be pointed to in order to assist me in my situation?

»fo
 
Old 11-09-2005, 08:51 PM   #2
trailnut
LQ Newbie
 
Registered: Oct 2004
Location: Vestal, NY
Distribution: Ubuntu
Posts: 15

Rep: Reputation: 0
You could try navigating to the directory: /etc/ppp

Then open a text editor (probably as root) and open the file, 'options' which lies withis /etc/ppp

Go down line by line and look for:

# Don't agree to authenticate using PAP
# -pap

Remove the # sign in front of -pap.

Do the same thing for the CHAP line.

Although I'm not sure how a hand shake would occur between you and your ISP without some kind of protocol. Make sure
you back up your original 'options' file before making changes.
 
Old 11-09-2005, 09:07 PM   #3
foolishone
LQ Newbie
 
Registered: Nov 2005
Location: Boondocks
Posts: 2

Original Poster
Rep: Reputation: 0
After I do that, would I just be able to do a wvdial and connect?

»fo
 
Old 11-10-2005, 08:30 AM   #4
mkIIIman089
LQ Newbie
 
Registered: Nov 2005
Location: Wantage, NJ
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
Okay, let me give this a shot, I'll let you know in a bit.
 
Old 11-10-2005, 09:36 AM   #5
mkIIIman089
LQ Newbie
 
Registered: Nov 2005
Location: Wantage, NJ
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
trailnut: those options do not exist in options. I searched line by line and using the find feature. They were simply not there.

Any other suggestions?

EDIT: By the way this is what happens:
linux:~ # cd /etc
linux:/etc # wvdial
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S32=192
OK
--> Modem initialized.
--> Idle Seconds = 300, disabling automatic reconnect.
--> Sending: ATDT9738751523
--> Waiting for carrier.
ATDT9738751523
NO CARRIER
--> No Carrier! Trying again.
--> Sending: ATDT9738751523
--> Waiting for carrier.
ATDT9738751523
NO DIAL TONE
--> No dial tone.
--> Disconnecting at Thu Nov 10 11:25:10 2005
linux:/etc #

Last edited by mkIIIman089; 11-10-2005 at 10:38 AM.
 
Old 11-10-2005, 11:15 AM   #6
trailnut
LQ Newbie
 
Registered: Oct 2004
Location: Vestal, NY
Distribution: Ubuntu
Posts: 15

Rep: Reputation: 0
I seem to remember something having to do with a "noauth" command in KPPP. I'm not at home yet but if you could post the wvdial.conf file that may help. When I get back to my Linux box tonight I may be able to offer more suggestions.
 
Old 11-10-2005, 11:22 AM   #7
vmlinuz101
Member
 
Registered: Mar 2005
Location: Ireland
Distribution: LFS, SuSE, Debian, gentoo
Posts: 93

Rep: Reputation: 15
the PAP or CHAP authentication (whichever you're using) is not the problem here. CHAP authentication takes place between you (the client) and your ISP (the server), but ONLY AFTER the connection has been made. Looking at your logs, it seems that a connection has not been made. Therefore, you might want to try reconfiguring ppp. Most dialers (e.g. qinternet, kinternet) let you do this. I am pretty sure too that qinternet and the like are also a frontend to ppp and wvdial. Make sure that all the information in wvdial is correct, otherwise you wont connect.
 
Old 11-10-2005, 11:43 AM   #8
mkIIIman089
LQ Newbie
 
Registered: Nov 2005
Location: Wantage, NJ
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
hmm... okay. I am continuously hearing about KInternet, however I don't even know how to get into it. Could you point me in the right direction on how to use/get to KInternet?

I'll post up the wvdial.conf in a minute.
 
Old 11-10-2005, 11:50 AM   #9
vmlinuz101
Member
 
Registered: Mar 2005
Location: Ireland
Distribution: LFS, SuSE, Debian, gentoo
Posts: 93

Rep: Reputation: 15
hi there. Your using SuSE 10 with KDE or GNOME presumably. The options you have accordingly are QInternet for GNOME and KInternet for KDE. These are frontends to pppd and wvdial (I think). They do allow you a fair amount of configuration at the start.
 
Old 11-10-2005, 11:54 AM   #10
mkIIIman089
LQ Newbie
 
Registered: Nov 2005
Location: Wantage, NJ
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
wvdial.conf:

[Dialer Defaults]
Modem = /dev/ttyS2
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S32=192
Init3 =
Area Code =973
Phone = 8751523
Username = (edited for forum)
Password = (edited for forum)
Ask Password = 0
Dial Command = ATDT
Stupid Mode = 0
Compuserve = 0
Force Address =
Idle Seconds = 300
DialMessage1 =
DialMessage2 =
ISDN = 0
Auto DNS = 1

I'm using GNOME so I'll be looking for QInternet. But how do I access it? Is it in the apps menu or is it a terminal thing?
 
Old 11-11-2005, 02:37 AM   #11
vmlinuz101
Member
 
Registered: Mar 2005
Location: Ireland
Distribution: LFS, SuSE, Debian, gentoo
Posts: 93

Rep: Reputation: 15
Sorry I had to run.. It should be in the apps menu.. On suse, it may be in the additional suse menu on the bottom of the drag-down menu.. Either way it's in Internet-Dialers 9or something). Your script looks ok. Why not use Yast2 to configure your dialer, it's much easier
 
Old 11-14-2005, 02:29 PM   #12
mkIIIman089
LQ Newbie
 
Registered: Nov 2005
Location: Wantage, NJ
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
bump... anyone?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I configure Kinternet on SuSE 9.2 to use pap script?? altech2k3 Linux - Networking 4 05-28-2005 11:47 PM
Chap 5 Binutils make LDFLAGS & make install errors shotokan Linux From Scratch 5 04-10-2005 03:01 AM
Sarge & PPPD RiSK Debian 4 02-19-2005 05:31 PM
PAP/CHAP Netscape FlameKhan Linux - Networking 8 02-03-2005 09:51 PM
pppoeserver with pap/chap know Linux - Networking 0 06-07-2003 09:14 AM


All times are GMT -5. The time now is 05:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration