LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Struggling with permissions on NAS drive (http://www.linuxquestions.org/questions/suse-novell-60/struggling-with-permissions-on-nas-drive-516927/)

rwhitworth 01-06-2007 12:14 PM

Struggling with permissions on NAS drive
 
I'm running SUSE 10.2, and have started moving some of my storage over to a NAS drive.

I mount the thing using the following in /etc/fstab:

//192.168.0.5/Music /home/russell/music cifs Username=Russell,password=xxx,uid=1000,gid=users,setuids 0 2

("Russell" is a user account on the NAS drive - and the authentication seems to work fine)

This all seems to work fine... my music collection now runs on the NAS drive. Amarok finds it and plays with no problems.

However, the first time I came to rip a new CD, I'm finding that KAudioCreator (and Grip) are complaining that they can't write to the new drive. It gets as far as creating a directory, which appears to be owned by me, but then complains that it can't create a file in the new directory.

Any thoughts, anyone?

rwhitworth 01-06-2007 12:49 PM

OK - fixed it (that was quick!)

It seems to be nothing to do with Linux - but something odd on the NAS. It's a Lindy Personal Server Premium.

I had set all the shares to "Authentication Free Access", which I assumed was the most open setting. If I change it to "Read/Write access for all users", then all is well.


All times are GMT -5. The time now is 01:28 PM.