LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2005, 04:18 PM   #1
samurai_jack_fan
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Rep: Reputation: 0
Starting the GUI....


Hi Linux Forums,

I'm a experinced windows user but have got so frustrated I figured it is time to try the alternative.

I've sucessfull installed suse 9.3 proffesional and everything was working fine, there were enough similarities for me to play around and not get too lost and concerned that I was breaking things. Now, two restarts later, when the computer boots it loads doen't load the GUI and all I see is a terminal (colourfull, but still a terminal) and after logon all I get is a prompt. I really miss the GUI.

I'm quite comfortable with the windows command line but I know exactly 0 linux commands and would like to learn at my own pace. How can I start the GUI back up again (1st priority) and make it do so by default on boot.

Thanks for your time,

Peter
 
Old 11-20-2005, 04:28 PM   #2
superdude_876
Member
 
Registered: Jan 2005
Location: Canada
Distribution: SuSE 10.0
Posts: 55

Rep: Reputation: 15
I don't know how to make it automaticly load into the GUI but typing startx should get you in there. And welcome to LQ!
 
Old 11-20-2005, 04:36 PM   #3
samurai_jack_fan
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Original Poster
Rep: Reputation: 0
humm,

Thanks superdude_876 for the quick reply.

'startx' returns the error "No startx installed".

I know there must be some kind of GUI installed, but couldn't say which one it was other than the one which suse installs by default.

Thanks

Peter
 
Old 11-20-2005, 05:00 PM   #4
superdude_876
Member
 
Registered: Jan 2005
Location: Canada
Distribution: SuSE 10.0
Posts: 55

Rep: Reputation: 15
Perhaps you should try running 'xf86config' at the command prompt and then after you have completed that type startx. BTW, the GUI you most likely have installed is KDE, just for reference.
 
Old 11-20-2005, 05:28 PM   #5
samurai_jack_fan
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Original Poster
Rep: Reputation: 0
grrr....

Thanks again superdude_876.

'xf86config' returns '-bash: xf86config: command not found'
 
Old 11-20-2005, 06:06 PM   #6
superdude_876
Member
 
Registered: Jan 2005
Location: Canada
Distribution: SuSE 10.0
Posts: 55

Rep: Reputation: 15
try that command loged in as root if you wern't already
 
Old 11-21-2005, 04:31 AM   #7
AdamCo
Member
 
Registered: Aug 2004
Distribution: Suse 10
Posts: 126

Rep: Reputation: 15
What do you mean by colourful?

Last edited by AdamCo; 11-21-2005 at 04:34 AM.
 
Old 11-21-2005, 08:31 AM   #8
diegoxcn
LQ Newbie
 
Registered: Nov 2005
Location: Shanghai, China
Distribution: RH 9 & SuSE 10 & Ubuntu 5.10
Posts: 10

Rep: Reputation: 0
Hello Peter, please check your /etc/inittab, the string in this file is like this: id:N:initdefault. Here, N is an integer. OK, if it's 3, just replace it with 5, then reboot.
But if it is still 5, you really should check you xf86config, but it's not call like this name now, I think, because I can't find it just like you. But I will go on to find it, so just do these things above, good luck!

Last edited by diegoxcn; 11-22-2005 at 06:13 AM.
 
Old 11-21-2005, 08:35 AM   #9
diegoxcn
LQ Newbie
 
Registered: Nov 2005
Location: Shanghai, China
Distribution: RH 9 & SuSE 10 & Ubuntu 5.10
Posts: 10

Rep: Reputation: 0
OK, we are all lucky dogs.
I find it, it's location: /etc/X11/XF86Config. Please notice that, 'XF' & 'C' is uppercase alphabet.

Now, just have a try.

Last edited by diegoxcn; 11-21-2005 at 08:37 AM.
 
Old 11-21-2005, 01:35 PM   #10
AdamCo
Member
 
Registered: Aug 2004
Distribution: Suse 10
Posts: 126

Rep: Reputation: 15
If by colorful you mean like a grey color you might be starting by default into xmd instead of kdm, this was a problem with Suse 9.3 reverting to xdm due to some conflicts. If this is the case then it's an easy fix.

1) login as root
2) type yast and hit enter
3) On the left side of yast click on System
4) On the right side open /etc/sysconfig editor or something similar
5) On the left side of the new window click to expand the desktop option and then expand the display manager one.
6) Click DISPLAYMANAGER
8) On the right side under Setting of: DISPLAYMANAGER, change it to say kdm (if it doesn't already say kdm)
9) Click finish

Last edited by AdamCo; 11-21-2005 at 01:44 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slax 4.1.4 Gui not starting negface Linux - Newbie 2 09-23-2004 07:43 PM
starting gui ltdlm Linux - Newbie 3 03-19-2004 06:10 PM
starting GUI garf12 Linux - Newbie 2 12-10-2003 06:27 AM
starting gui scudjockey Linux - General 2 03-17-2002 05:07 AM
My linux GUI isn't starting up :0 ( RancidLM Linux - General 3 10-25-2001 12:56 AM


All times are GMT -5. The time now is 12:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration