LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-30-2005, 05:01 PM   #1
Larsza
LQ Newbie
 
Registered: Sep 2005
Posts: 12

Rep: Reputation: 0
Soundcard/skype problem


This is weird. I use suse 9.3. Everything works pretty well. All audio applications/movie players handles sound correctly. But skype messes all up. When i want to call someone, often I get an error message "problem with sound device" and even though i rerun alsaconf, and I'm able to call, skype just won't work correctly. I have lots of echo, even feedbacks, the sound just disappears, then comes back on. I'm sure there is no firewall problem. In fact everything worked fine in the beginning.

Any other experiences like this? Suggestions?

Lars
 
Old 10-31-2005, 09:48 AM   #2
fouldsy
Senior Member
 
Registered: Jan 2002
Location: St Louis, MO
Distribution: Ubuntu
Posts: 1,284

Rep: Reputation: 47
Was Skype working properly at some point in the past? It doesn't sound like a firewall issue, but check within alsamixer or whatever mixer you use and check your line capture or similar isn't enabled, as it tries to capture anything from your mic and play it back. Doesn't work too well with Skype! Otherwise, what sound card do you have and what version of Skype do you have installed - there's a new version released a few days ago, with a SuSE package available.
 
Old 10-31-2005, 11:01 AM   #3
TigerLinux
Senior Member
 
Registered: Sep 2005
Location: Kuala Lumpur, Malaysia
Distribution: Ubuntu 11.04
Posts: 1,731

Rep: Reputation: 30
SKYPE exists in linux?
I better check it up.
 
Old 10-31-2005, 11:38 AM   #4
fouldsy
Senior Member
 
Registered: Jan 2002
Location: St Louis, MO
Distribution: Ubuntu
Posts: 1,284

Rep: Reputation: 47
Quote:
SKYPE exists in linux?
I better check it up.
Just for a little while Enjoy!
 
Old 10-31-2005, 12:10 PM   #5
gherikill
Member
 
Registered: Jan 2005
Posts: 56

Rep: Reputation: 15
I have had the same issue. "Problem with sound device" If I restart it usually fixes the problem.
 
Old 10-31-2005, 03:26 PM   #6
Larsza
LQ Newbie
 
Registered: Sep 2005
Posts: 12

Original Poster
Rep: Reputation: 0
It did work perfectly in the beginning. Now, I can't have a conversation but file transfers and chat still works fine. When i run alsaconf it tells me that I have a "intel8x0 Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97" card. Everything seems to be correctly detected and set up. Do you think my soundcard is the problem?

I just don't want to rerun alsaconf, or reboot my computer every time someone skypes me while I'm listening to music.
 
Old 10-31-2005, 03:47 PM   #7
zak317
Member
 
Registered: Oct 2005
Location: 500$/monthly
Distribution: Mandriva 2006
Posts: 56

Rep: Reputation: 15
What Skype version do you installed? I've got a lot of prob with sound in version 1.2.0.17 so I reinstalled the 1.1.0.13 and that solved all my problems....
 
Old 10-31-2005, 05:45 PM   #8
Larsza
LQ Newbie
 
Registered: Sep 2005
Posts: 12

Original Poster
Rep: Reputation: 0
OK, now everything works again. I did the following:

Uninstalled the newest skype rpm. I downloaded the zip/bz2 archive of the newest version. Run skype with the --resources-path /skype/sound commando.

After this step, it worked better but my friend still had problems with the echo when we spoke. Also my microphone was very low even if I had put all on max.

I started kmixer, and activated record under microphone (input tab). And everything just worked very well. Two questions though:

1) What does this activate record button do? Does it only sort of normalize the input volume? Or does it actually record the conversation?
2) How can I make a desktop icon linked to skype which also includes the --resources-path /skype/sound prefix? Or else I will not have any sound notifying.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get dependency problem (with skype) eantoranz Linux - Software 7 02-16-2006 07:26 PM
install skype GPG problem seow_ming Linux - Software 1 08-10-2005 04:56 AM
Sound problem with Skype der_kaiser1 Ubuntu 5 08-01-2005 12:42 PM
Mandrake 10.1 & Skype problem dolphans1 Mandriva 3 10-02-2004 08:55 AM
Skype problem Haroon Linux - Software 5 09-06-2004 03:09 PM


All times are GMT -5. The time now is 05:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration