LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-07-2009, 12:07 PM   #1
mbrager
LQ Newbie
 
Registered: Nov 2008
Posts: 9

Rep: Reputation: 0
Sound card issues in openSuse 11.0 and 11.1 X86_64 versions


I have been trying to get sound on my system running openSuse 64 bit with KDE for some time now. I have it running on a separate partition on a hard drive and with grub can boot into either Suse or Windows Vista. My sound card is an older Audigy 2 value card, which I'm using mostly because there's not enough room in my case for a longer card.
I upgraded to 11.1 last week but nothing different happened with the sound. I went through the configuration tutorial on the Suse website (http://en.opensuse.org/SDB:AudioTroubleshooting) with no success. I looked at the ALSA website and upgraded those drivers, etc. Nothing makes a difference: I don't get any sound, no test sounds, nothing. Everything else seems to work with my install. I can run video without sound, I can burn DVDs with no problem, but no sound.
I have been wondering if this is related to 64 bit version drivers not being mature, but I don't really know if this is the case.
Any recommendations you have would be welcome.
 
Old 02-08-2009, 03:22 PM   #2
Bugrem
Member
 
Registered: Nov 2004
Distribution: Suse 9.3, 10.0, 10.1, 10.3
Posts: 65

Rep: Reputation: 16
Hi
There seems to be an issue with sound with 11.0/1 - whether 32 or 64 bit. When logging on, something appears to be grabbing the sound card and refusing to let go!

Try typing into a terminal (as root); rcalsasound restart.

If the sound then bursts into life, that's what it is. It's a bit tiresome but, until someone figures out a workaround, you'll need to do it each time you log in.

HTH
B.
 
Old 02-08-2009, 04:32 PM   #3
mbrager
LQ Newbie
 
Registered: Nov 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your response. I tried what you suggested but didn't get any sound. I imagine I can't be the only one with this problem. It's kind of a deal breaker to using openSUSE isn't it?
 
Old 02-09-2009, 02:17 PM   #4
lauer
Member
 
Registered: Aug 2003
Location: Germany
Distribution: openSuSE
Posts: 61

Rep: Reputation: 16
It's hard to come up with a helpful answer with so little information. Did you check the log files? Did you try to start the driver in debug mode?

I even got the dreadful creative x-fi driver running under 11.0. Totally underwhelming quality, but better than nothing.
 
Old 02-09-2009, 11:46 PM   #5
mbrager
LQ Newbie
 
Registered: Nov 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for taking the time to respond to my question. I would love to submit the information you suggest, but I'm pretty new to Linux. Can you walk me through the steps?
I'd also be interested in trying the driver you suggest. Where do I find it and how can I install it? I have used Yast to install software so I'm familiar with that procedure. Again, thanks for any help you can give me.
 
Old 02-10-2009, 02:28 AM   #6
lauer
Member
 
Registered: Aug 2003
Location: Germany
Distribution: openSuSE
Posts: 61

Rep: Reputation: 16
You actually should be fine with the ALSA drivers. I only used the x-fi driver as an example that sometimes a little persistence is required

A good place to look is /var/log. I'm not at my linux box right now, but there might be an alsa log file. Otherwise check the messages log file for anything sound related. You can use the "dmesg" command to check what has happened during boot time.

It might actually be something simple, i.e. the driver is not started. Go to /etc/rc.d and start alsa manually with the script located there. As I said, I'm not near my linux box, so I can't be as specific as I would like. It should be something like './alsasound start'.

I realize that you are new to linux, but this might actually be a good opportunity to gain some understanding on how things work under linux. Free up some time, grab a coffee and start digging. It can be frustrating at times, but it feels good once you get it running. At least that's how it works for me (I'm currently struggling with openldap).
 
Old 02-10-2009, 08:01 AM   #7
anonymouser
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
I've got the same problem with sound an openSUSE 11.1 x86_64. I've googled the whole day but nothing works . Here I post my alsa-info.sh result for more details.
Code:
http://www.alsa-project.org/db/?f=05e08d1025480dece71e75002d919af06bfc77d7
I'll appreciate any helps.
Thanks in advance.
 
Old 02-11-2009, 05:06 PM   #8
Bugrem
Member
 
Registered: Nov 2004
Distribution: Suse 9.3, 10.0, 10.1, 10.3
Posts: 65

Rep: Reputation: 16
I've just installed and logged into KDE 3.5, went to 'Configure Desktop' - 'Sound and Multimedia' - 'Sound System', On the General tab, enabled the sound system, checked 'Run with the highest possible priority' and the 'Auto-suspend' boxes. Made sure that the audio device was ALSA (Hardware tab) and saved it.

Rebooted and logged back into KDE 4 - and all is now working fine.......?

B.

Last edited by Bugrem; 02-11-2009 at 05:31 PM. Reason: Elaborated
 
Old 02-12-2009, 10:30 AM   #9
mbrager
LQ Newbie
 
Registered: Nov 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Lauer:
I just had some time to try your suggestions about restarting the Alsa drivers and checking the log files. To my amazement, I got sound. Thanks so much for the suggestions.
Bugrem:
Your last post was less clear to me. What made you drop back to KDE 3.5? I presumed your own system was running adequately. I'm aware that there are issues with KDE 4 of course. Is there a difference in the configuration utilities?
I wondered if you (or anyone) can suggest a good book about using Linux commands. I was reminded of the old days of DOS commands before Windows, and obviously I'm just realizing something most of you have known for a while.
Thanks for your help and the time you took. Much appreciated.

Last edited by mbrager; 02-12-2009 at 10:34 AM. Reason: Wrong names in heading
 
Old 02-12-2009, 07:41 PM   #10
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,712

Rep: Reputation: 191Reputation: 191
Not on paper.

It isn't a book, but this is useful.

http://gd.tuwien.ac.at/linuxcommand.org/

Welcome to the linux party.
 
Old 02-14-2009, 01:56 PM   #11
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Rep: Reputation: 15
Same problem here, using Opensuse 11.1 x86 32bit

Same problem on my opensuse 11.1 x86 32bit, that I downloaded from the main site. I found this lines in my system log:
Feb 14 09:52:09 wildswede pulseaudio[3164]: pid.c: Stale PID file, overwriting.
Feb 14 09:52:10 wildswede pulseaudio[3164]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
Feb 14 09:52:10 wildswede pulseaudio[3164]: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_10de_6a_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.

For me seems like the pulseaudio is the one breaking the sound system.

I have all the updates from opensuse 11.1 repositories (update, oss and non-oss).

Any ideas?
 
Old 02-14-2009, 02:45 PM   #12
Bugrem
Member
 
Registered: Nov 2004
Distribution: Suse 9.3, 10.0, 10.1, 10.3
Posts: 65

Rep: Reputation: 16
mbrager
I use KDE 4 quite a bit. The KDE 3.5 sound setup has a few differences. The button "Enable Audio" is one. In my first post I said about restarting ALSA, and having to do it each time I logged on. After setting the sound up in 3.5, I no longer have to do anything in KDE 4 - it just works.

HTH
B.
 
Old 02-15-2009, 12:04 AM   #13
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Rep: Reputation: 15
Quote:
Originally Posted by Bugrem View Post
mbrager
I use KDE 4 quite a bit. The KDE 3.5 sound setup has a few differences. The button "Enable Audio" is one. In my first post I said about restarting ALSA, and having to do it each time I logged on. After setting the sound up in 3.5, I no longer have to do anything in KDE 4 - it just works.

HTH
B.
Can you specify the steps to log in kde 3.5 within 4.1? I'm a little confuse by your actions. It will be nice if I can do that to.

Thanks in advance.
 
Old 02-15-2009, 11:42 AM   #14
mbrager
LQ Newbie
 
Registered: Nov 2008
Posts: 9

Original Poster
Rep: Reputation: 0
thorkelljarl
Thanks for the link. It looks like a great tutorial, perfect for me. Lots of tips and tricks. Thanks again.
 
Old 02-15-2009, 03:55 PM   #15
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,712

Rep: Reputation: 191Reputation: 191
Thank you for the thanks.

Here are two other links you might find useful.

http://www.linux.org/lessons/beginner/toc.html

http://tldp.org/index.html

Useful advice, that's what Vikings are for.
 
  


Reply

Tags
opensuse, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
openSUSE 11.0 x86_64; No sound in Skype 2.0.x linux_junky Suse/Novell 9 06-01-2009 11:44 PM
Fedora 9 Kernel Source for both x86_64 and i[3|4|5|6]86 versions... amitra Fedora - Installation 1 11-14-2008 10:58 AM
opensuse 11 - compiz x86_64, libcompizconfig 586... wait, what? where is x86_64 ver? almcneill Suse/Novell 9 09-28-2008 10:36 AM
Sound problem at openSuSE 10.2. Sound card unidentified perfectly Fakhri Linux - Hardware 0 04-29-2007 10:01 PM
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-30-2005 11:35 PM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration