LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-01-2006, 05:38 PM   #1
deathbox
LQ Newbie
 
Registered: Aug 2005
Location: Belgium (though Im danish)
Distribution: SuSE Linux
Posts: 3

Rep: Reputation: 0
Sound card configure crash; No Sound


As no sound could be played under a fresh SuSE 10.1, even after making sure the right codecs were installed, I tried to configure the sound card:

1. Open YaST
2. Click Hardware icon
3. Click Sound icon

Sound window opens

4. One Sound card with no number, but with a Card Model name of "P4P800 Mainboard," is on the list.
5. Press the Edit Button.
6. Sound window closes down, and nothing happens.

My reaction to that was to try to install the sound card again. I checked the sound card, via the Hardware Information button in YaST, and found it to be using an "Intel ICH" driver.

After trying to install the sound card again several times, each time trying a new Intel ICH-something driver, I sat helpless and gave the sangria a needful stare.

I know for a fact that my sound card is an ASUSTeK something or other.

I do know a little about Linux, been using it on and off for 3 years, I know how to work with the console and the filesystem, but I still am an apprentice wizard.

Thankyou for your time.
Peter
 
Old 09-10-2006, 07:45 PM   #2
YvesGagnon
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
Smile

Hi,

I had the same problem as you did, except I was using two audio card, the onboard and a SB live. I took me 4 hr to figure out how to fix that problem. Here are the step I finally found:
Note, this is not the best/ideal method, but it worked for me.
1- Go into yast-->hardware-->sound, look at the driver name. In my case, it was snd-hda-intel
for motherboard audio snd-emu10k1 for the creative lab PCI-card.
2- Exit yast
3- Go at the shell (right click on the desktop-->open Terminal)
4- Log as super user (enter ¨su¨) and enter your password
5- Go to the directory with the config files: ¨cd /etc/sysconfig/hardware¨ (this is the folder
that took me very long to find)
6- Find the file that hold the driver: ¨grep -i snd-emu10k1 *¨ the filename containing the
config
7- move that file somewhere else as a backup (who knows, you might do a mistake)
8- reboot,
9- Go into yast-->hardware-->sound, the audio board should have bee re-discover, do edit and
then test if the audio works.

Have fun
 
Old 09-11-2006, 12:26 AM   #3
usaf_sp
Member
 
Registered: Jul 2005
Location: Tennessee
Distribution: openSUSE
Posts: 419

Rep: Reputation: 30
If you are using KDE, sometimes the KMix switch is set to external amplifier. This will cause no sound to be heard. Uncheck the External Amplifier and readjust your sound controls.

Good Luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How Do I Configure My Sound Card? Nukem Red Hat 13 04-11-2004 12:45 PM
Can't configure my sound card! fahdaziz Linux - Hardware 2 03-18-2004 09:17 PM
cant configure sound card in 2.2.2 gare39 Linux - Hardware 0 02-18-2004 10:50 AM
how to configure sound card? lpriyamb Linux - Software 22 10-21-2003 06:09 AM
Configure Sound Card!?? FreakboY Linux - Newbie 1 09-09-2002 12:35 PM


All times are GMT -5. The time now is 07:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration