LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   soudcard settings not persistent in SuSE 9.2 (http://www.linuxquestions.org/questions/suse-novell-60/soudcard-settings-not-persistent-in-suse-9-2-a-307732/)

piratu 03-30-2005 06:24 AM

soudcard settings not persistent in SuSE 9.2
 
hi,

I've just installed SuSE 9.2 on my system (Dell Dimension 2400 / P4 2.8GHz / 512MB RAM / i845 GII video onboard / sound onboard AC'97) and except an installation in text mode (I've got an awful resolution in graphic mode) all was recognized and installed.

to test the sound I've put in some OGGs and "amarok" (if I remeber well the name of the audio player proposed by default by SuSE team) playied them well at the first use of the newly installed 9.2

I've dome some custom settings (like configuring the dual boot) and reboot to see how it works ... fine, but when back again (reboot & load linux) the sound wouldn't want to work in any way.

so, I saw that amarok uses aRts as sound engine and to solve my problem I've installed xmms and deleted and reconfigured the sound card and used alsa sound engine to play my OGGs.

strange thing is that I have to launch, every time when I'm booting linux, YAST2 to reconfigure (autodetect) my soundcard to make it works.

is it anyway to make the sound card setting permanents? (persistents)

PS : btw, how do I configure aRts? ... and why so many sound engines : OSS, ALSA, eSound and aRts, which one of them must I choose?

thanks in advance

ithawtewrong 03-30-2005 12:12 PM

Some suggestions on things to check:

1. Check to make sure your user account has membership in the audio group. (Yast -> Security and Users -> Edit and Create Users -> Edit User -> Details -> Select Audio in the column on the right.)

2. Yast -> H/W -> Sound -> Volume - check your volume levels. I have seen this on my system where they zero out when adding or reconfiguring sound levels via other applications.

If this doesn't fix your issue repost specifics and someone else may be able to assist you since this is about the extent of my experience with these issues.

Good luck.

piratu 03-31-2005 07:32 AM

I've added myself to the "audio" group, detected again and setting the volume via YAST, reboot the system and nothing ... radio silence on that frequency ... :(

I have to run YAST to detecte & set volume each time I want to play something and this is embarasing.

my soundcard hardware specification says : ADI 198x Integrated Audio (in windows I've installed the SoundMax drivers suite)

ithawtewrong 03-31-2005 07:47 AM

I'll keep trying here but my knowledge is limited.

Can you provide the output of the command lspci?

You may want to look at your boot/err/warn logs too.

I did find this post that may help you, but it's not specific and you'll need the info from the lspci command to continue.

http://www.linuxquestions.org/questi...003/09/2/92254

This may help you too:

http://linux.derkeiler.com/Mailing-L...4-02/4951.html

piratu 04-01-2005 02:47 AM

thanks for the links, I think that I found the info on the ALSA's site.

I'll try it and tell you after that to see if it works or not.


All times are GMT -5. The time now is 11:49 PM.