LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-19-2007, 04:19 PM   #1
jquinn
LQ Newbie
 
Registered: Sep 2007
Location: Buffalo NY
Posts: 9

Rep: Reputation: 0
Software Update-> Failed to start X server - Fatal error inserting NVIDIA


hello,
recently did a software update in Suse 10.2
New NVDIA drivers selected.


upon reboot I get the following error:
"xserver disabled restart GDM when configured correctly"

"Failed to start the x server ... It is likely that it is not set up correctly. Would you like to view the x server output to diagnose the problem?"

YES ->

X windows system 7.1.99.902 (7.2.0 RC2)
Release Date: 13 Nov 2006
X Protocol Version 11, Revision 0, Release 7.1.99.902
Build Op System openSUSE SUSE Linux
Current Op System linux-PD 2.6.18.8-0.5-default#1smp
Module Loader Present

...
Fatal error inserting NVIDIA (/lib/modules/2.6.18.8-0.5-default
(EE) NVIDIA (0) Failed to load the NVIDIA Kernel Module



Stuck at login prompt.
Found a thread that suggested to boot into failsafe mode, login as root and run SAX2, but it aborts out and says that it couldnt start the configuration server: /var/log/SaX.log


very long to type here...
any suggestions?



thanks
jquinn
 
Old 09-19-2007, 04:32 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You could edit /etc/X11/xorg.conf and change the driver from nvidia to nv. Once you have X up and running, try reinstalling the nvidia driver.
 
Old 09-19-2007, 07:00 PM   #3
jquinn
LQ Newbie
 
Registered: Sep 2007
Location: Buffalo NY
Posts: 9

Original Poster
Rep: Reputation: 0
I did as you said and I was able to get xserver back, thanks

lets see if I can goof up the driver update.




jquinn

Last edited by jquinn; 09-19-2007 at 07:39 PM.
 
Old 09-20-2007, 08:44 AM   #4
jquinn
LQ Newbie
 
Registered: Sep 2007
Location: Buffalo NY
Posts: 9

Original Poster
Rep: Reputation: 0
I went to this site
http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html

however I dont see instructions for Suse 10.2/Intel 64bit

does anyone have any suggestions?



thank you for your time
jquinn
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Error inserting ndiswrapper raxxal Mandriva 7 07-06-2007 01:27 PM
Fatal: error inserting ip_tables magiconexxx Linux - Security 1 11-04-2006 10:05 AM
FATAL: Error inserting ndiswrapper derfaust Slackware 11 06-03-2006 02:41 PM
FATAL: Error inserting ivtv xvalentinex Linux - Software 2 01-31-2006 12:45 AM
X won't start: "Fatal server error: failed to initialize core devices" ! Debianewb Linux - Newbie 14 08-27-2002 05:21 PM


All times are GMT -5. The time now is 02:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration