LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-21-2012, 04:34 AM   #1
wallisgj
LQ Newbie
 
Registered: Dec 2012
Posts: 1

Rep: Reputation: Disabled
Slow overnight running on nomachine session speeds up on interacting with the machine


Dear experts,

This is an odd question, but it's had me scratching my head. I work on analysis of scientific data using MATLAB based packages, and I often login remotely using nomachine software to run code overnight, so the results are ready for me to inspect in the morning.

I've noticed a few times that when running code overnight, it seems to run extremely slowly. However, when I login in the morning to check progress, it immediately speeds up, simply through my interacting with the MATLAB window to check how it's doing.

It's a big speed change: a processing step that took 17 minutes during the night now takes 2. The speed-up was from the moment I logged on.

No-one else uses the machine, and nothing else, other than the gnome system monitor, is running on the machine. There is an automated night-time backup service, but there's no way that takes all night to run, although I'm wondering if it's somehow re-niceing my analysis code. However, on checking this morning the process has niceness 0, as usual. Also, no swap space is being used, and it's highly unlikely to be a RAM issue, as this analysis uses much less RAM than the machine has.

The machine is a 6-core workstation running SLED SUSE linux.

Any tips on what might be going on much appreciated!

best wishes
George
 
Old 12-21-2012, 11:54 AM   #2
sntnlz
Member
 
Registered: Jun 2005
Location: Virginia, USA
Distribution: openSUSE 12.3 / Debian 6.0.6
Posts: 34

Rep: Reputation: 17
I would've said the nightly backup was at least partially responsible but you seem to have looked into and ruled this out. Perhaps something changed in your power management settings which is leading to the machine running at lower CPU frequency while it's not "user-busy" overnight to supposedly conserve energy and in which case tweaking these might help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Interacting with running shells (Fedora 15) vachon Linux - Newbie 4 06-21-2011 08:44 PM
slow nomachine nx with FC2 bcmurray75 Fedora 7 05-10-2011 09:16 PM
Nomachine on RHEL 4/5 - Timeout in session download nsx241 Linux - Software 1 01-04-2010 09:52 PM
My Machine running slow? your_shadow03 Linux - Newbie 6 11-26-2009 07:18 AM
GnuCash via FreeNX (NoMachine) KDE session jst1 Suse/Novell 0 08-19-2005 01:11 PM


All times are GMT -5. The time now is 03:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration