LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-19-2006, 03:53 PM   #1
glimmersdad
LQ Newbie
 
Registered: May 2006
Distribution: SuSE 10.0
Posts: 2

Rep: Reputation: 0
Sendmail/Saslauthd problem/SuSE 10.0


I'm upgrading from SuSE 9.1, sendmail 8.12.10, saslauthd 2.1.18 to SuSE 10.0, sendmail 8.13.4, saslauthd 2.1.21 on a new machine so they're both running now (when the old one doesn't crash, which it does frequently).

On the old system, I've been running SMTP AUTH set up using Jon Fullmer's directions (Google "fullmer smtp auth" to find the page). On the new system, it doesn't work.

According to the output of <sendmail -d0.11>, both versions are compiled with the same options. (I'm using SuSE's builds.) And <saslauthd /status> says both saslauthd executables have the same suite of auth mechanisms (plus LDAP for the newer one).

I've run <saslauthd -d> on both systems. On the old system, when you telnet into sendmail by hand and do AUTH LOGIN, saslauthd writes to the terminal with a few lines status info as your authentication progresses. On the new system, there's no output so I conclude that sendmail is not communicating with saslauthd. Yes, I have the proper /usr/lib/sasl2/Sendmail.conf file with the line "pwcheck_method: saslauthd" on both systems. On the new system, I can run <testsaslauthd> and authenticate a user and see the -d debug info on the screen even though sendmail can't seem to connect to that same saslauthd process when I run it.

I've got the standard LOGIN PLAIN lines in linux.mc:

define(`confAUTH_OPTIONS', `A')dnl
define(`confAUTH_MECHANISMS', `LOGIN PLAIN')dnl
TRUST_AUTH_MECH(`LOGIN PLAIN')dnl

I thought this covered all the bases, but apparently I've skipped something. If you know what's missing, or need to know one more config item in order to help out, please write in.

-- Glimmersdad
 
Old 05-19-2006, 04:00 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
Sorry, this isn't a more specific answer.

I used SiegeX's howto here at http://www.linuxquestions.org/questi...d.php?t=224543 on 2 boxes. It might provide a way of cross-checking what you've done.
 
Old 05-19-2006, 04:16 PM   #3
glimmersdad
LQ Newbie
 
Registered: May 2006
Distribution: SuSE 10.0
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks, Steve, but I've already been through it :-) I've already spent a bunch of time on this, unfortunately. Still, I'll have another look.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Saslauthd - User/pass Problem (read Size Error) mmilan Linux - Networking 0 11-09-2005 07:05 AM
sendmail cannot access saslauthd server msound Linux - Software 0 09-13-2005 03:12 AM
sendmail problem in Suse 9.2 delamatrix Suse/Novell 3 08-02-2005 05:10 PM
Postfix SMTP AUTH, Problem using saslauthd + pam k1e0x Debian 0 10-19-2004 06:21 PM
Sendmail Problem on SuSe 8.1 sjuerges Linux - Newbie 2 12-01-2003 01:08 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration