LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2006, 04:46 PM   #1
mrkstapleton
LQ Newbie
 
Registered: Jul 2006
Location: Amarillo. Texas
Distribution: Ubuntu 9.04
Posts: 8

Rep: Reputation: 0
Screen Goes Blan Instead Of Screen Saver


Hello,

I'm a rookie, not quite a newbie. I have turned off all power saving functionality but my screen blanks out instead of the screen saver running. I have tried different saves all with the same result.

I's SuSe 10.1 as bad as I am reading is some of the posts?


Mark S.
Amarillo, TX
 
Old 09-23-2006, 05:03 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Seen this before in Fedora but never could figure out why it happened. To get around this I did the following and was using KDE as gui.
Disable screensaver from the KDE control panel
Now open a terminal window and run the command ' xscreensaver & '
Quickly click on the settings tab and setup as needed.
If I remember when you test one and come back the settings screen is gone. Open a second terminal window and use the command ' xscreensaver-demo ' and go back to modifing.
When done I add ' xscreensaver & ' to my /etc/rc.loca file. This may only apply to Redhat and Redhat clone distros. You may have to create a new service for it or add to an existing service that is running.

Brian1
 
Old 09-23-2006, 05:10 PM   #3
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
This bugged me for a long time also, but I recently figured out what was causing it. It's the monitor power-saving support in X. You can turn it off with the command "xset -dpms" (and on again with "xset +dpms"). See man xset for more options. To make it permanent, edit your xorg.conf file and remove the dpms entry from the monitor section.

Of course, I could be wrong and you might be experiencing some other problem instead.
 
Old 09-23-2006, 05:12 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I would give David the H. idea a try first. I would like to know if that would work as well. Such an easy fix.

Brian1
 
Old 09-23-2006, 05:24 PM   #5
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Rep: Reputation: 33
my suse 10.1 did the same thing and I tried many of the workarounds but not until I updated did it start working..
Goodluck,
jolphil
 
Old 09-23-2006, 05:25 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
My issues seemed to be with KDE 3.5.2. Beleived 3.5.3 fixed it but not sure.

Brian1
 
Old 09-23-2006, 08:11 PM   #7
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
From the xscreensaver manual, here's how to start xscreensaver at boot instead of the kde screensaver. It worked for me:

USING KDE (K DESKTOP ENVIRONMENT)
I understand that KDE has invented their own wrapper around xscreensaver, that is inferior to xscreensaver-demo (1) in any number of ways. I've never actually seen it, but I'm told that this is the way you disable it:
1: Switch off KDE's screen saver.
Open the ``Control Center'' and select the ``Look and Feel / Screensaver'' page. Turn off the ``Enable Screensaver'' checkbox.
2: Find your Autostart directory.
Open the ``Look and Feel / Desktop / Paths'' page, and see what your ``Autostart'' directory is set to: it will probably be ~/.kde3/Autostart/ or something similar.
3: Make xscreensaver be an Autostart program.
Create a file in your autostart directory called xscreensaver.desktop that contains the following five lines:

[Desktop Entry]
Exec=xscreensaver
Name=XScreensaver
Type=Application
X-KDE-StartupNotify=false

4: Make the various "lock session" buttons call xscreensaver.
Replace the file /usr/bin/kdesktop_lock with these two lines:

#!/bin/sh
xscreensaver-command -lock
Make sure the file is executable (chmod a+x).

Now use xscreensaver normally, controlling it via the usual xscreensaver-demo (1) and xscreensaver-command (1) mechanisms.
 
Old 09-24-2006, 10:25 AM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Nice fix there pilotgi. I will make a note on that one for future refernece. After seeing the chmod commands I remember it seemed to be a permissions issues that caused the blank screen.

Brian1

Last edited by Brian1; 09-24-2006 at 10:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change the background for X windows and set to fill whole screen and set screen saver eatranman Linux - Newbie 2 05-10-2006 08:41 PM
ATI 9200 SE screen flicker in screen saver gargamel Slackware 12 07-09-2005 04:10 PM
screen saver goes off and screen goes black Doug.Gentry Suse/Novell 2 03-26-2005 05:08 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
Blank screen - screen saver ??? cstehle Linux - Newbie 8 03-13-2002 09:44 PM


All times are GMT -5. The time now is 08:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration