LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Screen Goes Blan Instead Of Screen Saver (http://www.linuxquestions.org/questions/suse-novell-60/screen-goes-blan-instead-of-screen-saver-486338/)

mrkstapleton 09-23-2006 04:46 PM

Screen Goes Blan Instead Of Screen Saver
 
Hello,

I'm a rookie, not quite a newbie. I have turned off all power saving functionality but my screen blanks out instead of the screen saver running. I have tried different saves all with the same result.

I's SuSe 10.1 as bad as I am reading is some of the posts?


Mark S.
Amarillo, TX

Brian1 09-23-2006 05:03 PM

Seen this before in Fedora but never could figure out why it happened. To get around this I did the following and was using KDE as gui.
Disable screensaver from the KDE control panel
Now open a terminal window and run the command ' xscreensaver & '
Quickly click on the settings tab and setup as needed.
If I remember when you test one and come back the settings screen is gone. Open a second terminal window and use the command ' xscreensaver-demo ' and go back to modifing.
When done I add ' xscreensaver & ' to my /etc/rc.loca file. This may only apply to Redhat and Redhat clone distros. You may have to create a new service for it or add to an existing service that is running.

Brian1

David the H. 09-23-2006 05:10 PM

This bugged me for a long time also, but I recently figured out what was causing it. It's the monitor power-saving support in X. You can turn it off with the command "xset -dpms" (and on again with "xset +dpms"). See man xset for more options. To make it permanent, edit your xorg.conf file and remove the dpms entry from the monitor section.

Of course, I could be wrong and you might be experiencing some other problem instead.

Brian1 09-23-2006 05:12 PM

I would give David the H. idea a try first. I would like to know if that would work as well. Such an easy fix.

Brian1

jolphil 09-23-2006 05:24 PM

my suse 10.1 did the same thing and I tried many of the workarounds but not until I updated did it start working..
Goodluck,
jolphil

Brian1 09-23-2006 05:25 PM

My issues seemed to be with KDE 3.5.2. Beleived 3.5.3 fixed it but not sure.

Brian1

pilotgi 09-23-2006 08:11 PM

From the xscreensaver manual, here's how to start xscreensaver at boot instead of the kde screensaver. It worked for me:

USING KDE (K DESKTOP ENVIRONMENT)
I understand that KDE has invented their own wrapper around xscreensaver, that is inferior to xscreensaver-demo (1) in any number of ways. I've never actually seen it, but I'm told that this is the way you disable it:
1: Switch off KDE's screen saver.
Open the ``Control Center'' and select the ``Look and Feel / Screensaver'' page. Turn off the ``Enable Screensaver'' checkbox.
2: Find your Autostart directory.
Open the ``Look and Feel / Desktop / Paths'' page, and see what your ``Autostart'' directory is set to: it will probably be ~/.kde3/Autostart/ or something similar.
3: Make xscreensaver be an Autostart program.
Create a file in your autostart directory called xscreensaver.desktop that contains the following five lines:

[Desktop Entry]
Exec=xscreensaver
Name=XScreensaver
Type=Application
X-KDE-StartupNotify=false

4: Make the various "lock session" buttons call xscreensaver.
Replace the file /usr/bin/kdesktop_lock with these two lines:

#!/bin/sh
xscreensaver-command -lock
Make sure the file is executable (chmod a+x).

Now use xscreensaver normally, controlling it via the usual xscreensaver-demo (1) and xscreensaver-command (1) mechanisms.

Brian1 09-24-2006 10:25 AM

Nice fix there pilotgi. I will make a note on that one for future refernece. After seeing the chmod commands I remember it seemed to be a permissions issues that caused the blank screen.

Brian1


All times are GMT -5. The time now is 01:56 AM.