LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-24-2007, 09:18 AM   #16
Lord Ghost
Member
 
Registered: Jul 2003
Posts: 68

Rep: Reputation: 15

Quote:
Originally Posted by saikee View Post
If you regard extended partition is advanced user stuff and wish to work only with primaries it is your choice. Nobody can disagree with you or deny your rights.
I have two things to say, and I'm done:

#1: The above statement really shows that you are a furry toothed nerd. Please try to respond only to questions that start: "I know this is a weird thing to be doing to a beowulf cluster..."

#2: Awwww, thank you Saikee for sticking up for my rights! You're a very special person!

Cheers,
Ghost
 
Old 12-24-2007, 09:45 AM   #17
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
gumb,

Just a thought when you say you need to go to the Bios to boot up Suse every time. Have you got a password or setting set up in the Bios to prevent changes?

It so happen my Suse 10.3 is also in the 5th partition with fstab as follow
Code:
/dev/sdb5   /                    ext3       acl,user_xattr        1 1
/dev/sda4 /abit                ext3       defaults              0  0
/dev/sda5 swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/fd0             /media/floppy        auto       noauto,user,sync      0 0
It boots normally with menu.lst entries
Code:
###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd1,4)
    kernel /boot/vmlinuz-2.6.22-rc4-git3-2-default root=/dev/sdb5 resume=/dev/sda5 splash=silent showopts
    initrd /boot/initrd-2.6.22-rc4-git3-2-default
The point about Suse 10.3 is its new kernel 2.6.22 no longer distinguishes between IDE and Sata disks and everyone is given the name sda, sdb, sdc, sdd....etc according to the order each one is detected.

Last edited by saikee; 12-24-2007 at 09:58 AM.
 
Old 12-25-2007, 07:34 AM   #18
gumb
LQ Newbie
 
Registered: Oct 2005
Distribution: openSUSE
Posts: 27

Original Poster
Rep: Reputation: 15
There's no password set in the BIOS. There is a BIOS-Protect setting but I've already disabled that for the time being. There's also a jumper on the board for preventing flashing of the BIOS which is enabled, but that doesn't inhibit the detection of new devices. I tried disabling it anyway but it makes no difference to the boot capabilities. I also used YaST's Boot Loader to copy GRUB into the extended partition container, having read on an official Novell document somewhere that this is a slightly esoteric setting but one which is known to work well on most hardware. So, possibly GRUB now exists in two locations, I'm not sure about that but I don't think it does any harm anyway and I'm convinced it's the BIOS that's at fault.

The board is a QDI model about 3 - 4 years old, and may have been an early model to feature both PATA and SATA support. I've read some comments on other forums suggesting some such early versions were designed to boot only from PATA, and that SATA support was only meant to be there for additional disks. However, from experimenting it seems to be purely an issue with mixing PATA and SATA in the precise way that I want to. My new SATA DVD drive should be here by the end of the week and then all will be revealed as to whether that is the case.

In fact, I could (and should) probably have tested this beforehand, simply by unplugging the secondary IDE drives from the motherboard and seeing if it can boot reliably from the SATA disk left on its own. I'm sure it can, else it would surely make some comment to the effect in the relatively detailed manual. The SATA port 0/1 options in the BIOS are either Disabled, Auto or Manual. If set to manual, it then allows for either:

Primary Master / Slave
Secondary Master / Slave
Logical Primary / Secondary
Tertiary Master / Quartenary Master

I've tried setting it to any of these whilst my two PATA drives occupy the secondary IDE ports, and I've tried disabling either or both of the IDE ports too. Whatever I try, it doesn't seem to abide by my settings in the expected way. Only when set to Auto does it appear to test a few configurations of its own, and then after a few boots settle on something that allows it to boot every time but without the functionality of the IDE ports. When I return to the BIOS to see what greyed-out settings appear under the SATA Auto setting, it's different all the time.

I think that so long as something is plugged into any IDE port, it will always try to boot from that first (this is what I read on other forums about old SATA motherboards). So regardless of what setting I make it will hunt for a CD or floppy and then produce a disk boot failure. Without anything on IDE it might just go straight to the SATA ports first. Of course, I do have the boot order set to HDD-0, CDROM, Floppy. I even tried setting the third option as various others such as SCSI, USB, HDD-2/3 etc, just in case it was set to detect SATA devices as such, but again no difference.

This is probably more information than anybody needs, but I guess it can sit here in the archive should someone else ever be searching for similar clues.
 
Old 12-25-2007, 10:27 AM   #19
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I have tried a maximum of booting 9 hard disks from my current mobo; 3 internal Sata, 1 internal Pata, 3 external disks via USB, one external disk via firewire and one external disk eSata. I am quite sure a mobo is supposed to allow a user to select any disk to boot first from any of the attached or onboard hdd controllers.

As far as I know the Bios controls the booting by

(a) different devices from floppy, CD/DVD, internal hard disk, USB device etc

(b) hard disks or USB devices in an order as specified by the user.

You can select any hard disk as the first bootable disk. The booting is then controlled by whatever is in its MBR. Thus if you have say an IDE/Pata disk and a Sata you should be able to nominate wither one as the first boot disk. The Bios will load its MBR into the memory and the boot loader inside will load its second part from any partition of any disk to complete the first phase of the booting process. The second phase is for the boot loader to load ing actual system.

The MBR is only 512 byte long and has almost no intelligence. The working portion is always from the second stage of the boot loader. For both Grub and Lilo the second stage can "sourced" from any partition in any disk.

If you have only one disk hda and the /boot is in hda5 then the MBR of the device hda will conatin the hard disk address for the first sector of hda5. That is how OpenSuse boot itself. It needs to give you a screen to choose which system to boot and acts on it once a selection is made. It can only do so if the stage2 of Grub in /boot is obtained and loaded.

So my question is if you are getting a Grub screen showing different alternatives and able to select Suse then Grub is working properly from a logical partition.

Although this thread has been dragged on a bit some basic information about your problem is still unknown.

Do you get a Grub screen for selecting booting choices at all?

According to your description you can't even select the only hard disk to boot. You seem to need to go into the Bios to specify it each time. Is this correct? So is your problem basically not able to select a hard disk, from the choices of floppy, CD, USB etc, to boot?

Can you boot the system with a floppy?

You can created a bootable floppy in Suse as follow

(1) fire up Suse in any way you can (ask help if you can't)
(2) Click terminal mode, type "su", give the password and fire up a Grub shell by command "grub"
Code:
grub
(3) Stick a spare floppy into the drive and type
Code:
root (hd0,4)
setup (fd0)
quit
This tells Grub to source its system files from the 5th partition of the 1st disk, as Grub counts from 0, and set itself up in device fd0 which is the 1st floppy drive.

That floppy can boot up Suse if the Bios is told to boot the floppy as the first bootable device.
 
Old 12-25-2007, 06:53 PM   #20
gumb
LQ Newbie
 
Registered: Oct 2005
Distribution: openSUSE
Posts: 27

Original Poster
Rep: Reputation: 15
I've always been able to see the GRUB menu and select options from there, but half the time the system doesn't get that far. Instead it tries to find something on either the CDROM or floppy and then produces a boot failure. To remedy the situation, I have to restart, go into the BIOS and simply 'Save & Exit', even without having made any changes. It will virtually always then boot to GRUB and onwards, unless I've set a bad configuration. If I leave the openSUSE DVD in the drive (assuming I haven't set the SATA option to Auto and thereby possibly disabled the IDE ports) then it will always boot to the DVD first time, even though the boot order preference is HDD-0 and then CDROM. IDE always seems to get priority.

It just ignores the SATA drive on first boot (often on restarts too) regardless of what settings I have. Just the presence of the drives on the secondary IDE ports seems to throw it, because there's an underlying conflict. According to all the literature in the motherboard manual, this shouldn't happen because it will boot from IDE or SATA. In my previous post, I listed the SATA port options, though what I omitted were the extra details listed in the manual for each of these. They describe how choosing certain options will enable / disable the IDE ports and allow for either IDE / SATA boot or both.

So a SATA boot is perfectly feasible, apparently, and indeed it does perform this after I've paid a visit to the BIOS or left it on Auto for a few boots. I think that whatever logic might dictate in this situation has to be thrown out the window, because there's an undocumented conflict that arises on this board / BIOS if you try to boot from a SATA drive whilst other IDE drives are present.

At least, this is what I've whittled it down to. Like I said before, I should have just unplugged the IDE ports altogether to verify this, before splashing out on an assumed solution with my new DVD drive, but somehow at that moment the idea hadn't come to me in analysing so many options and expecting it all to be more complex than it perhaps is.
 
Old 12-25-2007, 08:16 PM   #21
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
It appears to me your Grub is working satisfactorily.

There may be an error in the Grub's configuration file /boot/grub/menu.lst resulting Grub unable to pass the control to the Linux kernel.

Have you bypass the hard disk booting with a floppy as I suggested previously?

Can you post here the file /boot/grub/menu.lst in the partition hda5?
 
Old 12-29-2007, 05:57 PM   #22
gumb
LQ Newbie
 
Registered: Oct 2005
Distribution: openSUSE
Posts: 27

Original Poster
Rep: Reputation: 15
Well I've not had much access to the computer over recent days, but the SATA DVD drive arrived yesterday and I was heartbroken / frustrated / steaming with fury (take your pick) to discover upon removing the old IDE devices and inserting the new drive that I still had the same blasted problem. In subsequent hours I went through every BIOS configuration change that I thought could make any difference, and then prepared to try the suggestion from saikee of making a boot floppy, so I could report back here with the findings.

Of course, it was on this final restart that I decided to try just one last thing that has miraculously - at least at this stage - appeared to cure the problem. It was simply a case of changing the 'Quick Power On Self Test' setting in the BIOS from Enabled to Disabled. As far as I can gather, this is most likely to point to an issue with the drive not spinning up fast enough to be recognised on a cold boot, unless somebody can provide an alternative diagnosis?

The strange and annoying thing about this, though, is that I'd already discounted this possibility soon after the issue first arose, because I had problems originally on both cold and warm boots, hence the drive was already spinning when it was failing. I'd heard of this problem a few times in the past having read other forums over the years, but ruled it out because the logic didn't add up given the series of events that was occurring. I can only conclude that there was indeed some other configuration issue with the IDE drives (though possibly one that could have been resolved using this same BIOS self test setting if I'd known what the other drive settings should have been), and now without them I eliminated one half of the problem.

So anyway, thanks for all the suggestions. Hopefully I can lay the issue to rest but I'd be interested to hear anybody's analysis on why this problem exists, given that it's a brand new Samsung SpinPoint 500gb SATA drive, surely faster at spinning up than the old IDE Maxtor drive that was present beforehand? I've used many drives in many systems over the years and never had to adjust the Quick Power On setting in the BIOS with any of them. Does the extra testing perform some other check that might help the BIOS detect the boot partition properly?

I'll have another fiddle with a few other BIOS settings over coming days and attempt to confirm that it is just this one Self Test setting that is screwing everything. A couple of weeks on from inserting the new hard drive and hoping to have everything sorted and up and running properly by the end of that evening, I'm instead left with a faster DVD drive featuring Lightscribe, but a 30 quid hole in my pocket and a lost Christmas frustratedly sat fiddling with a blue screen. Then again, I hate Christmas, so I need something to divert my attention.
 
Old 12-29-2007, 06:32 PM   #23
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Thanks for letting us know this peculiar problem and its solution. I wonder if it is mobo-related or not.
 
  


Reply

Tags
bios, drive, extended, logical, numbering, partition, primary, sata, special


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me avoid ever losing data again Z038 Linux - General 12 10-09-2006 02:32 AM
Repartitionning without losing data mimithebrain Linux - General 6 10-22-2005 04:38 PM
Repartitioning without losing data Cdzin Slackware 4 01-30-2005 08:27 PM
'Losing' installed programs in YAST bizshop Linux - Software 3 12-19-2004 09:58 AM
Repartitioning Without Damaging Data Cr4wford Linux - Hardware 5 11-02-2003 01:06 PM


All times are GMT -5. The time now is 01:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration