LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-15-2007, 07:02 AM   #1
yyarin
LQ Newbie
 
Registered: Feb 2007
Location: Toronto, Ontario, Canada
Distribution: SUSE 10.2
Posts: 8

Rep: Reputation: 0
Removable Hard Disk


Hi, I'm maybe slightly more knowledgeable than a newbie. I'm using SUSE 10.2, which I set up recently, and had the same thing in SUSE 10.1.

Here's the problem. I have a huge external hard drive on which I store movies, music etc. I plug it into the computer and it works fine. The problem arises when I try to move files around, and it says I don't have permission. I check in the properties to see what the permissions are like and see that they are set to access only for everybody.

I figure that root should be able to access that and change those permissions. I log into root try to change them, but it just says this drive is a read-only drive. But that is not true because I used to write/ delete all the time when I was using windows.

So I think that the problem is how the system recognizes the nature of the drive maybe. I have no idea.

Thank you for reading.
 
Old 02-15-2007, 07:33 AM   #2
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,846

Rep: Reputation: 128Reputation: 128
It sounds like it's the way you external drive is being mounted. Can you post the output of "cat /etc/fstab" and "mount" (without the quotes), and we'll go from there.
 
Old 02-16-2007, 10:16 AM   #3
yyarin
LQ Newbie
 
Registered: Feb 2007
Location: Toronto, Ontario, Canada
Distribution: SUSE 10.2
Posts: 8

Original Poster
Rep: Reputation: 0
Can you post the output of "cat /etc/fstab" and "mount"

I don't know what to do with that...
 
Old 02-16-2007, 05:17 PM   #4
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,846

Rep: Reputation: 128Reputation: 128
You need to open up a terminal (or konsole), and type:
Code:
cat /etc/fstab
and also
Code:
mount
and then copy the output from those two commands into a reply here.
 
Old 02-19-2007, 08:44 PM   #5
yyarin
LQ Newbie
 
Registered: Feb 2007
Location: Toronto, Ontario, Canada
Distribution: SUSE 10.2
Posts: 8

Original Poster
Rep: Reputation: 0
Done, here it is: (this includes my removable hard disk as well as my removable flash drive, and the problem is with the both of them, also c is for some strange reason refers to the removable hard disk)

yyarin:~ # mount
/dev/hda2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hda3 on /home type ext3 (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
yyarin:~ # cat /etc/fstab
/dev/hda2 / ext3 acl,user_xattr 1 1
/dev/hda3 /home ext3 acl,user_xattr 1 2
/dev/sda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
yyarin:~ # mount
/dev/hda2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hda3 on /home type ext3 (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
/dev/sda1 on /windows/C type ntfs (ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8)
/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev,shortname=winnt,uid=1000)
 
Old 02-20-2007, 09:23 AM   #6
cormack
Member
 
Registered: Oct 2005
Location: Scotland, UK
Distribution: Kubuntu 9.10, ubuntu 8.04.2 server
Posts: 156

Rep: Reputation: 30
securityfs on /sys/kernel/security type securityfs (rw)
/dev/sda1 on /windows/C type ntfs (ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8)
/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev,shortname=winnt,uid=1000)

I am assuming that /dev/sda1 is your external drive, and therefor it is formatted to NTFS. Although i cant think why you would have a problem copying files off it, writing to NTFS in linux does not have very much support, and you may not have that ability installed or have the correct kernel modules.

U mite need to update your kernel to one with NTFS write support, or better yet, back up the external drive, format to FAT32 or ext2, then put it all back on. Just remember you need to install the app that lets yopu rite to ext2 in windows then
 
Old 02-20-2007, 09:29 AM   #7
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,846

Rep: Reputation: 128Reputation: 128
I'm guessing the directory you're having trouble with is /windows/C? The reason you can't write (including moving files) to /dev/sda1 (which is accessible as /windows/C), is because that's an NTFS formatted partition. What that means is that only windows can reliably write to that partition. There are some programs out there which allow linux to write to NTFS, and I believe kernel support is almost there too, but I still don't trust it. In essence, you won't be able to write to that partition (no matter which user you are) from within Linux; only windows will allow you to do that.

There is lots of information on why you can't totally work with NTFS drives from within Linux, but suffice it to say, since Microsoft created NTFS, they haven't released all the information needed to correctly create a driver which will read and write to NTFS.

Just to clarify a little, the line in the output you copied and pasted which is of interest is this:
Code:
/dev/sda1 on /windows/C type ntfs (ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8)
specifically the section I've highlighted in bold. What that says is that /dev/sda1 (which is the partition of your external disk) is mounted at /windows/C, with a filesystem type of ntfs, with further options of readonly (ro). Therefore, you cannot write to it as it is currently mounted.

The part umask=0002 tells the operating system that only "everybody" can access it (represented by the 2), where as a user or a group cannot (the zeroes). For further information, I suggest you take a look at this short page, which explains the "user, group and everybody" system: http://www.ahinc.com/linux101/permission.htm

edit: Beaten to it!

edit 2: I see no reason why /dev/sdb1 (/media/disk) shouldn't work though, as fat filesystems are fully supported in linux (read and write).

Last edited by pwc101; 02-20-2007 at 09:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling rwx permissions on my removable USB hard disk? mejpark Suse/Novell 11 10-10-2006 01:08 PM
How can I reinstall grub into my removable hard disk? whut-linux Linux - Laptop and Netbook 5 09-23-2006 04:24 PM
60GB laptop hard disk & 200GB external USB hard disk linux compatibility powah Linux - Hardware 0 03-07-2006 10:55 AM
Removable disk problem! Braveheart1980 Linux - General 3 02-11-2004 03:58 AM
LAN backup to a removable hard disk chakkerz Linux - Networking 3 12-16-2003 06:11 PM


All times are GMT -5. The time now is 03:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration