LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-19-2005, 08:54 PM   #1
cheetahman
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 10/Windows XP
Posts: 208

Rep: Reputation: 30
Read-only mount error at boot


Can't save the edits to my fstab so i can log back into Suse
 
Old 03-19-2005, 10:33 PM   #2
tdonoughue
Member
 
Registered: Feb 2005
Location: The Woodlands, TX
Distribution: Ubuntu
Posts: 44

Rep: Reputation: 15
As you might envision, your description of the problem is lacking in a few critical details, such as:
1) who are you logged in as?
2) if you are getting this 'read-only mount error' at boot, how is it that you are logging in?
3) when and where is the 'read-only mount error' appearing?
4) what, exactly, does the error say?
5) how are you trying to edit fstab? directly or via the config utilities?

Can you give us a couple of those answers, please?
 
Old 03-20-2005, 03:09 PM   #3
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Additionally, you need to be running with root privs in order to edit fstab. If you've been attempting to edit it as a regular user, you won't be able to save changes.

In any case though, please provide more details, as already suggested -- J.W.
 
Old 03-20-2005, 08:31 PM   #4
cheetahman
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 10/Windows XP
Posts: 208

Original Poster
Rep: Reputation: 30
the mount output in knoppix

/dev/root on / type ext2 (rw)
/dev/scd0 on /cdrom type iso9660 (ro)
/dev/cloop on /KNOPPIX type iso9660 (ro)
/ramdisk on /ramdisk type tmpfs (rw,size=406488k)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
automount(pid705) on /mnt/auto type autofs (rw,fd=4,pgrp=705,minproto=2,maxproto=4)
/dev/sda1 on /mnt/sda1 type vfat (rw,nosuid,nodev,umask=000,uid=1000,gid=1000)
/dev/hda5 on /mnt/hda5 type reiserfs (rw,nosuid,nodev)
/dev/hda7 on /mnt/hda7 type reiserfs (rw,nosuid,nodev)
/dev/hda2 on /mnt/hda2 type ntfs (ro,nosuid,nodev,umask=000,uid=1000,gid=1000)
/dev/hda1 on /mnt/hda1 type vfat (ro,nosuid,nodev,umask=000,uid=1000,gid=1000)
 
Old 03-20-2005, 08:47 PM   #5
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,579

Rep: Reputation: 187Reputation: 187
"the mount output in knoppix"

If you have booted a Knoppix CD in order to edit /etc/fstab on SuSE then your problem is that Knoppix mounts all hard drive partitions as read only. Assuming that /dev/hda5 is your SuSE / partition then you need to:
umount /dev/hda5
mount -t reiserfs /dev/hda5
and then edit /dev/hda5/etc/fstab

--------------------------
Steve Stites
 
Old 03-20-2005, 09:01 PM   #6
cheetahman
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 10/Windows XP
Posts: 208

Original Poster
Rep: Reputation: 30
more information

I am trying to edit the fstab with either Knoppix or Suse in maintence mode by overwriting the new fstab with the old one.

Yes i got 2 errors and tried to run Reiserfsck --fix-fixable

su
chroot /mnt/hda7/

he error I get is
bash:/dev/null:Permission denied
knoppix:/#

vi /etc/fstab

press i and edit, then press Esc, and then type :w so save and :q to exit, then restart the comp with Ctrl+D.

Got this error

--Insert-W10:Warning:Changing a reaonly file
E325:Attention

(1) Another person may be editing the file

(2)Edit session for this file crashes
In this case use :recovwer or vim -r /etc/fstab
to recover the changes if did this already delte swap file ?etc/.fstab.swp to avoid this message

E303 Unable to open swap file for "/etc/fstab",recovery impossible

E505:"/etc/fstab" is read-only (add ! to override)

Here is the output of mount in knoppix

/dev/root on / type ext2 (rw)
/dev/scd0 on /cdrom type iso9660 (ro)
/dev/cloop on /KNOPPIX type iso9660 (ro)
/ramdisk on /ramdisk type tmpfs (rw,size=406488k)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
automount(pid705) on /mnt/auto type autofs (rw,fd=4,pgrp=705,minproto=2,maxproto=4)
/dev/sda1 on /mnt/sda1 type vfat (rw,nosuid,nodev,umask=000,uid=1000,gid=1000)
/dev/hda5 on /mnt/hda5 type reiserfs (rw,nosuid,nodev)
/dev/hda7 on /mnt/hda7 type reiserfs (rw,nosuid,nodev)
/dev/hda2 on /mnt/hda2 type ntfs (ro,nosuid,nodev,umask=000,uid=1000,gid=1000)
/dev/hda1 on /mnt/hda1 type vfat (ro,nosuid,nodev,umask=000,uid=1000,gid=1000)

Updated Fstab

/dev/hda7 / reiserfs rw,acl,user_xattr 1 1
/dev/hda2 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda6 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/hda5 /mount/dev/hda5/mnt/1GB_native reiserfs auto,acl,user_xattr 1 2
/dev/cdrom /media/cdrom subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/sda1 /media/usb-storage-Y3KQ3YTE:0:0:0p1 ext3 acl,user_xattr 1 2

Last edited by cheetahman; 03-21-2005 at 02:19 PM.
 
Old 03-21-2005, 06:30 PM   #7
cheetahman
Member
 
Registered: Feb 2005
Distribution: SuSE Linux 10/Windows XP
Posts: 208

Original Poster
Rep: Reputation: 30
Yeah, an fstab config problem...lovely, huh? Honestly, the best way to fix this is to load the SUSE CD and select Installation from the menu options. Let it boot the kernel and proceed along until it finishes the system analysis section. At this point, YaST will attempt to detect existing Linux installations and when it notices that you have SUSE installed it should give you the option to perform a repair session. From here, you can select some manual repair parameters or just have YaST do an auto-repair. I would just go with the latter, but if you desire to get straight on with a file check that should work as well.

YaST should then verify your fstab file and present you with errors that it finds.
Make the needed changes at this point.

On your next boot you should be fine.

I need Help on doing this

Last edited by cheetahman; 03-21-2005 at 06:31 PM.
 
Old 03-21-2005, 07:16 PM   #8
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
YaST System Repair
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error mounting ext3 filesystem... mount: /dev/hdd1: can't read superblock versaulis Linux - Software 5 11-26-2006 09:34 PM
Read Only Error at boot II cheetahman Suse/Novell 1 04-03-2005 08:09 PM
Read-only mount error at boot cheetahman Suse/Novell 9 03-07-2005 03:33 AM
kernel panic unable to mount root (yes ive read/read other posts) dmx9595 Linux - General 4 01-17-2004 06:07 AM
GRUB read error with dual boot with XP gatekeepa Linux - Newbie 1 06-14-2003 06:03 AM


All times are GMT -5. The time now is 04:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration