LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Q for Picasa users (http://www.linuxquestions.org/questions/suse-novell-60/q-for-picasa-users-598573/)

cbjhawks 11-10-2007 08:29 AM

Q for Picasa users
 
I've had Picasa installed before but recently I've had to reinstall OpenSuSE 10.2 and now Picasa will not load...I dont
remember any errors during the install and the program appears in the proper menu category but regardless what I try the program as user or root nothing loads.

I click on the program icon and after a few seconds of spinning the icon disappears and nothing happens....am I missing some libs or what could be the problem?...is there a log I could check for missing libs/erros?

marozsas 11-10-2007 12:46 PM

Try to run picassa in a terminal so you can see any errors message in that terminal.
To figure out what command line you should use, right click on the icon and choose properties.
In the launcher tab, copy the command field and paste it on the terminal and press ENTER.
There are several messages as the normal launch of program and you need to figure out what messages are errors and what are just regular ones.

cbjhawks 11-11-2007 09:20 AM

thanks morozsas...will give that a try...
 
and post the results later. :)

cbjhawks 11-12-2007 09:23 AM

for marozsas...no luck/joy...
 
I found Picasa located in the below directory...when I tried to launch it from the cli nothing happen....the cursor returned but the program did not launch....???

cbjhawks@linuxfan:~> cd /usr/bin
cbjhawks@linuxfan:/usr/bin> picasa
cbjhawks@linuxfan:/usr/bin> cd /opt/picasa/bin
cbjhawks@linuxfan:/opt/picasa/bin> ls
icons killpicasa mediadetector picasa postinstall setpicasascreensaver showpicasascreensaver wrapper xsu
cbjhawks@linuxfan:/opt/picasa/bin> ./picasa
cbjhawks@linuxfan:/opt/picasa/bin>

marozsas 11-12-2007 11:01 AM

The file /opt/picasa/bin/picasa is a bourne shell script.
Try to run it in verbose mode:
Code:

$ bash -vx /opt/picasa/bin/picasa
... a lot of commands finishing with....
# Then, actually run Picasa
exec "$PIC_BINDIR"/wrapper license.exe.so  /gate Picasa2 "$*"
+ exec /opt/picasa/bin/wrapper license.exe.so /gate Picasa2 ''

As you can see above, the script ends by calling "/opt/picasa/bin/wrapper".

Try to run it in verbose mode and may be you see an error message somewhere.

Other alternatives are:
1) move $HOME/.picassa to $HOME/old.picassa and try to run picassa again
2) uninstall picassa, remove the /opt/picassa and re-install it

cbjhawks 11-12-2007 03:37 PM

will give those thoughts a try...
 
thanks....


All times are GMT -5. The time now is 08:44 PM.