LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2013, 07:41 AM   #1
yossarian42
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Rep: Reputation: 0
Problems with nvidia drivers in 12.2 - glxinfo "couldn't find RGB GLX visual"


I tried to install the NVidia drivers using the 1-click install on the openSuse wiki, but it didn't seem to work properly. My laptop stopped booting properly - it would get to "Started Postfix Mail Transport Agent" and hang (I guess that's a red herring, and it's really failing on the next step). I could get a virtual console to reboot the computer and then boot with the failsafe kernel.

I then uninstalled the NVidia drivers through yast and reinstalled the nouveau drivers.

Now, I can't start steam. It fails with this message:
Code:
OpenGL GLX extension not supported by display
The output of glxinfo is:
Code:
$ glxinfo                                                                                                                                                                                
name of display: :0                                                                                                                                                                             
Error: couldn't find RGB GLX visual or fbconfig
and lspci:
Code:
$ sudo lspci | grep vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 9300M GS] (rev a1)
It looks like nouveau is actually installed:
Code:
$ lsmod | grep nouveau
nouveau               844746  1 
ttm                    91974  1 nouveau
mxm_wmi                12979  1 nouveau
drm_kms_helper         51052  2 nouveau,i915
drm                   272508  6 nouveau,ttm,i915,drm_kms_helper
i2c_algo_bit           13413  2 nouveau,i915
button                 13906  2 nouveau,i915
wmi                    19070  2 nouveau,mxm_wmi
video                  19345  2 nouveau,i915
So why does my computer think it doesn't have openGL/GLX?
 
Old 01-27-2013, 08:52 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Check your /var/log/Xorg.0.log file for any errors.

Adam
 
Old 01-27-2013, 09:46 AM   #3
yossarian42
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Here are the warnings and errors in my Xorg.0.log:

Code:
egrep '\((EE|WW|NI)\)' /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    30.440] (WW) The directory "/usr/share/fonts/URW/" does not exist.
[    30.452] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[    31.669] (WW) Falling back to old probe method for fbdev
[    31.670] (WW) Falling back to old probe method for vesa
[    31.758] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
I've tried searching for that error message, but all the advice is conflicting and unhelpful. I've given up trying to get the nvidia drivers to work, now I just want the nouveau ones to work properly again!
 
Old 01-27-2013, 09:49 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Code:
[    31.758] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
X is still trying to use the nvidia GLX extension, which you still have installed on your machine. Apparently you did not completely remove the nvidia driver.

Adam
 
Old 01-27-2013, 10:38 AM   #5
yossarian42
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Ok, how do I find out what is still left behind and remove it?
 
Old 01-27-2013, 12:37 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,062

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
i just upgraded from 12.1 ( been using opensuse since 11.1 ) to 12.2

the "one click" installed the nvidia 304 driver
from my experience on 12.1 that driver is ( well crap ) it is very buggy .So buggy that on 12.1 i HAD to drop down to the nvidia 295 driver

however the new 310 and the 313.18 BETA nvidia driver seam to work just fine

"the hard way"
it really is not that hard .YOU just need to do a bit of reading
http://en.opensuse.org/SDB:NVIDIA_the_hard_way
and have to manually reinstall the .run for EVERY kernel update
-- it is just a bit more "time consummating" than hard --

also those instructions are a bit OLD ,very old

so if you want to use the .run let me know and i can post the FULL instructions for 12.2


you will need to edit files using just the text only terminal ( no gui ) using "nano" ( it will need to be installed )
 
Old 01-27-2013, 12:48 PM   #7
yossarian42
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I've tried installing 313 the hard way, but I couldn't get it to work, it would always fail to start X. I managed to work out that if I told it not to create an Xorg.conf, then it would start X. However, I still didn't have access to openGL. The errors in Xorg.0.log were like:

Code:
libglamoregl.so: undefined symbol: _glapi_tls_Context
Googling this error is no help whatsoever.

How did you manage to get it working?
 
Old 01-27-2013, 07:50 PM   #8
John VV
Guru
 
Registered: Aug 2005
Posts: 13,062

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
before we mess around with the " *.run " driver

lets see about installing the nvidia proprietary driver with yast instead of the nouveau driver

suse uses a TON of automated scripts ( so much so that nvidia has a special section in the install guide JUST FOR SUSE )

SUSE is rpm based BUT they very differently that any other rpm based distro ( think red hat,centos,fedora,...)

from the above posts you do know how to add a repo in the yast GUI
but to just go over it ( i am assuming you are using the default KDE 4 desktop)


the "kick off application launcher" -- the thing that is in the same place as the windows "start"
Warning:
yast has a very "annoying default behavior of closing after EVERY task
this can be changed ,but that is for a new thread.

computer / install/remove software
-- type in the root password in the pop-up--
At the top of the gui window click on "configuration" then select "repositories" from the drop down menu
then in the new window click on "add"
put a dot on the radio checkbox for "community repositories" and click "next"
put a check on the "nvidia Graphics driver" and click "ok" then after a few seconds and back to a older window click "ok" again

then back in the "install/remove software" main window
click on "view" and select "repositories"
from that select nvidia

put a check on "X11-video-nvidiaG02"
( bottom of the list )
that will auto add the other two needed packages

then click "accept"

when it is done reboot

this will be the 304.64 driver


this will auto do all the configuring of the system to use the proprietary driver

then IF ( you might not need it ? unknown for now ) then installing the 310 .run will be VERY easy
IF you need it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
glxinfo "couldn't find rgb glx visual or fbconfig" on nvidia drivers MikeyCarter Linux - Software 3 10-13-2009 08:15 AM
America's Army "Cannot find matching GLX visual", XFree86 4.3, 128MB ATI Radeon 9200 RavenOfOdin Linux - Games 7 02-06-2006 06:09 PM
damn fireGLCouldn't set video mode: Couldn't find matching GLX visual Kilka Linux - Games 0 11-27-2003 08:01 PM
ut2003--- couldn't set video mode:couldn't find matching GLX visual <h1>tux</h1> Linux - Newbie 1 08-22-2003 07:17 PM


All times are GMT -5. The time now is 03:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration