LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2007, 11:40 AM   #1
amitabhishek
Member
 
Registered: Jul 2006
Location: Bombay, India
Distribution: Ubuntu (Hardy Heron)
Posts: 118

Rep: Reputation: 15
Problems with Acer aspire 4520


Hi,

I use Acer aspire 4520 with SLED on it. Among other things, the first and foremost is that I want to connect to Internet via a LAN (no proxy).I tried configuring it through Yast but of no help. Lspci is as under:

root@slax:~# lspci
00:00.0 RAM memory: nVidia Corporation: Unknown device 0547 (rev a2)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 0548 (rev a2)
00:01.1 SMBus: nVidia Corporation: Unknown device 0542 (rev a2)
00:01.2 RAM memory: nVidia Corporation: Unknown device 0541 (rev a2)
00:01.3 Co-processor: nVidia Corporation: Unknown device 0543 (rev a2)
00:02.0 USB Controller: nVidia Corporation: Unknown device 055e (rev a2)
00:02.1 USB Controller: nVidia Corporation: Unknown device 055f (rev a2)
00:04.0 USB Controller: nVidia Corporation: Unknown device 055e (rev a2)
00:04.1 USB Controller: nVidia Corporation: Unknown device 055f (rev a2)
00:06.0 IDE interface: nVidia Corporation: Unknown device 0560 (rev a1)
00:07.0 Class 0403: nVidia Corporation: Unknown device 055c (rev a1)
00:08.0 PCI bridge: nVidia Corporation: Unknown device 0561 (rev a2)
00:09.0 IDE interface: nVidia Corporation: Unknown device 0550 (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation: Unknown device 054c (rev a2)
00:0c.0 PCI bridge: nVidia Corporation: Unknown device 0563 (rev a2)
00:0e.0 PCI bridge: nVidia Corporation: Unknown device 0563 (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation: Unknown device 0533 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:09.0 FireWire (IEEE 1394): Ricoh Co Ltd: Unknown device 0832 (rev 05)
01:09.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
01:09.2 System peripheral: Ricoh Co Ltd: Unknown device 0843 (rev 12)
01:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
01:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
07:00.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001c (rev 01)
root@slax:~#


Also thr is no sound, no compiz fusion, color depth is only 65000. Can anyone help pls...pls.
 
Old 12-21-2007, 04:28 AM   #2
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
Quote:
Ethernet controller: Atheros Communications, Inc.: Unknown device 001c (rev 01)
Ethernet controller: nVidia Corporation: Unknown device 054c (rev a2)
No proper drivers have been found during installation.

Did your installation go wrong somewhere?
or maybe the nvidia drivers dont come with the installation, I guess you would need to download them of the nividia site. i.e. if they do support linux.

Last edited by w3bd3vil; 12-21-2007 at 04:30 AM.
 
Old 12-21-2007, 05:04 AM   #3
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
w3bd3vil: translation "I don't know". Well done - first step to wisdom. Better watch that next step, it's a doozy

Those devices have no free drivers, thus openSUSE (and fedora for that matter) will not support them out of the box.

Aetheros device is the wifi nic, supported via madwifi.
nVidia device is the wired nic, probably forcedeth drivers will do it.

See other thread:
http://www.linuxquestions.org/questi...7/#post2997733
 
Old 12-21-2007, 04:55 PM   #4
jepuzon
LQ Newbie
 
Registered: Jun 2004
Location: Philipines
Distribution: Slackware, OpenBSD
Posts: 13

Rep: Reputation: 0
Hi,

This seems to me that most of your hardware are not known by SLED. This is self explanatory since SLED was release almost 2 years ago if I'm not mistaken. And this Acer model has been recently released this year.

root@slax:~# lspci
00:00.0 RAM memory: nVidia Corporation: Unknown device 0547 (rev a2)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 0548 (rev a2)
00:01.1 SMBus: nVidia Corporation: Unknown device 0542 (rev a2)
00:01.2 RAM memory: nVidia Corporation: Unknown device 0541 (rev a2)
00:01.3 Co-processor: nVidia Corporation: Unknown device 0543 (rev a2)
00:02.0 USB Controller: nVidia Corporation: Unknown device 055e (rev a2)
00:02.1 USB Controller: nVidia Corporation: Unknown device 055f (rev a2)
00:04.0 USB Controller: nVidia Corporation: Unknown device 055e (rev a2)
00:04.1 USB Controller: nVidia Corporation: Unknown device 055f (rev a2)
00:06.0 IDE interface: nVidia Corporation: Unknown device 0560 (rev a1)
00:07.0 Class 0403: nVidia Corporation: Unknown device 055c (rev a1)
00:08.0 PCI bridge: nVidia Corporation: Unknown device 0561 (rev a2)
00:09.0 IDE interface: nVidia Corporation: Unknown device 0550 (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation: Unknown device 054c (rev a2)
00:0c.0 PCI bridge: nVidia Corporation: Unknown device 0563 (rev a2)
00:0e.0 PCI bridge: nVidia Corporation: Unknown device 0563 (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation: Unknown device 0533 (rev a2)



Since you are using an older version of SUSE, try using their OpenSUSE 10.3. Video, sound and webcam works for me. Mine is Acer Aspire 4520G. Just stick to YaST when configuring your hardware. If you don't want to upgrade yet. Update your version of SUSE immediately. Don't forget to add the NVIDIA Repositories.
 
Old 12-21-2007, 08:09 PM   #5
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
Simon, I couldnt really understand what you meant.
 
Old 12-21-2007, 11:16 PM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
SLED was release almost 2 years ago if I'm not mistaken
SLED 10 SP1 was released some months ago. People may have picked up free copies at the last Software Freedom Day. This is a good point though - the distro version was not specified.

The advice is sound: either, change to openSUSE 10.3 or use the commercial support you paid for (SFD copies came with free updates for 6 months.) If you do not want to pay for support, that's fine, but you'll be happier using a non-commercial distro.

Last edited by Simon Bridge; 12-21-2007 at 11:20 PM.
 
Old 12-21-2007, 11:49 PM   #7
amitabhishek
Member
 
Registered: Jul 2006
Location: Bombay, India
Distribution: Ubuntu (Hardy Heron)
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Simon Bridge View Post
w3bd3vil: translation "I don't know".
I think it means WEBDEVIL.

Meanwhile I am continuing with my quest to put life into my laptop.
 
Old 12-23-2007, 08:40 AM   #8
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
I think [w3bd3vil] means WEBDEVIL.
Well, I'm certain it means "webdevil". I was "translating" the content of the webby one's post... but, since it turns out to be too cryptic of me, I apologize. I'm content to let the matter drop without further comment.

How are you getting on with your issues?
 
Old 12-23-2007, 09:30 AM   #9
amitabhishek
Member
 
Registered: Jul 2006
Location: Bombay, India
Distribution: Ubuntu (Hardy Heron)
Posts: 118

Original Poster
Rep: Reputation: 15
don't know Man! You can view my thread almost all the forums. Currently trying my luck at a couple of Suse forums.
 
Old 12-23-2007, 09:46 AM   #10
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Have you tried ndiswrapper for your wifi?
Have you tried the forcedeth driver for your ethernet?
... you see, you have provided zero feedback to the suggestions on this thread - it's kinda discouraging.
 
Old 12-23-2007, 10:06 AM   #11
amitabhishek
Member
 
Registered: Jul 2006
Location: Bombay, India
Distribution: Ubuntu (Hardy Heron)
Posts: 118

Original Poster
Rep: Reputation: 15
not at all, pls check here:
http://www.linuxquestions.org/questi...e-4520-607537/


I used this thread so that I may get a more focussed reponse.
 
Old 02-20-2008, 02:08 PM   #12
mpicco
LQ Newbie
 
Registered: Feb 2008
Location: Northern California
Distribution: openSUSE, FC8, freeBSD
Posts: 2

Rep: Reputation: 0
openSUSE 10.3 on Acer Aspire 4520

I have found that the ethernet connection works with a fresh install (using the 32-bit version). Sound and wireless still escape me. Has anyone solved these two issues?

Thanks.
 
Old 02-20-2008, 06:09 PM   #13
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Install nvidia proprietory driver package - the supply output of lspci.
 
Old 02-21-2008, 11:36 PM   #14
mpicco
LQ Newbie
 
Registered: Feb 2008
Location: Northern California
Distribution: openSUSE, FC8, freeBSD
Posts: 2

Rep: Reputation: 0
Thanks

I'm not quite clear on what you've suggested ... being somewhat of a newbie and all ... could you be a little bit more specific?

Thanks for the response.
 
Old 02-22-2008, 09:48 PM   #15
amitabhishek
Member
 
Registered: Jul 2006
Location: Bombay, India
Distribution: Ubuntu (Hardy Heron)
Posts: 118

Original Poster
Rep: Reputation: 15
If you have 4520 and you want Ubuntu 7.10 then this thread should be your bible.For wireless you may want to look here.

Alternatively get Sabayon it provides out of the box support to most of the hardware (on this laptop) including ethernet & nVidia graphics.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Ubuntu 7.10 on Acer aspire 4520 amitabhishek Linux - Laptop and Netbook 28 02-20-2008 06:19 PM
acer aspire 4520 riple Linux - Laptop and Netbook 1 10-15-2007 02:40 AM
which distro suitable for acer aspire 4520 zero717k Linux - Laptop and Netbook 2 09-10-2007 02:50 PM
Laptop Problems (Acer aspire 3682wxci) Boom_Fist Linux - Laptop and Netbook 1 08-14-2007 04:23 PM
laptop Acer Aspire 1522 Problems JJX Debian 2 01-01-2005 05:44 PM


All times are GMT -5. The time now is 04:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration