LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2009, 07:12 PM   #1
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Unhappy Problem with media players


hiii to every one,
i am using SUSE 11.0 KDE 4.0
i had installed Totem player, VLC media player from 1-click install avialable from SUSE download site (software.opensuse.org) and VLC site (www.videolan.org) respectively.
Now my problem is -----, when ever i tried to open video files ( they are *.avi format ) in any of those 2 players , the window of player opens, they play 1 or 2 seconds clip of movie and then disappears.
the same files are playing nice ...in WINDOWS XP..
but in SUSE they are just showing player window and disappearing !!

plzz help me !!
 
Old 01-23-2009, 05:13 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Do they actually start to play the video, or not?

It sounds as if both are instantly crashing / getting killed.

Have you tried starting them from the commandline and examining if you see any error reported there?

Also, have you tried MPlayer? IMO it is better than Totem or VLC for playing videos. It has an extremely complete codec pack, in 5 years of use I have very rarely been able to find a file it could not play (It does have difficulty consistently with some .FLV files though).
 
Old 01-23-2009, 06:52 AM   #3
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Original Poster
Rep: Reputation: 92
yes... they starts playing, but within seconds of time ... player automatically closes.

plz tell me how to open in commandline , So that i can see error report if any ...
 
Old 01-23-2009, 06:57 AM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
Quote:
Originally Posted by raju.mopidevi View Post
yes... they starts playing, but within seconds of time ... player automatically closes.

plz tell me how to open in commandline , So that i can see error report if any ...
you can issue the following commands:

Code:
 
vlc film.avi
mplayer film.avi
 
Old 01-23-2009, 06:00 PM   #5
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Original Poster
Rep: Reputation: 92
i had tried above command
Code:
raju@linux-d6yt:~> vlc /home/raju/public_html/MVI_0894.AVI
VLC media player 0.9.8a Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.8a Grishenko - (c) 1996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure  '--prefix=/usr' '--libdir=/usr/lib' '--disable-dependency-tracking' '--enable-gnomevfs' '--enable-ncurses' '--enable-wxwidgets' '--disable-pda' '--disable-macosx' '--disable-qnx' '--enable-xosd' '--enable-gnutls' '--enable-visual' '--disable-goom' '--enable-slp' '--enable-lirc' '--disable-joystick' '--disable-corba' '--enable-dvdread' '--enable-dvdnav' '--disable-dshow' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-vcd' '--enable-satellite' '--enable-ogg' '--enable-mkv' '--enable-mod' '--enable-libcdio' '--enable-vcdx' '--enable-cddax' '--enable-libcddb' '--enable-x11' '--enable-xvideo' '--enable-glx' '--enable-fb' '--enable-mga' '--enable-freetype' '--enable-fribidi' '--disable-svg' '--disable-directx' '--disable-wingdi' '--disable-glide' '--enable-aa' '--enable-caca' '--enable-oss' '--disable-esd' '--enable-arts' '--enable-waveout' '--disable-coreaudio' '--disable-hd1000a' '--disable-hd1000v' '--enable-mad' '--enable-ffmpeg' '--enable-faad' '--enable-a52' '--enable-dca' '--enable-flac' '--enable-libmpeg2' '--enable-vorbis' '--enable-tremor' '--enable-speex' '--disable-tarkin' '--enable-theora' '--enable-cmml' '--enable-utf8' '--enable-pth' '--disable-st' '--disable-gprof' '--disable-cprof' '--disable-testsuite' '--enable-optimizations' '--disable-altivec' '--disable-debug' '--enable-release' '--enable-sout' '--with-ffmpeg-faac' '--disable-galaktos' '--enable-httpd' '--disable-jack' '--enable-mozilla' '--enable-alsa' '--enable-real' '--enable-realrtsp' '--enable-live555' '--with-live555-tree=/usr/lib/live' '--enable-fast-install' '--enable-dvbpsi' '--enable-dvb' '--enable-lua' '--enable-pulse' '--enable-asademux' '--enable-libproxy' '--enable-libass' '--enable-kate' '--enable-smb'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[????????] x11 video output error: X11 request 140.19 failed with error code11:
 BadAlloc (insufficient resources for operation)
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  91
  Current serial number in output stream:  92
raju@linux-d6yt:~>
as shown above ..., i got error report
this time also the player window just opened , and then automatically closed .

Last edited by raju.mopidevi; 01-23-2009 at 06:05 PM.
 
Old 01-26-2009, 03:09 AM   #6
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Do you know if your xserver provides XV (x video) services?

I don't know how to check if you do have this... I do know xine has a "xine-check" script that displays this. It seems as if VLC is looking for functionality that is not present in your system. Can you try a different output mode?

I. e. in mplayer, you can start it with the -vo (video output) switch. To use XV, for example:

mplayer -vo xv

I. e. try something else - I think mplayer also accepts

mplayer -vo xshm

etc... Maybe VLC has different output plugins / modes as well? Maybe some other mode will work and not crash instantly in your setup.
 
Old 03-13-2010, 06:14 AM   #7
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Original Poster
Rep: Reputation: 92
sorry i forgot to post this, I solved this by setting output as x11
mplayer -vo x11
similarly for vlc also
 
  


Reply

Tags
media, players


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Non drm/conversion "mp3 players"/portable media players Hairulfr General 5 12-12-2007 10:12 AM
I Need to Know How to make my Media Players Play Media jason.rohde Linux - Software 4 07-03-2006 07:48 AM
I Need to Know How to make my Media Players Play Media jason.rohde Linux - Software 3 07-02-2006 10:23 AM
media players pinkfae222 Linux - Newbie 7 07-15-2005 10:57 PM


All times are GMT -5. The time now is 05:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration