LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2005, 12:02 PM   #1
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,257

Rep: Reputation: 53
Problem with gcc: configure: error: C compiler cannot create executable


I get this error even though I have gcc
configure: error: C compiler cannot create executable

linux:~/ettercap-NG-0.7.2 # which gcc
/usr/bin/gcc
linux:~/ettercap-NG-0.7.2 # rpm -q gcc
gcc-3.3.4-11
linux:~/ettercap-NG-0.7.2 # ./configure
checking whether to enable maintainer-specific portions of Makefiles... no

Configuring ettercap NG-0.7.2...

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
linux:~/ettercap-NG-0.7.2 #

How do I get gcc to create executables?
 
Old 05-11-2005, 12:06 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Not sure about this, but maybe you need glibc-devel as well.
 
Old 05-11-2005, 01:09 PM   #3
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,257

Original Poster
Rep: Reputation: 53
Thanks, but I get the same error:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
linux:~/ettercap-NG-0.7.2 # rpm -q glibc
glibc-2.3.3-97
 
Old 05-11-2005, 02:49 PM   #4
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,257

Original Poster
Rep: Reputation: 53
Is it saying its not working because it can't find the file conftest.c ? How do I get that file?
Using built-in specs.
Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --enable-languages=c,c++,f77,objc,java,ada --disable-checking --libdir=/usr/lib --enable-libgcj --with-gxx-include-dir=/usr/include/g++ --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit i586-suse-linux
Thread model: posix
gcc version 3.3.4 (pre 3.3.5 20040809)
configure:2808: $? = 0
configure:2810: gcc -V </dev/null >&5
gcc: `-V' option must have argument
configure:2813: $? = 1
configure:2836: checking for C compiler default output file name
configure:2839: gcc conftest.c >&5
gcc: installation problem, cannot exec `cc1': No such file or directory
configure:2842: $? = 1
configure: failed program was:
| /* confdefs.h. */
 
Old 05-11-2005, 06:12 PM   #5
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi Abefroman,

It is saying you don't have cc1 which must be on /usr/lib/gcc-lib/<your-distrbution>/3.3.4/ directory. The file conftest.c is created by "configure" which is a shell script.

Be sure you have a recent ethercap package. This appears to be some incompatibility between your configure and the gcc compiler. The first mistake the script does is "gcc -V". I suppose the correct option is "-v" (lower case) which informs the compiler version and the directory where the compiler specs are.

You may try to hack the configure script changing the case of the option and look the result.

Good luck,

Osvaldo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: C++ compiler cannot create executables dicou Linux - Newbie 15 12-22-2012 01:00 PM
checking for C compiler default output... configure: error: C compiler cannot create fiorejm Linux - Software 6 11-12-2009 12:35 PM
configure: error: C compiler cannot create executables watashiwaotaku7 Linux - General 7 10-22-2009 09:40 AM
configure: error: installation or configuration problem: C++ compiler cannot create e abirami Linux - Software 28 01-23-2008 11:35 AM
configure: error: C compiler cannot create executables strimp099 Linux - Software 2 07-11-2005 07:23 PM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration