LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-13-2005, 04:45 PM   #1
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Rep: Reputation: 31
Question Playing WAV files in SUSE 9.3-64


Hi,

When I try to play Cd with wav files on it I got a message that it is not possible (does not matter which player I use). I have been searching if there is a thread dealing with the same problem on the forum, but I cant find any. There is no problem playing other audio files.

 
Old 08-14-2005, 10:57 PM   #2
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
What programs are you using... .wav is pretty common and most players will play them by default... have you also tried playing the wav files after copying to your HD... Never heard of the "not possible" error...?

KC
 
Old 08-15-2005, 10:31 AM   #3
mac57
Member
 
Registered: Nov 2004
Location: Texas
Distribution: openSUSE 10.3, Yoper Linux 3.0 , Arch Linux 2007.08
Posts: 253

Rep: Reputation: 30
Have you downloaded the SuSE multimedia packs? SuSE by default ships with a lot of the multimedia stuff turned off. You need to install the optional multimedia pack patches to enable them. This can be done via YOU (YaST Online Update). Once you have this done, you might want to go "whole hog" and install all the other multimedia "enablers" out there.

I found (as have numerous others) that after I had installed all of the multimedia option packs, SuSE would play .mpg and .mp3 files, but no joy on my .avi and .wmv files. I searched on the web and found that there is a site in Germany, where someone has rebuilt the relevant packages from scratch, not from "crippled source" like SuSE did. If you delete your offending media players, add this site to your list of installation sources and then re-install, all is well. This is what I did, and it worked great.

Here is the "recipe":
1) Go to YaST, Software, Change Source of Installation. Select Add, then select HTTP from the drop down list
2) Add "packman.iu-bremen.de" as the server, suse/9.3 as the directory
3) Finish out of Change Source of Installation

4) Go to YaST Install and Remove Software
5) Delete (uninstall) Kaffeine, xine-lib, xine-ui
6) Install the following (Search for each one by full or partial title and then select):
- w32codecs-all
- amarok-xine
- kaffeine
- kdemultimedia30-video-xine
- libxine1
- xine-ui
- xvid
- xvid4conf
- MPlayer
- Mplayerplug-in
7) Finish out of installing the software and then reboot

This fully resolved my issues with SuSE 9.3's multimedia limitations. I hope it helps you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Playing Media files on Suse 9.3 Murdoc Linux - Software 1 11-16-2005 10:23 PM
Perl playing .wav or .mp3 Cornholio Programming 2 05-01-2005 11:14 AM
Playing FLAC Files in Suse gemini2011 Linux - Software 15 12-20-2004 04:09 PM
playing wav files bdu Linux - General 2 02-22-2002 10:48 PM
Playing wav files bdu Linux - General 1 02-07-2002 04:22 AM


All times are GMT -5. The time now is 04:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration