LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 11-21-2005, 03:52 PM   #1
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Rep: Reputation: 30
PHP 4 and Pear on suse 10...


Hi,

I am attempting to configure Horde on my SuSE 10.0 eval box. One of the -recommended, but optional- installs is the database module for pear.

When I attempt to install this software I receive the following error:

# pear install DB
downloading DB-1.7.6.tgz ...
Starting to download DB-1.7.6.tgz (124,807 bytes)
............................done: 124,807 bytes
requires package `PEAR' >= 1.0b1
DB: Dependencies failed

I have also completely removed and reinstalled both PHP and perl from my box and continue to recieve the same error.


when I grep my installed packages I receive the following information:

#rpm -qa | grep php
php4-4.4.0-6
php4-pear-log-1.8.7-2
php4-zlib-4.4.0-6
php4-pear-4.4.0-6

# rpm -qa | grep pear
php4-pear-log-1.8.7-2
php4-pear-4.4.0-6


any ideas on where to go first?
-thanks


[edit]: general type corrections

Last edited by jsheffie; 11-21-2005 at 03:54 PM.
 
Old 12-07-2005, 07:49 AM   #2
chameleon06
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
Horde and SuSe 10

Hi
I have solved this issue so post it here hopefully no other souls have to go through the same pain. Just follow the folowing steps

1) # pear upgrade PEAR-1.3.3 ( you need to run this first as the next step required this version)
2) # pear upgrade PEAR ( this will take you to the latest PEAR version)
3) # pear channel-update "pear.php.net"
4) # pear install DB

Hope this helps
Cheers

Last edited by chameleon06; 12-07-2005 at 07:51 AM.
 
Old 03-07-2006, 07:40 AM   #3
esaylor
LQ Newbie
 
Registered: Mar 2006
Posts: 1

Rep: Reputation: 0
Hey thanks a ton for posting the fix. I've been searching all over for a way to get around that problem. Also, I had more dependency problems than you had. While trying to perform the first couple steps I received errors and had to install them as well. I found type pear install and the package name worked successfully for everyone. I know most everyone knows this, but I'm extremely new to this and so may be someone else reading, so I thought I post my 2 cents.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
urpmi and php-pear Huppybanny Linux - Newbie 9 10-19-2005 09:15 AM
pear issue with Apache 2 and PHP Jediman Mandriva 0 04-19-2005 01:31 PM
php pear problem craddy Linux - Software 4 11-09-2004 09:25 PM
Trouble with PHP & Pear Gerardoj Programming 0 10-17-2004 04:30 PM
php pear quickforms question BaerRS Programming 1 02-19-2004 07:07 PM


All times are GMT -5. The time now is 11:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration