LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-24-2005, 10:49 AM   #1
SchadeBoy
Member
 
Registered: Jun 2004
Location: Sierra Vista, AZ
Distribution: SUSE 10.0 OSS
Posts: 143

Rep: Reputation: 15
Permanent modprobe solution. But is it messy?


Hello, everyone.

As some of you may recall, I was having trouble with my nVidia drivers properly displaying on my screen. I was getting colored vertical lines on the right side, and a replication of the top 1/8th of my screen on the bottom. The image of the problem is located here.

I found a solution to my problem on the nVidia news forum, which worked. The solution was to use the modprobe command to insert the nvidia driver into the kernel (that is, if I'm understanding the way modprobe is used). This would require me to go to a terminal screen prior to loading my GUI. The command sequence went like this:

rmmod nvidia
modprobe --first-time -v nvidia NVreg_Mobile=0

I could then exit from my root login and the KDM would automatically start up. I had to make a slight modification to my screen horizontal and vertical refresh rates in the xorg.conf file, but after that, it works fine.

The problem was that this method only worked for that session. If I shut down or rebooted, I'd have to repeat the procedure (except the part about modifying my xorg.conf file). So I went looking for a solution to make it automatic. I found one here.

The solution I found was to modify my lc.local file under /etc/lc.d. Except that I don't have that file. But I did find a boot.local file. I added the rmmod and modprobe commands in the sequence listed above. This solved my problem. I no longer have to do this whole thing manually.

However, to me this seems a bit messy. I can't help but shake the feeling that there's a better, more efficient, and maybe even more stable way of doing this. I'm just a noob to Linux, though. I could be wrong.

Anyone have any thoughts, comments, or suggestions?

Thanks.
 
Old 09-26-2005, 03:27 AM   #2
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
try YAST===>system ==etc/sysconfig editor==kernel>===>modules_loaded_on_boot

enter your module name

Now it should be loaded automatically next time you boot.

Cheers

-K
 
Old 09-26-2005, 11:44 AM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Try editing the /etc/modules.conf file and putting the line.

Code:
options nvidia NVreg_Mobile=0
Then rebooting after having commented out the modifications you have made in your local file to see if it will use the option for the module.
 
Old 09-26-2005, 12:23 PM   #4
SchadeBoy
Member
 
Registered: Jun 2004
Location: Sierra Vista, AZ
Distribution: SUSE 10.0 OSS
Posts: 143

Original Poster
Rep: Reputation: 15
1Kyle - I tried your suggestion this morning. I added the option you suggested in the modules_loaded_on_boot location, then commented out the additions I made to the boot.local file and rebooted. The question I have, I guess is do I place just the module name there, or do I need the entire line? I put just the module name along with the NVreg_Mobile=0 switch and it didn't work. That's all I had time to try before I had to leave for work.

HappyTux - I'll try your idea this evening, too. Thanks for the suggestion.
 
Old 09-26-2005, 10:52 PM   #5
SchadeBoy
Member
 
Registered: Jun 2004
Location: Sierra Vista, AZ
Distribution: SUSE 10.0 OSS
Posts: 143

Original Poster
Rep: Reputation: 15
HappyTux - your solution worked. Except I don't have a modules.conf file in the location you specified. I did, however, find a modprobe.conf file in there. That file states that any custom entries be added to the modprobe.conf.local file. I entered the code as you suggested and rebooted. So far, things are working great.

If there are other suggestions that might be even better, please let me know. For now, I feel like I'm doing good and hope to keep on Linuxing.

Thanks again!
 
Old 09-26-2005, 11:57 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally posted by SchadeBoy
HappyTux - your solution worked. Except I don't have a modules.conf file in the location you specified. I did, however, find a modprobe.conf file in there. That file states that any custom entries be added to the modprobe.conf.local file. I entered the code as you suggested and rebooted. So far, things are working great.

If there are other suggestions that might be even better, please let me know. For now, I feel like I'm doing good and hope to keep on Linuxing.

Thanks again!
Good to hear it is working, the file names would just be different between distros that is the right place to be putting the options as that is what it is telling you to do.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Searching 4 Permanent solution for the mp3 loudness erickFis Linux - Software 5 07-04-2006 08:19 PM
Messy OpenGL djib Linux - Software 5 04-24-2005 04:53 PM
Permanent solution for the mp3 loudness erickFis LinuxQuestions.org Member Success Stories 0 02-02-2005 05:31 AM
Load module permanent (modprobe) Beuzekom Linux - Newbie 2 01-24-2004 09:05 AM
A messy house psyklops Linux - General 3 05-19-2002 02:17 PM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration