LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Permanent modprobe solution. But is it messy? (http://www.linuxquestions.org/questions/suse-novell-60/permanent-modprobe-solution-but-is-it-messy-366560/)

SchadeBoy 09-24-2005 10:49 AM

Permanent modprobe solution. But is it messy?
 
Hello, everyone.

As some of you may recall, I was having trouble with my nVidia drivers properly displaying on my screen. I was getting colored vertical lines on the right side, and a replication of the top 1/8th of my screen on the bottom. The image of the problem is located here.

I found a solution to my problem on the nVidia news forum, which worked. The solution was to use the modprobe command to insert the nvidia driver into the kernel (that is, if I'm understanding the way modprobe is used). This would require me to go to a terminal screen prior to loading my GUI. The command sequence went like this:

rmmod nvidia
modprobe --first-time -v nvidia NVreg_Mobile=0

I could then exit from my root login and the KDM would automatically start up. I had to make a slight modification to my screen horizontal and vertical refresh rates in the xorg.conf file, but after that, it works fine.

The problem was that this method only worked for that session. If I shut down or rebooted, I'd have to repeat the procedure (except the part about modifying my xorg.conf file). So I went looking for a solution to make it automatic. I found one here.

The solution I found was to modify my lc.local file under /etc/lc.d. Except that I don't have that file. But I did find a boot.local file. I added the rmmod and modprobe commands in the sequence listed above. This solved my problem. I no longer have to do this whole thing manually.

However, to me this seems a bit messy. I can't help but shake the feeling that there's a better, more efficient, and maybe even more stable way of doing this. I'm just a noob to Linux, though. I could be wrong.

Anyone have any thoughts, comments, or suggestions?

Thanks.

1kyle 09-26-2005 03:27 AM

try YAST===>system ==etc/sysconfig editor==kernel>===>modules_loaded_on_boot

enter your module name

Now it should be loaded automatically next time you boot.

Cheers

-K

HappyTux 09-26-2005 11:44 AM

Try editing the /etc/modules.conf file and putting the line.

Code:

options nvidia NVreg_Mobile=0
Then rebooting after having commented out the modifications you have made in your local file to see if it will use the option for the module.

SchadeBoy 09-26-2005 12:23 PM

1Kyle - I tried your suggestion this morning. I added the option you suggested in the modules_loaded_on_boot location, then commented out the additions I made to the boot.local file and rebooted. The question I have, I guess is do I place just the module name there, or do I need the entire line? I put just the module name along with the NVreg_Mobile=0 switch and it didn't work. That's all I had time to try before I had to leave for work.

HappyTux - I'll try your idea this evening, too. Thanks for the suggestion.

SchadeBoy 09-26-2005 10:52 PM

HappyTux - your solution worked. Except I don't have a modules.conf file in the location you specified. I did, however, find a modprobe.conf file in there. That file states that any custom entries be added to the modprobe.conf.local file. I entered the code as you suggested and rebooted. So far, things are working great.

If there are other suggestions that might be even better, please let me know. For now, I feel like I'm doing good and hope to keep on Linuxing.

Thanks again!

HappyTux 09-26-2005 11:57 PM

Quote:

Originally posted by SchadeBoy
HappyTux - your solution worked. Except I don't have a modules.conf file in the location you specified. I did, however, find a modprobe.conf file in there. That file states that any custom entries be added to the modprobe.conf.local file. I entered the code as you suggested and rebooted. So far, things are working great.

If there are other suggestions that might be even better, please let me know. For now, I feel like I'm doing good and hope to keep on Linuxing.

Thanks again!

Good to hear it is working, the file names would just be different between distros that is the right place to be putting the options as that is what it is telling you to do.


All times are GMT -5. The time now is 12:23 AM.