LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 07-16-2008, 12:50 PM   #1
linux_junky
Member
 
Registered: Feb 2004
Location: Upstate New York
Distribution: openSUSE Linux 10.2
Posts: 83

Rep: Reputation: 15
openSUSE 11.0 x86_64; No sound in Skype 2.0.x


Hello,

Has anyone gotten Skype 2.0.x to work in openSUSE 11.0 x86_64?

(So far, I've installed the 'static' version and when I call, it indicates there is a problem with sound.)

Obviously, it's a 32-bit app running in 64-bit so I suspect it's not finding certain libraries.

Any guidance would be appreciated.

Thanks in advance.
 
Old 07-17-2008, 12:02 AM   #2
df6269
LQ Newbie
 
Registered: Jul 2008
Location: Taiwan
Distribution: openSUSE 10.3, 11.0, FreeBSD 6.3, 7.0, OpenBSD 4.1
Posts: 26

Rep: Reputation: 15
I also run skype 2.0.x static version in openSUSE 11 x86_64 but i can speak and listen when call out via skype.
Can you output more message when run skype by command?
 
Old 07-18-2008, 08:41 AM   #3
stasik
Member
 
Registered: Dec 2005
Location: dublin
Distribution: suse 11.3, 64 bit
Posts: 126

Rep: Reputation: 15
when i use skype on my suse 11.0 64 bit i can hear but i can not use microfon. when i connect microfon i can hear my voice in the speakers (so microfon is working ok and is connected ok) bu on the other end cant hear me.i even tried a soft to record my voice and no luck...
 
Old 07-18-2008, 03:56 PM   #4
linux_junky
Member
 
Registered: Feb 2004
Location: Upstate New York
Distribution: openSUSE Linux 10.2
Posts: 83

Original Poster
Rep: Reputation: 15
stderr for loading skype from cli

ALSA lib control.c:874snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib pcm.c:2104snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib control.c:874snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib control.c:874snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so

Any ideas?
 
Old 07-18-2008, 05:50 PM   #5
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
Start alsamixer from the command line. Press tab to bring up the capture field.

Use the right arrow key to highlight the mic column. Make sure L R CAPTUR is red. If not, press the space bar.

Use the right arrow key to move to the capture column. Raise the gain level at least past half way with the up arrow key. Press space to add the red L R CAPTUR indication to this column.

Press esc to quit. Try the mic again. HTH

Last edited by pilotgi; 07-18-2008 at 07:46 PM. Reason: First post was relevant to 10.3
 
Old 07-19-2008, 07:00 AM   #6
linux_junky
Member
 
Registered: Feb 2004
Location: Upstate New York
Distribution: openSUSE Linux 10.2
Posts: 83

Original Poster
Rep: Reputation: 15
no prob with (64-bit) sound in general

I have no problem with sound--it's only when placing a call that the callee cannot hear me.
Thanks
 
Old 07-22-2008, 03:56 AM   #7
stasik
Member
 
Registered: Dec 2005
Location: dublin
Distribution: suse 11.3, 64 bit
Posts: 126

Rep: Reputation: 15
i think this is what we get for using 64 bit. i dont think there is a fix, but i wish
 
Old 07-30-2008, 11:22 PM   #8
tof@usa
LQ Newbie
 
Registered: Jul 2008
Location: Pennsylvaina
Distribution: Slackware
Posts: 1

Rep: Reputation: 0
Hi I'm new. Does the alsamixer have a fork to 'alsactrl'? It would be nice (after making some changes to the mixer) to just press a key or two to do an 'alsactrl store'. I have the sound blaster live! and for some reason (maybe after compiling a new kernel) my default microphone changes from mic1 to mic2. Leaving Skype with no microphone input.
Please forgive me if I've posted in the wrong area. I'll catch-on quickly (I hope) :^)
 
Old 02-14-2009, 04:26 PM   #9
Kemron
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 1
Skype OpenSuse 11 Microphone problem?

Hi there,

Here is the solution that worked for me:

First: Uninstall the whole pulseaudio except from libpulse0 (in Yast)

Second: Go to Sound [Computer -> More Applications] and under Devices change all first four settings to Alsa and the fifth to HDA Intel (Alsa mixer)
Then switch from Devices to Sounds and tick Enable software sound mixing

Third: In [Computer -> More Aplcations] find Volume Control and in HDA Intel (Alsa mixer) -> Playback -> make sure that Mic Boost is high enough. Then go from Playback into Recording and make sure that both Capture settings are set to the top

Then when you go to Skype preferences -> Audio settings -> the top one will be HDA Intel (hw:Intel,0), second one HDA Intel (hw:Intel,0) and the third will be HDA Intel (plughw:Intel,0)

I hope this helps as it did help me...

Good luck.
Tom

Last edited by Kemron; 02-14-2009 at 04:32 PM.
 
Old 06-02-2009, 12:44 AM   #10
fritz_p
LQ Newbie
 
Registered: Dec 2008
Location: buenos aires
Distribution: opensuse 10.3, opensuse 11.0, fedora 10
Posts: 26
Blog Entries: 1

Rep: Reputation: 15
this worked for me

Quote:
Originally Posted by pilotgi View Post
Start alsamixer from the command line. Press tab to bring up the capture field.

Use the right arrow key to highlight the mic column. Make sure L R CAPTUR is red. If not, press the space bar.

Use the right arrow key to move to the capture column. Raise the gain level at least past half way with the up arrow key. Press space to add the red L R CAPTUR indication to this column.

Press esc to quit. Try the mic again. HTH
Hi pilotgi, thanks, this worked for me!!!

Do you know if I could have changed this with kmix?

Does anybody know why can't a program like skype check this for me?
Or why would I want L R CAPTUR off as a default?
My solution had been to install another linux distro, opensuse 11.0, so that some things work in 10.3, some in 11, some with ubuntu, etc...,
and my webcam with windows XP, unfortuantely.
Very instructive, but not really the way it should be.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with skype install opensuse 11 crees Linux - Software 4 07-19-2008 01:16 PM
downloading opensuse 10.3 x86_64 abhattacharya Suse/Novell 8 05-18-2008 02:03 PM
problem to install skype on opensuse 10.2 dissident_goodchild Suse/Novell 20 10-22-2007 08:28 AM
Skype on Suse 10.2 x86_64 plk Suse/Novell 5 10-13-2007 11:37 AM
install skype on mandriva x86_64 neo571 Mandriva 1 05-13-2007 07:35 AM


All times are GMT -5. The time now is 07:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration