LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   openSUSE 11.0 x86_64; No sound in Skype 2.0.x (http://www.linuxquestions.org/questions/suse-novell-60/opensuse-11-0-x86_64%3B-no-sound-in-skype-2-0-x-656164/)

linux_junky 07-16-2008 12:50 PM

openSUSE 11.0 x86_64; No sound in Skype 2.0.x
 
Hello,

Has anyone gotten Skype 2.0.x to work in openSUSE 11.0 x86_64?

(So far, I've installed the 'static' version and when I call, it indicates there is a problem with sound.)

Obviously, it's a 32-bit app running in 64-bit so I suspect it's not finding certain libraries.

Any guidance would be appreciated.

Thanks in advance.

df6269 07-17-2008 12:02 AM

I also run skype 2.0.x static version in openSUSE 11 x86_64 but i can speak and listen when call out via skype.
Can you output more message when run skype by command?

stasik 07-18-2008 08:41 AM

when i use skype on my suse 11.0 64 bit i can hear but i can not use microfon. when i connect microfon i can hear my voice in the speakers (so microfon is working ok and is connected ok) bu on the other end cant hear me.i even tried a soft to record my voice and no luck...

linux_junky 07-18-2008 03:56 PM

stderr for loading skype from cli
 
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib pcm.c:2104:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so

Any ideas?

pilotgi 07-18-2008 05:50 PM

Start alsamixer from the command line. Press tab to bring up the capture field.

Use the right arrow key to highlight the mic column. Make sure L R CAPTUR is red. If not, press the space bar.

Use the right arrow key to move to the capture column. Raise the gain level at least past half way with the up arrow key. Press space to add the red L R CAPTUR indication to this column.

Press esc to quit. Try the mic again. HTH

linux_junky 07-19-2008 07:00 AM

no prob with (64-bit) sound in general
 
I have no problem with sound--it's only when placing a call that the callee cannot hear me.
Thanks

stasik 07-22-2008 03:56 AM

i think this is what we get for using 64 bit. i dont think there is a fix, but i wish

tof@usa 07-30-2008 11:22 PM

Hi I'm new. Does the alsamixer have a fork to 'alsactrl'? It would be nice (after making some changes to the mixer) to just press a key or two to do an 'alsactrl store'. I have the sound blaster live! and for some reason (maybe after compiling a new kernel) my default microphone changes from mic1 to mic2. Leaving Skype with no microphone input.
Please forgive me if I've posted in the wrong area. I'll catch-on quickly (I hope) :^)

Kemron 02-14-2009 04:26 PM

Skype OpenSuse 11 Microphone problem?
 
Hi there,

Here is the solution that worked for me:

First: Uninstall the whole pulseaudio except from libpulse0 (in Yast)

Second: Go to Sound [Computer -> More Applications] and under Devices change all first four settings to Alsa and the fifth to HDA Intel (Alsa mixer)
Then switch from Devices to Sounds and tick Enable software sound mixing

Third: In [Computer -> More Aplcations] find Volume Control and in HDA Intel (Alsa mixer) -> Playback -> make sure that Mic Boost is high enough. Then go from Playback into Recording and make sure that both Capture settings are set to the top

Then when you go to Skype preferences -> Audio settings -> the top one will be HDA Intel (hw:Intel,0), second one HDA Intel (hw:Intel,0) and the third will be HDA Intel (plughw:Intel,0)

I hope this helps as it did help me...:)

Good luck.
Tom

fritz_p 06-02-2009 12:44 AM

this worked for me
 
Quote:

Originally Posted by pilotgi (Post 3219318)
Start alsamixer from the command line. Press tab to bring up the capture field.

Use the right arrow key to highlight the mic column. Make sure L R CAPTUR is red. If not, press the space bar.

Use the right arrow key to move to the capture column. Raise the gain level at least past half way with the up arrow key. Press space to add the red L R CAPTUR indication to this column.

Press esc to quit. Try the mic again. HTH

Hi pilotgi, thanks, this worked for me!!!

Do you know if I could have changed this with kmix?

Does anybody know why can't a program like skype check this for me?
Or why would I want L R CAPTUR off as a default?
My solution had been to install another linux distro, opensuse 11.0, so that some things work in 10.3, some in 11, some with ubuntu, etc...,
and my webcam with windows XP, unfortuantely.
Very instructive, but not really the way it should be.


All times are GMT -5. The time now is 06:49 PM.