LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-18-2007, 11:46 AM   #1
ln3wb13
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Rep: Reputation: 0
Question openSUSE 10.2 vmware tools issue (vmware fusion)


Hello,
I'm running vmware fusion on a macbook pro. I installed opensuse 10.2, and I'm trying to install the vmware tools. I've got the tools in the guest OS, but when I run the vmware-config-tools.pl, it detects that the kernel headers don't match the updated kernel.

I've installed gcc and all available updates, but my kernel headers don't match the installed kernel:

rpm -qa | grep kernel:

linux-kernel-headers-2.6.18.2-3
kernel-default-2.6.18.8-0.5

I can't find any kernel headers online or through Yast that match my updated kernel. Any suggestions?

Thanks,

CH

--------------------------------

I added four other repositories to yast, and none of them had updated kernel headers ( i was searching for kernel-source in yast). I'm still at:

linux-kernel-headers-2.6.18.2-3
kernel-default-2.6.18.8-0.5

I tried manually installing kernel-source-2.6.18.8.....rpm from the web, and yast gives me an error saying that this would conflict with kernel-source-2.6.18.8-0.5 that's currently installed. I'm not sure why the 8-0.5 header files aren't installed as well.

CH

Last edited by ln3wb13; 09-18-2007 at 06:12 PM.
 
Old 09-19-2007, 05:59 PM   #2
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
I think the opensuse folks forgot to publish an updated linux-headers package or it isn't necessary. You need to configure an update repository and update the kernel and kernel-source packages through it.

Last edited by auxsvr; 09-19-2007 at 06:03 PM.
 
Old 09-20-2007, 12:11 PM   #3
ln3wb13
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks. I updated the kernel-source package and then got:

kernel-source-2.6.18.8-0.5
kernel-default-2.6.18.8-0.5
linux-kernel-headers-2.6.18.2-3

Then the vmware tools ran fine. Thanks for the response.

CH
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: VMware Unveils VMware Tools as Open Source Software LXer Syndicated Linux News 0 09-12-2007 04:10 AM
vmware fusion conanm4 Linux - General 0 08-01-2007 12:27 AM
vmware server 2.5 Vmware tools in slackware 12 mr_sarge Slackware 5 07-18-2007 07:14 AM
VMWare - Installing VMWare Tools Nightmare jerkmonkee Linux - Newbie 2 11-14-2004 06:52 PM
vmware, mandrake 9.0 (finding vmware tools) Gratz Linux - Software 2 03-01-2004 01:03 PM


All times are GMT -5. The time now is 07:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration