LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2006, 08:16 AM   #1
damm
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Rep: Reputation: 0
Online Kernel update - now can't boot!


Hello,

Yesterday I was looking for a package on the Yast Online update. The default screen came up that I should install a range of security related packages... so I did (dumb?)

one was linux kernel update (I am running Suse 10.0). A message popped up that if I was running lilo, I needed to do something. I didn't configure the machine, so I don't know if I am running lilo...

I typed lilo at the sbin prompt, and got the message etc/lilo.cfg not found. so, I assumed I was not using lilo (dumb again?)

this morning when it boots it goes to the page where you choose suse 10, safe mode, etc. when I let it run on suse 10 it boots to a shell prompt. NO SUSE. What did I do, and how can I fix it?

argh.

 
Old 02-15-2006, 08:30 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
If you are looking for packages to install, use "Software Managment" instead of "Online Update"

Booting to a shell prompt doesn't mean "NO SUSE". You may only have a problem with the X server. Maybe you need to reinstall the driver for your graphics card. The NVIDIA driver can be installed from command-line YaST -> Online update. You could also run sax2 to reconfigure the graphics card.

If this isn't possible, try to provide a little more information at which stage you can't proceed (e.g. messages on the screen).
 
Old 02-15-2006, 08:48 AM   #3
damm
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Hi,

thanks for the help. when I boot the last messages are...
kernel 2.6.13-15.8-smp
skipped services in runlevel 5: smbfs mfs splash

it i login as root I can get to yast, but when I try online update it says the network connection is not working. Usually I need to open a browser window and enter my corporate domain and password before I try launching yast. without suse up, how could I do this?

Also, the graphics card issue... the packages I was after yestday were dependancies for gmsh. one of them was OpenGl. There was a free version that I tried to get from mesa3, but think it did not install right. sounds like this could be related!
 
Old 02-15-2006, 08:55 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Do you have an installation medium of SUSE or do you rely on the internet connection?
If you have a CD/DVD, try to reinstall the kernel package. This will restore the previous kernel version and hopefully solve the problems coming from the update.
 
Old 02-15-2006, 09:04 AM   #5
damm
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
I have a both dvd and cds. I tried mount /dev/dvd, and nothing happened?
 
Old 02-15-2006, 09:10 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Don't mount the DVD, just make sure you have it listed in "Installation source"
 
Old 02-15-2006, 09:16 AM   #7
damm
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Ok, yast shows it as being the source. now what?
software management
installation in to dir
media check
pathch cd update
system update
virtual machine installation

or... if I re-boot, I can select:
boot from hard disk
installation
installatin - acpi disabled
installation - safe settings
rescue system
memory test...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 10:27 AM
YaST Online Update(YOU) Kernel Update? batorma Linux - Newbie 9 10-30-2005 03:17 AM
9.2 Pro won't boot into GUI after YOU (online update) Steerpike Suse/Novell 3 11-27-2004 06:53 PM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 11:01 AM
YaST Online Update + AMD kernel patch = kernel panic THX1138 Linux - General 3 10-26-2003 04:25 PM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration